PDA

View Full Version : SLED 11 SP: Videos for blind people only? Codecs (avi, DivX)



Lina33
19-Dec-2011, 17:56
Hi all,
I am a beginner with Linux. To enjoy my video collection (mpeg4, DivX,
avi) I installed VLC my favorite video player. It works only as an audio
player!!! No pictures, but perfect sound. Error message about missing
codec. I tried Xine too, but it was even worse. all so-called codec
packages from the web did not help. SO PLEASE tell me what to do which
package to install...
Thank You very much! Lina33


--
Lina33
------------------------------------------------------------------------
Lina33's Profile: http://forums.novell.com/member.php?userid=121439
View this thread: http://forums.novell.com/showthread.php?t=449781

mikewillis
19-Dec-2011, 20:06
The first thing I'd do is remove all the packages you've installed thus
far and remove any repositories you've added.

The easiest way to get extra codec support is to add gstreamer plugins
packages. You can then use the default media players like Totem and
Banshee, or anything that uses gstreamer as a backend.

The way I give gstreamer more codecs is described at 'Additional
multimedia codec support for SLED 11 SP1 | Novell User Communities'
(http://www.novell.com/communities/node/13146/additional-multimedia-codec-support-sled-11-sp1)
It's by no means the easiest method but what I perceive to be the
benefits of it over other methods are described in the article.

You can also use the Packman essentials repo. This method is easiest to
set up but it does mean you're replacing a bunch of packages provided in
SLED with ones from a third party. Often doing that is fine, sometimes
you can get weird unpredictable and undesirable results. The relevant
repo doesn't seem to be locatable via their website right now (or
perhaps I didn't look in the right way, sure I've found it before,
anyway...) but you can add it like this

Code:
--------------------
$ su -
$ cd /etc/zypp/repos.d
$ wget http://packman.inode.at/suse/sle_11_sp1/Essentials/packman-essentials.repo
$ zypper in gstreamer-0_10-ffmpeg gstreamer-0_10-plugins-ugly
--------------------

At this point you will be told that what you're trying to do isn't
going to work and given three options. Choose the option which causes
the packages to change vendors.


--
mikewillis
------------------------------------------------------------------------
mikewillis's Profile: http://forums.novell.com/member.php?userid=7510
View this thread: http://forums.novell.com/showthread.php?t=449781