PDA

View Full Version : How to reactivate Gnome?



mrspedag2
11-Jun-2015, 19:31
I am using SLES 12 and have changed the DISPLAYMANAGER from gdm to console, to do some work. I thought, change the file displaymanger back to gdm, the Gnome will start after reboot. The system still booting in console mode.
How can I activate Gnome starting automatically?

Thx for info

mrspedag2
12-Jun-2015, 10:00
I reply myself: startin' yast in console mode, and enable the service. Startin' via yast - no problem. GUI is usable.
After the reboot, the displaymanager doesn't start the gui. Checking the services manager the display-manager ist Enabled/Inactive. How can I change that the display-manager will started Enabled & active?

malcolmlewis
12-Jun-2015, 12:33
On Fri 12 Jun 2015 09:04:01 AM CDT, mrspedag2 wrote:


I reply myself: startin' yast in console mode, and enable the service.
Startin' via yast - no problem. GUI is usable.
After the reboot, the displaymanager doesn't start the gui. Checking the
services manager the display-manager ist Enabled/Inactive. How can I
change that the display-manager will started Enabled & active?




Hi
To set the graphical session to start (aka init/runlevel 5);


systemctl set-default graphical.target


For console session to start (aka init/runlevel 3);


systemctl set-default multi-user.target


You can press ctrl+alt+F1 to get to a console, press alt+ctl+F7 to get
back to the GUI.

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.39-47-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

mrspedag2
15-Jun-2015, 09:51
Thx for the reply: the shortcuts running fine...
I have started the gdm with yast--> service Manager. Setting the default: systemctl set-default multi-user.target.
Rebooted the system. Unfortunately the gdm is not started.
See the yast service manager display manger: Disable/Inactiv:
107

Another idea?

malcolmlewis
15-Jun-2015, 15:32
Hi
Disabled is correct, if you tab to the 'D' for details, what does it say?

And if you use YaST /etc/sysconfig editor and check under Desktop -> Display manager -> DISPLAYMANAGER this is set to gdm?