PDA

View Full Version : install-suse-cloud & proxy



quentinsourice
24-Jun-2015, 16:33
Hi,

I'm deploying a Suse OpenStack Cloud 5 but facing a proxy problem.

If I activate my proxy settings, without forgetting to add my administration server's ip & hostname in the "no proxy" part :
--> The install-suse-cloud script seems to avoid the "no proxy" configuration in the chef "knife" part :


Where should I put the config file? [/root/.chef/knife.rb]
Please enter the chef server URL: [http://suse01a.local:4000]
Please enter a clientname for the new client: [root]
Please enter the existing admin clientname: [chef-webui]
Please enter the location of the existing admin client's private key: [/etc/chef/webui.pem]
Please enter the validation clientname: [chef-validator]
Please enter the location of the validation key: [/etc/chef/validation.pem]
Please enter the path to a chef repository (or leave blank): Creating initial API user...
ERROR: Server returned error for http://suse01a.local:4000/clients, retrying 1/5 in 4s

From this step, a wget http://suse01a.local:4000/clients will return a good request


If I deactivate my proxy settings, the knife part is ok but as I'm running without my proxy, in this case zypper seems to fail somewhere...


[2015-06-24T17:32:04+02:00] ERROR: Running exception handlers
[2015-06-24T17:32:04+02:00] FATAL: Saving node information to /var/chef/cache/failed-run-data.json
[2015-06-24T17:32:04+02:00] ERROR: Exception handlers complete
[2015-06-24T17:32:04+02:00] FATAL: Stacktrace dumped to /var/chef/cache/chef-stacktrace.out
[2015-06-24T17:32:04+02:00] FATAL: Chef::Exceptions::Package: package[rsyslog] (logging::server line 17) had an error: Chef::Exceptions::Package: zypper failed - #<Process::Status: pid 4438 exit 4>!



Somebody ?

Thank you by advance,
Quentin

Automatic reply
29-Jun-2015, 05:30
quentinsourice,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team
http://forums.suse.com

jniedergang
29-Jun-2015, 09:38
Hello Quentin,

It looks like you have a problem with the access to repositories set on your admin node.
How do you provision repositories to your SUSE Cloud admin installation? (SMT, SUSE Manager...?)
What is displayed in /etc/crowbar/provisioner.json ?

Thank you


Hi,

I'm deploying a Suse OpenStack Cloud 5 but facing a proxy problem.

If I activate my proxy settings, without forgetting to add my administration server's ip & hostname in the "no proxy" part :
--> The install-suse-cloud script seems to avoid the "no proxy" configuration in the chef "knife" part :


Where should I put the config file? [/root/.chef/knife.rb]
Please enter the chef server URL: [http://suse01a.local:4000]
Please enter a clientname for the new client: [root]
Please enter the existing admin clientname: [chef-webui]
Please enter the location of the existing admin client's private key: [/etc/chef/webui.pem]
Please enter the validation clientname: [chef-validator]
Please enter the location of the validation key: [/etc/chef/validation.pem]
Please enter the path to a chef repository (or leave blank): Creating initial API user...
ERROR: Server returned error for http://suse01a.local:4000/clients, retrying 1/5 in 4s

From this step, a wget http://suse01a.local:4000/clients will return a good request


If I deactivate my proxy settings, the knife part is ok but as I'm running without my proxy, in this case zypper seems to fail somewhere...


[2015-06-24T17:32:04+02:00] ERROR: Running exception handlers
[2015-06-24T17:32:04+02:00] FATAL: Saving node information to /var/chef/cache/failed-run-data.json
[2015-06-24T17:32:04+02:00] ERROR: Exception handlers complete
[2015-06-24T17:32:04+02:00] FATAL: Stacktrace dumped to /var/chef/cache/chef-stacktrace.out
[2015-06-24T17:32:04+02:00] FATAL: Chef::Exceptions::Package: package[rsyslog] (logging::server line 17) had an error: Chef::Exceptions::Package: zypper failed - #<Process::Status: pid 4438 exit 4>!



Somebody ?

Thank you by advance,
Quentin