PDA

View Full Version : Problem registering



niroca
01-Jul-2015, 11:41
Hello forum,
I've got a problem to register our SLES12 server.
We want to change from SLES11 to SLES12. For this reason I want to setup a new SLES12 server (VMWARE) for testing.

I can not register from the first setup, because we use proxy servers for internet and I did not find any proxy-configuration in the first setup.
After the first boot with proxy settings I can reach the internet with wget, so the network setup works as I want.
But if I start to register (yast or console) I get this error:

sles12-tst:/tmp # SUSEConnect -r [regcode] -e [email] -u https://scc.suse.com
SUSEConnect error: OpenSSL::SSL::SSLError: SSL_connect SYSCALL returned=5 errno=0 state=SSLv2/v3 read server hello A
sles12-tst:/tmp #

This is not a vmware-issue, because I have the same behavior with a hardware server.
I also tried a upgrade from SLES11.3 to SLES12 and this works!


The server is setup in a minimal configuration (terminal only).
I already searched this forum and asked google, but I found no solution about that.

Do you have any hints for me for debugging or any solutions?


Regards,
Rolf

niroca
01-Jul-2015, 15:12
I found the solution!
Here it comes, maybe someone has got the same problem:

I just tried
sles12-tst:/tmp # SUSEConnect -r [regcode] -e [email] -u https://scc.suse.com --debug

and I found in the following output:

opening connection to [proxy-ip]:80...
opened
starting SSL for [proxy-ip]...
SSL established

BUT: the proxy-port for ssl in our LAN is 443!

so I checked the settings:

sles12-tst:~ # set | grep -i proxy
http_proxy=http://[proxy-ip]:80
https_proxy=http://[proxy-ip]:443

This is ok for me, but not for the script.

And this is the solution:
it seems that the register script uses only the http_proxy Setting and not the https_proxy.

I just had to change the value
sles12-tst:~ # export http_proxy=http://[proxy-ip]:443


run the register script again
sles12-tst:~ # SUSEConnect -r [regcode] -e [email] -u https://scc.suse.com
Registered SLES 12 x86_64
To server: https://scc.suse.com
Using E-Mail: [email]
sles12-tst:~ #

That's it. Seems like a bug to me....

Regards,
Rolf

jmozdzen
01-Jul-2015, 15:23
Hi Rolf,

thank you for reporting your solution, too.

It'd indeed be a bug if the script uses http_proxy for HTTPS traffic, despite the explicitly set https_proxy variable. Would you mind opening a SR for this, as these forums are not monitored by SUSE officials?

Regards,
Jens

niroca
01-Jul-2015, 15:34
Hi Jens,
I will try that.
But I am not sure, if I am able to, because we only have a license model without any support...

Regards,
Rolf

niroca
01-Jul-2015, 15:53
Just sent a bug Report to SUSE

Regards,
Rolf

niroca
02-Jul-2015, 09:59
Another update:
this happens too, if you want to add Extensions:
Yast -- Support -- SUSE Customer Center Configuration -- Select Extensions

Solution: Exit yast,
set the http_proxy to according SSL-port
sles12-tst:~ # export http_proxy=http://[proxy-ip]:443


Try again, it will work.

Regards,
Rolf

jmozdzen
02-Jul-2015, 10:40
Hi Rolf,

thank you for taking your time to report this. I've asked my SUSE contacts if this is a known problem, let's see what they'll have to say...

Best regards,
Jens