PDA

View Full Version : SLES 11SP3 looking for specific kernel



isaez
24-Jul-2015, 08:18
Hi,

I've a SuSe Enterprise 11SP3 64 bit and need to dowload a specfific kernel version: 3.0.101-0.15. At the moment we have an higher version. Is it possible to get (or download) and older version with zypper??

regards,

Ivan

thsundel
24-Jul-2015, 08:38
Hi,

I've a SuSe Enterprise 11SP3 64 bit and need to dowload a specfific kernel version: 3.0.101-0.15. At the moment we have an higher version. Is it possible to get (or download) and older version with zypper??

regards,

Ivan

See here, at the bottom there is an example how to downgrade the kernel: https://www.novell.com/support/kb/doc.php?id=7014823

Thomas

isaez
24-Jul-2015, 09:05
Thomas,

Thank you for your reply. I've tried to download the package but I get not found:

zypper in --oldpackage --download-only kernel-default=3.0.101-0.15.1
Refreshing service 'nu_novell_com'
Loading repository data....
..
Package 'kernel-default-3.0.101-0.15.1' not found

Strangely enough I get an "Unknown option '--no-refresh'" if I add --no-refresh but zypper knows the option.

And the url to download the kernel (http://download.novell.com/Download?buildid=X-K27cpMfVQ~) shows me only 3.0.101-0.21 kernels. Is there some other url where the 3.0.101-0.15 can be found?

regards,

Ivan

thsundel
24-Jul-2015, 09:15
Thomas,

Thank you for your reply. I've tried to download the package but I get not found:

zypper in --oldpackage --download-only kernel-default=3.0.101-0.15.1
Refreshing service 'nu_novell_com'
Loading repository data....
..
Package 'kernel-default-3.0.101-0.15.1' not found

Strangely enough I get an "Unknown option '--no-refresh'" if I add --no-refresh but zypper knows the option.

And the url to download the kernel (http://download.novell.com/Download?buildid=X-K27cpMfVQ~) shows me only 3.0.101-0.21 kernels. Is there some other url where the 3.0.101-0.15 can be found?

regards,

Ivan

Here is the URL for that specific kernel: https://download.suse.com/Download?buildid=5Vh7boLCyOQ~

Thomas

thsundel
24-Jul-2015, 09:26
Here is the URL for that specific kernel: https://download.suse.com/Download?buildid=5Vh7boLCyOQ~

Thomas

You could also try enabling multiversion support: https://www.suse.com/documentation/sles11/book_sle_tuning/data/cha_tuning_multikernel_enable.html

Thomas

isaez
24-Jul-2015, 11:56
Thomas,

Thanks for your support. I've downloaded the 3.0.101-0.15 rpm kernel files and will apply them. For now I want look at multiversion as I'm in a hurry but I'll give it a try in the near future.

regards,

Ivan