PDA

View Full Version : samba-tool on SLES 12



klausj66
27-Jul-2015, 17:33
I want to migrate our classic Samba 3 domain on SLES 11 to an Active Directory Samba 4 installation on SLES 12. The Samba Wiki recommends 'samba-tool classicupgrade' for this, but I could not find teh tool on SLES 12. All samba related packages are installed. Is the tool not available on SLES 12?

Automatic reply
03-Aug-2015, 05:30
klausj66,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team
http://forums.suse.com

ab
03-Aug-2015, 11:38
Do you have a link to the wikip age? I have never seen this tool, and
cannot find it on SLES 11 or 12 right now, but seeing the original link
may help.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...

swadm
19-Aug-2015, 08:38
I want to migrate our classic Samba 3 domain on SLES 11 to an Active Directory Samba 4 installation on SLES 12. The Samba Wiki recommends 'samba-tool classicupgrade' for this, but I could not find teh tool on SLES 12. All samba related packages are installed. Is the tool not available on SLES 12?

From SuSE support, last year, we learned that "Suse does not support a samba 4 AD DC".
That may be the reason for the missing samba-tool command.

I've heard that most Sambistas choose the Sernet packages (http://www.samba.plus/), which, of course, are also not supported by SuSE / Novell.

Let me know if you learned something different.

HTH, Thomas

klausj66
15-Sep-2015, 15:36
Hi Thomas,

thank you for the link. I will use the Sernet packages or change to another Linux distribution. I think SuSE only supports Samba membership in an existing Active Directory.

Klaus

klausj66
15-Sep-2015, 15:49
Do you have a link to the wikip age? I have never seen this tool, and
cannot find it on SLES 11 or 12 right now, but seeing the original link
may help.


--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...

Here is the Samba Wiki link:
https://wiki.samba.org/index.php/Migrating_a_Samba_NT4_domain_to_a_Samba_AD_domain_ %28classic_upgrade%29

And the Samba man page for samba-tool:
https://www.samba.org/samba/docs/man/manpages/samba-tool.8.html

Klaus