PDA

View Full Version : new SLES12: SUSE-connect rubygems error



emanuele_lombardi
20-Aug-2015, 09:18
I'm trying to register my new SLES12 VM, but I get the following error:

SUSEConnect -help
/usr/lib64/ruby/2.1.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'suse-connect' (= 0.2.14) among 65 total gem(s) (Gem::LoadError)
from /usr/lib64/ruby/2.1.0/rubygems/dependency.rb:309:in `to_spec'
from /usr/lib64/ruby/2.1.0/rubygems/core_ext/kernel_gem.rb:53:in `gem'
from /usr/sbin/SUSEConnect:22:in `<main>'

If I have a look at /usr/lib64/ruby/ I see the following files:

find /usr/lib64/ruby -name \*suse\*
/usr/lib64/ruby/gems/2.1.0/cache/suse-connect-0.2.14.gem
/usr/lib64/ruby/gems/2.1.0/gems/gem2rpm-0.10.1/templates/opensuse.spec.erb
/usr/lib64/ruby/gems/2.1.0/gems/suse-connect-0.2.14
/usr/lib64/ruby/gems/2.1.0/gems/suse-connect-0.2.14/lib/suse
/usr/lib64/ruby/gems/2.1.0/gems/suse-connect-0.2.14/lib/suse.rb
/usr/lib64/ruby/gems/2.1.0/specifications/suse-connect-0.2.14.gemspec

What's wrong?
I had to install an older version of ruby in /usr/local/rvm to allow an old web application work properly. It may be possible the error is this?

Thank for any help,
Emanuele

Automatic reply
26-Aug-2015, 05:30
emanuele,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team
http://forums.suse.com

cyberiad
27-Aug-2015, 13:21
I had to install an older version of ruby in /usr/local/rvm to allow an old web application work properly. It may be possible the error is this?

Yes, very likely, since YaST and SUSEConnect are written in Ruby. So I suspect that the older ruby version broke the stack that SUSEConnect is relying on.

swadm
01-Sep-2015, 08:32
Just as an alternative idea: SuSE has been quite quick in officially supporting docker (https://www.suse.com/communities/conversations/welcome-docker-to-suse-linux-enterprise-server/).

Ruby, to my knowledge is quite a complex system to setup. Perhaps you can find a docker image addressing your need: we implemented a dockerized installation of the discourse (http://www.discourse.org/)forum, which also requires ruby. In case of discourse, docker based install is even the only supported one.

HTH, Thomas

emanuele_lombardi
02-Sep-2015, 08:30
I'm lucky yast2 works properly.
The old version 1.8.7 of ruby in /usr/local/rvm thus I hoped it would not interfere with ruby 2.1.0 which is in /usr/lib64/ruby

Is there any other way to register my SLES12 to SUSE? May I send an email to someone of the SUSE support?

swadm
02-Sep-2015, 14:16
I'm lucky yast2 works properly.
The old version 1.8.7 of ruby in /usr/local/rvm thus I hoped it would not interfere with ruby 2.1.0 which is in /usr/lib64/ruby

Is there any other way to register my SLES12 to SUSE? May I send an email to someone of the SUSE support?

Have you tried the following?


yast inst_suse_register

emanuele_lombardi
08-Sep-2015, 10:14
it doesn't work. I also tryed with yast2, same result.

yast inst_suse_register
No such client module inst_suse_register
The search path follows. It does not include the current directory.
/y2update/clients
/root/.yast2/clients
/usr/share/YaST2/clients

Run 'yast2 -h' for help on usage

emanuele_lombardi
09-Sep-2015, 09:08
After a lot of tests, I found out that, in my system,
SUSEConnect doesn't work if root login shell is /bin/bash but
SUSEConnect works when root login shell is /bin/sh (!)
I didn't test other login shells, but it could be interesting, if I had time.

I still have problems registering my system, problems related to repositories and I'm going to create a new post about it.
Thanks to everybody who helped.

Emanuele