PDA

View Full Version : SLES 11sp4 upgrade issues



skunkboy
20-Aug-2015, 20:00
So I'm back again already. Trying to upgrade a bunch of SLES 11sp3 boxes to sp4, which is why my last thread was about trying to straighten out our machine registrations. That seems to be fixed, but when I try to run WAGON to upgrade to the newest service pack I get the following error ::

Permission to access 'https://nu.novell.com/repo/$RCE/SLE11-SDK-SP4-Pool/sle-11-x86_64/repodata/repomd.xml?credentials=NCCcredentials' denied.

Visit the Novell Customer Center to check whether your registration is valid and has not expired.

The machines I'm running WAGON on are listed as registered on suse.com and we are connecting directly for packages. Not sure why I can download sp3 patches but not upgrade to sp4??

Thanks,
Matt

smflood
20-Aug-2015, 23:03
skunkboy Wrote in message:

> So I'm back again already. Trying to upgrade a bunch of SLES 11sp3
> boxes to sp4, which is why my last thread was about trying to straighten
> out our machine registrations. That seems to be fixed, but when I try
> to run WAGON to upgrade to the newest service pack I get the following
> error ::
>
> Permission to access
> 'https://nu.novell.com/repo/$RCE/SLE11-SDK-SP4-Pool/sle-11-x86_64/repodata/repomd.xml?credentials=NCCcredentials'
> denied.
>
> Visit the Novell Customer Center to check whether your registration is
> valid and has not expired.
>
> The machines I'm running WAGON on are listed as registered on suse.com
> and we are connecting directly for packages. Not sure why I can
> download sp3 patches but not upgrade to sp4??

I've not had any issues upgrading a 64-bit SLES11 SP3 server (with
SDK) to SLES11 SP4 although I did so using zypper rather than
YaST Wagon. You mention suse.com but the error references
novell.com so can you post the output from "zypper lr
-u".

HTH.
--
Simon Flood
SUSE Knowledge Partner


----Android NewsGroup Reader----
http://usenet.sinaapp.com/

skunkboy
21-Aug-2015, 14:56
Just tried to run the upgrade with WAGON on this box and it failed, so here is the output of zypper lr -u

# | Alias | Name | Enabled | Refresh | URI
---+--------------------------------------------------------+--------------------------------------------------------+---------+---------+---------------------------------------------------------------------------------------------------
1 | SUSE-Linux-Enterprise-Server-11 11-0 | SUSE-Linux-Enterprise-Server-11 11-0 | No | No | cd:///?devices=/dev/sr0
2 | SUSE-Linux-Enterprise-Software-Development-Kit-11_11-0 | SUSE-Linux-Enterprise-Software-Development-Kit-11 11-0 | No | No | dvd:///
3 | nu_novell_com:SLE11-Public-Cloud-Module | SLE11-Public-Cloud-Module | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-Public-Cloud-Module/sle-11-i586?credentials=NCCcredentials
4 | nu_novell_com:SLE11-SDK-SP1-Pool | SLE11-SDK-SP1-Pool | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP1-Pool/sle-11-i586?credentials=NCCcredentials
5 | nu_novell_com:SLE11-SDK-SP1-Updates | SLE11-SDK-SP1-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP1-Updates/sle-11-i586?credentials=NCCcredentials
6 | nu_novell_com:SLE11-SDK-SP2-Core | SLE11-SDK-SP2-Core | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP2-Core/sle-11-i586?credentials=NCCcredentials
7 | nu_novell_com:SLE11-SDK-SP2-Updates | SLE11-SDK-SP2-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP2-Updates/sle-11-i586?credentials=NCCcredentials
8 | nu_novell_com:SLE11-SDK-SP3-Pool | SLE11-SDK-SP3-Pool | Yes | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP3-Pool/sle-11-i586?credentials=NCCcredentials
9 | nu_novell_com:SLE11-SDK-SP3-Updates | SLE11-SDK-SP3-Updates | Yes | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP3-Updates/sle-11-i586?credentials=NCCcredentials
10 | nu_novell_com:SLE11-SDK-SP4-Pool | SLE11-SDK-SP4-Pool | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP4-Pool/sle-11-i586?credentials=NCCcredentials
11 | nu_novell_com:SLE11-SDK-SP4-Updates | SLE11-SDK-SP4-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP4-Updates/sle-11-i586?credentials=NCCcredentials
12 | nu_novell_com:SLE11-SP1-Debuginfo-Pool | SLE11-SP1-Debuginfo-Pool | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SP1-Debuginfo-Pool/sle-11-i586?credentials=NCCcredentials
13 | nu_novell_com:SLE11-SP1-Debuginfo-Updates | SLE11-SP1-Debuginfo-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SP1-Debuginfo-Updates/sle-11-i586?credentials=NCCcredentials
14 | nu_novell_com:SLE11-SP2-Debuginfo-Core | SLE11-SP2-Debuginfo-Core | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SP2-Debuginfo-Core/sle-11-i586?credentials=NCCcredentials
15 | nu_novell_com:SLE11-SP2-Debuginfo-Updates | SLE11-SP2-Debuginfo-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SP2-Debuginfo-Updates/sle-11-i586?credentials=NCCcredentials
16 | nu_novell_com:SLE11-SP3-Debuginfo-Pool | SLE11-SP3-Debuginfo-Pool | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SP3-Debuginfo-Pool/sle-11-i586?credentials=NCCcredentials
17 | nu_novell_com:SLE11-SP3-Debuginfo-Updates | SLE11-SP3-Debuginfo-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SP3-Debuginfo-Updates/sle-11-i586?credentials=NCCcredentials
18 | nu_novell_com:SLE11-SP4-Debuginfo-Pool | SLE11-SP4-Debuginfo-Pool | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SP4-Debuginfo-Pool/sle-11-i586?credentials=NCCcredentials
19 | nu_novell_com:SLE11-SP4-Debuginfo-Updates | SLE11-SP4-Debuginfo-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SP4-Debuginfo-Updates/sle-11-i586?credentials=NCCcredentials
20 | nu_novell_com:SLE11-Security-Module | SLE11-Security-Module | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-Security-Module/sle-11-i586?credentials=NCCcredentials
21 | nu_novell_com:SLES11-Extras | SLES11-Extras | No | Yes | https://nu.novell.com/repo/$RCE/SLES11-Extras/sle-11-i586?credentials=NCCcredentials
22 | nu_novell_com:SLES11-SP1-Pool | SLES11-SP1-Pool | No | Yes | https://nu.novell.com/repo/$RCE/SLES11-SP1-Pool/sle-11-i586?credentials=NCCcredentials
23 | nu_novell_com:SLES11-SP1-Updates | SLES11-SP1-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLES11-SP1-Updates/sle-11-i586?credentials=NCCcredentials
24 | nu_novell_com:SLES11-SP2-Core | SLES11-SP2-Core | No | Yes | https://nu.novell.com/repo/$RCE/SLES11-SP2-Core/sle-11-i586?credentials=NCCcredentials
25 | nu_novell_com:SLES11-SP2-Extension-Store | SLES11-SP2-Extension-Store | No | Yes | https://nu.novell.com/repo/$RCE/SLES11-SP2-Extension-Store/sle-11-i586?credentials=NCCcredentials
26 | nu_novell_com:SLES11-SP2-Updates | SLES11-SP2-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLES11-SP2-Updates/sle-11-i586?credentials=NCCcredentials
27 | nu_novell_com:SLES11-SP3-Extension-Store | SLES11-SP3-Extension-Store | No | Yes | https://nu.novell.com/repo/$RCE/SLES11-SP3-Extension-Store/sle-11-i586?credentials=NCCcredentials
28 | nu_novell_com:SLES11-SP3-Pool | SLES11-SP3-Pool | Yes | Yes | https://nu.novell.com/repo/$RCE/SLES11-SP3-Pool/sle-11-i586?credentials=NCCcredentials
29 | nu_novell_com:SLES11-SP3-Updates | SLES11-SP3-Updates | Yes | Yes | https://nu.novell.com/repo/$RCE/SLES11-SP3-Updates/sle-11-i586?credentials=NCCcredentials
30 | nu_novell_com:SLES11-SP4-Pool | SLES11-SP4-Pool | No | Yes | https://nu.novell.com/repo/$RCE/SLES11-SP4-Pool/sle-11-i586?credentials=NCCcredentials
31 | nu_novell_com:SLES11-SP4-Updates | SLES11-SP4-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLES11-SP4-Updates/sle-11-i586?credentials=NCCcredentials

Thanks,
Matt

bkesting
22-Aug-2015, 05:53
I am also trying to update via wagon and am getting the same error as the OP listed.

skunkboy
25-Aug-2015, 17:03
The only further suggestion I have received is to open a support request with Novell/Suse support.

Matt

smflood
26-Aug-2015, 12:16
On 21/08/2015 15:04, skunkboy wrote:

> Just tried to run the upgrade with WAGON on this box and it failed, so
> here is the output of zypper lr -u
>
> # | Alias | Name
> | Enabled | Refresh | URI
>
>
> ---+--------------------------------------------------------+--------------------------------------------------------+---------+---------+---------------------------------------------------------------------------------------------------
> 1 | SUSE-Linux-Enterprise-Server-11 11-0 |
> SUSE-Linux-Enterprise-Server-11 11-0 | No | No
> | cd:///?devices=/dev/sr0
>
> 2 | SUSE-Linux-Enterprise-Software-Development-Kit-11_11-0 |
> SUSE-Linux-Enterprise-Software-Development-Kit-11 11-0 | No | No
> | dvd:///
>
> 3 | nu_novell_com:SLE11-Public-Cloud-Module |
> SLE11-Public-Cloud-Module | No | Yes
> |
> https://nu.novell.com/repo/$RCE/SLE11-Public-Cloud-Module/sle-11-i586?credentials=NCCcredentials
>
> 4 | nu_novell_com:SLE11-SDK-SP1-Pool |
> SLE11-SDK-SP1-Pool | No | Yes
> |
> https://nu.novell.com/repo/$RCE/SLE11-SDK-SP1-Pool/sle-11-i586?credentials=NCCcredentials
>
> 5 | nu_novell_com:SLE11-SDK-SP1-Updates |
> SLE11-SDK-SP1-Updates | No | Yes
> |
> https://nu.novell.com/repo/$RCE/SLE11-SDK-SP1-Updates/sle-11-i586?credentials=NCCcredentials
>
> 6 | nu_novell_com:SLE11-SDK-SP2-Core |
> SLE11-SDK-SP2-Core | No | Yes
> |
> https://nu.novell.com/repo/$RCE/SLE11-SDK-SP2-Core/sle-11-i586?credentials=NCCcredentials
>
> 7 | nu_novell_com:SLE11-SDK-SP2-Updates |
> SLE11-SDK-SP2-Updates | No | Yes
> |
> https://nu.novell.com/repo/$RCE/SLE11-SDK-SP2-Updates/sle-11-i586?credentials=NCCcredentials
>
> 8 | nu_novell_com:SLE11-SDK-SP3-Pool |
> SLE11-SDK-SP3-Pool | Yes | Yes
> |
> https://nu.novell.com/repo/$RCE/SLE11-SDK-SP3-Pool/sle-11-i586?credentials=NCCcredentials
>
> 9 | nu_novell_com:SLE11-SDK-SP3-Updates |
> SLE11-SDK-SP3-Updates | Yes | Yes
> |
> https://nu.novell.com/repo/$RCE/SLE11-SDK-SP3-Updates/sle-11-i586?credentials=NCCcredentials
>
> 10 | nu_novell_com:SLE11-SDK-SP4-Pool |
> SLE11-SDK-SP4-Pool | No | Yes
> |
> https://nu.novell.com/repo/$RCE/SLE11-SDK-SP4-Pool/sle-11-i586?credentials=NCCcredentials
>
> 11 | nu_novell_com:SLE11-SDK-SP4-Updates |
> SLE11-SDK-SP4-Updates | No | Yes
> |
> https://nu.novell.com/repo/$RCE/SLE11-SDK-SP4-Updates/sle-11-i586?credentials=NCCcredentials
>
> 12 | nu_novell_com:SLE11-SP1-Debuginfo-Pool |
> SLE11-SP1-Debuginfo-Pool | No | Yes
> |
> https://nu.novell.com/repo/$RCE/SLE11-SP1-Debuginfo-Pool/sle-11-i586?credentials=NCCcredentials
>
> 13 | nu_novell_com:SLE11-SP1-Debuginfo-Updates |
> SLE11-SP1-Debuginfo-Updates | No | Yes
> |
> https://nu.novell.com/repo/$RCE/SLE11-SP1-Debuginfo-Updates/sle-11-i586?credentials=NCCcredentials
> 14 | nu_novell_com:SLE11-SP2-Debuginfo-Core |
> SLE11-SP2-Debuginfo-Core | No | Yes
> |
> https://nu.novell.com/repo/$RCE/SLE11-SP2-Debuginfo-Core/sle-11-i586?credentials=NCCcredentials
>
> 15 | nu_novell_com:SLE11-SP2-Debuginfo-Updates |
> SLE11-SP2-Debuginfo-Updates | No | Yes
> |
> https://nu.novell.com/repo/$RCE/SLE11-SP2-Debuginfo-Updates/sle-11-i586?credentials=NCCcredentials
> 16 | nu_novell_com:SLE11-SP3-Debuginfo-Pool |
> SLE11-SP3-Debuginfo-Pool | No | Yes
> |
> https://nu.novell.com/repo/$RCE/SLE11-SP3-Debuginfo-Pool/sle-11-i586?credentials=NCCcredentials
>
> 17 | nu_novell_com:SLE11-SP3-Debuginfo-Updates |
> SLE11-SP3-Debuginfo-Updates | No | Yes
> |
> https://nu.novell.com/repo/$RCE/SLE11-SP3-Debuginfo-Updates/sle-11-i586?credentials=NCCcredentials
> 18 | nu_novell_com:SLE11-SP4-Debuginfo-Pool |
> SLE11-SP4-Debuginfo-Pool | No | Yes
> |
> https://nu.novell.com/repo/$RCE/SLE11-SP4-Debuginfo-Pool/sle-11-i586?credentials=NCCcredentials
>
> 19 | nu_novell_com:SLE11-SP4-Debuginfo-Updates |
> SLE11-SP4-Debuginfo-Updates | No | Yes
> |
> https://nu.novell.com/repo/$RCE/SLE11-SP4-Debuginfo-Updates/sle-11-i586?credentials=NCCcredentials
> 20 | nu_novell_com:SLE11-Security-Module |
> SLE11-Security-Module | No | Yes
> |
> https://nu.novell.com/repo/$RCE/SLE11-Security-Module/sle-11-i586?credentials=NCCcredentials
>
> 21 | nu_novell_com:SLES11-Extras |
> SLES11-Extras | No | Yes
> |
> https://nu.novell.com/repo/$RCE/SLES11-Extras/sle-11-i586?credentials=NCCcredentials
>
> 22 | nu_novell_com:SLES11-SP1-Pool |
> SLES11-SP1-Pool | No | Yes
> |
> https://nu.novell.com/repo/$RCE/SLES11-SP1-Pool/sle-11-i586?credentials=NCCcredentials
>
> 23 | nu_novell_com:SLES11-SP1-Updates |
> SLES11-SP1-Updates | No | Yes
> |
> https://nu.novell.com/repo/$RCE/SLES11-SP1-Updates/sle-11-i586?credentials=NCCcredentials
>
> 24 | nu_novell_com:SLES11-SP2-Core |
> SLES11-SP2-Core | No | Yes
> |
> https://nu.novell.com/repo/$RCE/SLES11-SP2-Core/sle-11-i586?credentials=NCCcredentials
>
> 25 | nu_novell_com:SLES11-SP2-Extension-Store |
> SLES11-SP2-Extension-Store | No | Yes
> |
> https://nu.novell.com/repo/$RCE/SLES11-SP2-Extension-Store/sle-11-i586?credentials=NCCcredentials
>
> 26 | nu_novell_com:SLES11-SP2-Updates |
> SLES11-SP2-Updates | No | Yes
> |
> https://nu.novell.com/repo/$RCE/SLES11-SP2-Updates/sle-11-i586?credentials=NCCcredentials
>
> 27 | nu_novell_com:SLES11-SP3-Extension-Store |
> SLES11-SP3-Extension-Store | No | Yes
> |
> https://nu.novell.com/repo/$RCE/SLES11-SP3-Extension-Store/sle-11-i586?credentials=NCCcredentials
>
> 28 | nu_novell_com:SLES11-SP3-Pool |
> SLES11-SP3-Pool | Yes | Yes
> |
> https://nu.novell.com/repo/$RCE/SLES11-SP3-Pool/sle-11-i586?credentials=NCCcredentials
>
> 29 | nu_novell_com:SLES11-SP3-Updates |
> SLES11-SP3-Updates | Yes | Yes
> |
> https://nu.novell.com/repo/$RCE/SLES11-SP3-Updates/sle-11-i586?credentials=NCCcredentials
>
> 30 | nu_novell_com:SLES11-SP4-Pool |
> SLES11-SP4-Pool | No | Yes
> |
> https://nu.novell.com/repo/$RCE/SLES11-SP4-Pool/sle-11-i586?credentials=NCCcredentials
>
> 31 | nu_novell_com:SLES11-SP4-Updates |
> SLES11-SP4-Updates | No | Yes
> |
> https://nu.novell.com/repo/$RCE/SLES11-SP4-Updates/sle-11-i586?credentials=NCCcredentials

Okay so this shows that your server is configured to point to Novell
Customer Center (NCC) for all of its repos in which case you need to
check there (and not SUSE Customer Center) to see what it thinks about
your access to SP4, or at least the SP4 SDK. If there is a problem
there's an option within NCC to "Chat Now" (top-right).

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

cyberiad
27-Aug-2015, 13:06
Okay so this shows that your server is configured to point to Novell
Customer Center (NCC) for all of its repos in which case you need to
check there (and not SUSE Customer Center) to see what it thinks about
your access to SP4, or at least the SP4 SDK. If there is a problem
there's an option within NCC to "Chat Now" (top-right).


Yes, that's the right thing to do. It could happen when the registration is not valid anymore or when the wrong e-mail address had been provided during the re-registration step during the migration.

skunkboy
27-Aug-2015, 19:37
We got a support ticket opened up, and our registration is okay. Sounds like there are timing issues on the back end. If I apply the sp4 upgraded patch, run wagon, let it fail, and then try it again about 20-24 hours later 80% of my machines can then upgrade...

bkesting
10-Sep-2015, 03:34
Mine finally upgraded. Everything seems fine, though I now have a hv_fcopy_daemon (this is apparently new in SP4) and it will not start. Just started investigating, but sure if I need it or not (my SLES 11 SP4 machines are running as Hyper V virtual machines)