PDA

View Full Version : Problem with autofs on SLED12



ttrcf
03-Sep-2015, 11:51
I have configured various SLED12 machines to automount users home directories and some software packages using NFS. I am seeing on seemingly random machines the following error in /var/log/messages when the automount fails:

2015-09-03T11:45:19.732322+01:00 this-machine rpc.gssd[7911]: ERROR: gssd_refresh_krb5_machine_credential: no usable keytab entry found in keytab /etc/krb5.keytab for connection with host remote-machine
2015-09-03T11:45:19.732663+01:00 this-machine rpc.gssd[7911]: ERROR: No credentials found for connection to server remote-machine
2015-09-03T11:45:19.737695+01:00 this-machine rpc.gssd[7912]: ERROR: gssd_refresh_krb5_machine_credential: no usable keytab entry found in keytab /etc/krb5.keytab for connection with host remote-machine
2015-09-03T11:45:19.737938+01:00 this machine rpc.gssd[7912]: ERROR: No credentials found for connection to server remote-machine

Other SLed12 machines can connect without issue.

I do not use Kerberos authentication and never have. In the Yast2 setup page for NFS Client on the NFS Settings tab, Enable NFSv4 is checked (I have tried unchecking it but it made no difference), Enable GSS Security is not checked.

Any insights would be much appreciated as I a starting to tear my hair out (and I don't have much to spare!). Never had this issue with SLED11.

ROB

Automatic reply
09-Sep-2015, 05:30
ttrcf,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team
http://forums.suse.com

dpartrid
21-Oct-2015, 22:53
The errors you quoted are somewhat cosmetic, and shouldn't actually result in failed mounts. Are you sure that you aren't seeing these messages on *both* successful and unsuccessful mount attempts?

Changes have been made to prevent those messages, i.e. to avoid loading rpc.gssd if there is no krb5.keytab file. You could update your SLED to current maintenance, to get those changes (which were made public just this week.) The specific package involve is nfs-client, but I would always update nfs-kernel-server at the same time. And you might chose to update nfs-doc while you're at it... all those packages come from nfs-util source code.

For a few more details see https://www.novell.com/support/kb/doc.php?id=7016917

I would get those updates in place and then re-evaluate the situation.