PDA

View Full Version : postgresql-devel-8.3 on SLES11SP3 - failed dependencies



cris119
07-Sep-2015, 13:45
Has anyone succeeded to install postgresql-devel-8.3.23-0.4.1 on SLES11SP3?

I'm stuck with this error:

# rpm -ivh postgresql-devel-8.3.23-0.4.1.x86_64.rpm
error: Failed dependencies:
libecpg6 = 8.3.23 is needed by postgresql-devel-8.3.23-0.4.1.x86_64
libpq5 = 8.3.23 is needed by postgresql-devel-8.3.23-0.4.1.x86_64

Thanks in advance for your help.

jmozdzen
07-Sep-2015, 14:11
Hi cris119,

while I can confirm that dependency issue, I recall from earlier cases that SUSE does not guarantee all SLE SDK packages to run all SLE platforms (SLED, SLES). So it may well be that on SLED, you'd be able to install without a problem. I'll ask my SUSE contact if in this particular case, some corrective measure can be made available since postgresql (and according development) is rather common on servers as well.

Regards,
Jens