PDA

View Full Version : AutoYast issue for VNC



dschaldenovell
27-Feb-2012, 19:34
My customer is trying to determine why his AutoYast installation is working for everything except VNC (Remote Administration) Would anyone be able to assist? Please see the attached message,

I've been able to make all AutoYast features I've tried work so far except enabling of Remote Administration via VNC. I've tried both of the configurations shown below and the /etc/xinetd.d/vnc file is modified correctly but checking via YaST on the running system I see that Remote Administration via VNC is still disabled. Any ideas?

Without the "service" tag.../etc/xinetd.d/vnc modified correctly but remote admin not enabled:

<inetd>
<netd_service config:type="symbol">xinetd</netd_service>
<netd_status config:type="integer">0</netd_status>
<netd_conf config:type="list">
<conf>
<script>vnc</script>
<enabled config:type="boolean">true</enabled>
</conf>
</netd_conf>
</inetd>


With the "service" tag....this actually leaves xinetd disabled!

<inetd>
<netd_service config:type="symbol">xinetd</netd_service>
<netd_status config:type="integer">0</netd_status>
<netd_conf config:type="list">
<conf>
<script>vnc</script>
<service>xinetd</service>
<enabled config:type="boolean">true</enabled>
</conf>
</netd_conf>
</inetd>


Any thoughts would be helpful.

malcolmlewis
02-Mar-2012, 02:21
My customer is trying to determine why his AutoYast installation is
working for everything except VNC (Remote Administration) Would anyone
be able to assist? Please see the attached message,

I've been able to make all AutoYast features I've tried work so far
except enabling of Remote Administration via VNC. I've tried both of the
configurations shown below and the /etc/xinetd.d/vnc file is modified
correctly but checking via YaST on the running system I see that Remote
Administration via VNC is still disabled. Any ideas?

Without the "service" tag.../etc/xinetd.d/vnc modified correctly but
remote admin not enabled:

<inetd>
<netd_service
config:type="symbol">xinetd</netd_service>
<netd_status config:type="integer">0</netd_status>
<netd_conf config:type="list">
<conf>
<script>vnc</script>
<enabled config:type="boolean">true</enabled>
</conf>
</netd_conf>
</inetd>


With the "service" tag....this actually leaves xinetd disabled!

<inetd>
<netd_service
config:type="symbol">xinetd</netd_service>
<netd_status config:type="integer">0</netd_status>
<netd_conf config:type="list">
<conf>
<script>vnc</script>
<service>xinetd</service>
<enabled config:type="boolean">true</enabled>
</conf>
</netd_conf>
</inetd>


Any thoughts would be helpful.



Hi
Have you seen this thread?
http://forums.suse.com/showthread.php?t=655

--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
up 4 days 22:27, 2 users, load average: 0.00, 0.02, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU