PDA

View Full Version : SAPHanaSR Package - where is it?



diheim
15-Oct-2015, 15:37
Hello!

I tried to setup up a PoC for a customer on SLES 11SP3 with the HA Extension. We installed everything according to https://www.suse.com/docrep/documents/wvhlogf37z/sap_hana_system_replication_on_sles_for_sap_applic ations.pdf , but I failed at 5.6 Install SAPHanaSR : this package is not available, not on SLES11SP3 SLES for SAP, the HA Addon ... where do I find that package? I expected it to be part of the high availability addon or the base SLES for SAP, but couldn't find it anywhere.

regards
Martin

jmozdzen
15-Oct-2015, 15:52
Hi Martin,

Hello!

I tried to setup up a PoC for a customer on SLES 11SP3 with the HA Extension. We installed everything according to https://www.suse.com/docrep/documents/wvhlogf37z/sap_hana_system_replication_on_sles_for_sap_applic ations.pdf , but I failed at 5.6 Install SAPHanaSR : this package is not available, not on SLES11SP3 SLES for SAP, the HA Addon ... where do I find that package? I expected it to be part of the high availability addon or the base SLES for SAP, but couldn't find it anywhere.

regards
Martin

I see it at least as part of the SLES11 SP3 SAP update repository. Have you registered your system, what does "zypper lr" report?

Regards,
Jens

diheim
15-Oct-2015, 16:02
Hi!



I see it at least as part of the SLES11 SP3 SAP update repository. Have you registered your system, what does "zypper lr" report?


I saw the update packages, too, but the systems are currently isolated and not yet connected to external repositories. (And I'm still wondering how updates can be available for packages that are not in the distribution)
"zypper lr" reports:


# | Alias | Name | Aktiviert | Aktualisieren
--+----------------------------------------------------------------------+----------------------------------------------------------+-----------+--------------
1 | SLES-for-SAP-Applications_11.3.3-1.17 | SLES for SAP Applications | Ja | Nein
2 | SUSE-Linux-Enterprise-High-Availability-Extension-11-SP3_11.3.3-1.69 | SUSE Linux Enterprise High Availability Extension 11 SP3 | Ja | Nein
3 | SUSE-Linux-Enterprise-Server-11-SP3_11.3.3-1.138 | SUSE-Linux-Enterprise-Server-11-SP3 11.3.3-1.138 | Ja | Nein


regards
Martin

jmozdzen
15-Oct-2015, 16:22
Hi Martin,

Hi!

I saw the update packages, too, but the systems are currently isolated and not yet connected to external repositories.
Then that's your source of trouble. Fetch the packages (RPMs) and transfer them to your machine for manual installation, that should get you over the failing step ("zypper install via repos").


(And I'm still wondering how updates can be available for packages that are not in the distribution)

Well, the update repos also updates the amount of packages, not only their versions ;) I've seen it before that new packages are provided via the update channels, though it hasn't been the most common thing.

Regards,
Jens

diheim
15-Oct-2015, 16:41
Then that's your source of trouble. Fetch the packages (RPMs) and transfer them to your machine for manual installation, that should get you over the failing step ("zypper install via repos").

ok, thanks, I will try that and report back :)



Well, the update repos also updates the amount of packages, not only their versions ;) I've seen it before that new packages are provided via the update channels, though it hasn't been the most common thing.


Still strange, though ;)

regards
Martin

PS: sorry for the cross post, I wasn't sure if it belongs to the SAP or HA part