PDA

View Full Version : SLES 11 SP3 Does the SP3 for SLES 11 contain "cifs-utils" package?



pbartol
20-Oct-2015, 16:02
Hi,

I need to make use of getcifsacl/setcifsacl on SLES11 SP1, but the system is not open to the world,
so I can't use online repos.
I tried to use the installation DVD iso files, but it didn't help - zypper could not find the package.
The company I work for is considering that we may have to apply SP3, if the Service Pack can solve our problem.

So, could anyone tell me if there is a chance that after installing SP3 we are going to have cifs-utils working?
Thanks in advance!

malcolmlewis
20-Oct-2015, 16:13
On Tue 20 Oct 2015 03:04:01 PM CDT, pbartol wrote:


Hi,

I need to make use of getcifsacl/setcifsacl on SLES11 SP1, but the
system is not open to the world,
so I can't use online repos.
I tried to use the installation DVD iso files, but it didn't help -
zypper could not find the package.
The company I work for is considering that we may have to apply SP3, if
the Service Pack can solve our problem.

So, could anyone tell me if there is a chance that after installing SP3
we are going to have cifs-utils working?
Thanks in advance!




Hi
It's in the pool for SP3 (should be on the DVD);


Information for package cifs-utils:

Repository: SLES11-SP3-Pool for x86_64
Name: cifs-utils
Version: 5.1-0.11.1

Download DVD1 and verify it's there?

You should consider SP4 as SP3 will go out of general support.

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 | GNOME 3.10.1 | 3.12.48-52.27-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

smflood
20-Oct-2015, 16:47
On 20/10/2015 16:04, pbartol wrote:

> I need to make use of getcifsacl/setcifsacl on SLES11 SP1, but the
> system is not open to the world,
> so I can't use online repos.
> I tried to use the installation DVD iso files, but it didn't help -
> zypper could not find the package.
> The company I work for is considering that we may have to apply SP3, if
> the Service Pack can solve our problem.
>
> So, could anyone tell me if there is a chance that after installing SP3
> we are going to have cifs-utils working?

The SLES11 SP3 media includes the cifs-utils package but it doesn't
include the getcifsacl or setcifsacl utilities. Since the openSUSE
version of the package does include these utilities I'll ask my SUSE
contacts why the SLES one doesn't.

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

pbartol
21-Oct-2015, 09:44
The SLES11 SP3 media includes the cifs-utils package but it doesn't
include the getcifsacl or setcifsacl utilities. Since the openSUSE
version of the package does include these utilities I'll ask my SUSE
contacts why the SLES one doesn't.

I need both: getcifsacl and setcifsacl working on my system, to have ability to work with windows ACLs (on a share mounted on SLES).

What do I need to do to achieve it, if it's not included?
How can I properly install those on my SLES 11?

pbartol
21-Oct-2015, 12:02
You should consider SP4 as SP3 will go out of general support.

Thank you, we will consider it.

smflood
21-Oct-2015, 12:26
On 21/10/2015 12:04, pbartol wrote:

> Thank you, we will consider it.

Note that at this point in time upgrading to SLES11 SP4 will not help
you as the cifs-utils package installed with SLES11 SP4 also doesn't
include the getcifsacl or setcifsacl utilities.

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

smflood
21-Oct-2015, 12:27
On 21/10/2015 09:54, pbartol wrote:

> I need both: getcifsacl and setcifsacl working on my system, to have
> ability to work with windows ACLs (on a share mounted on SLES).
>
> What do I need to do to achieve it, if it's not included?
> How can I properly install those on my SLES 11?

I'm waiting to hear from my SUSE contact how to proceed but if this is
urgent and you have the ability to open a Service Request then that
would help expedite things. I'll post back when I get a response.

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

pbartol
21-Oct-2015, 13:44
I'm waiting to hear from my SUSE contact how to proceed but if this is
urgent and you have the ability to open a Service Request then that
would help expedite things. I'll post back when I get a response.


Thanks, I'll try to find out if we can open a SR,
but of course I'm looking forward for any update from you.

Regards
Pawel

pbartol
29-Oct-2015, 12:47
Hi Simon,

I guess my case has died? :)

Pawel

jmozdzen
29-Oct-2015, 15:50
Hi Pawel,


Hi Simon,

I guess my case has died? :)

from what I can see, SLES12 seems to have the utilities included - as you're running on an old platform anyhow (SLES11SP1), any chance to upgrade the server beyond SLES11SP3, to SLES12?

Regards,
Jens

pbartol
03-Nov-2015, 14:09
[...]any chance to upgrade the server beyond SLES11SP3, to SLES12?


Unfortunately, there is no chance to do it due to organization constraints.
But what most surprises me, is the fact that nobody can give me a solution to have those programs working or at least an instruction what is necessary to have them installed ;-)
I'm starting to think that this is almost rocket science :D

Cheers,
Pawel