PDA

View Full Version : SLES 12 Yast Online Update-Error refreshing service service



frankrams
22-Oct-2015, 19:38
I attempted to add a repos to zypper and pointed to a bad or invalid url, now I'm getting:

There was an error in the repository initialization.
Error refreshing service service
(http://software.opensuse.org/ymp/utilities/SLE_12/incron.ymp):

Parse error: reposindex.xml [536] Couldn't find end of Start Tag div
History:
(that is all in the text based window)

Any ideas how I can remove this repo entry and eliminate the error?

-Frank

frankrams
22-Oct-2015, 20:09
Additional detail:

# zypper ref -s
Refreshing service 'Advanced_Systems_Management_Module_12_s390x'.
Refreshing service 'Legacy_Module_12_s390x'.
Refreshing service 'Public_Cloud_Module_12_s390x'.
Refreshing service 'SUSE_Linux_Enterprise_Server_12_s390x'.
Refreshing service 'SUSE_Linux_Enterprise_Software_Development_Kit_12 _s390x'.
Refreshing service 'Web_and_Scripting_Module_12_s390x'.
Refreshing service 'service'.
Timeout exceeded when accessing 'http://software.opensuse.org/ymp/utilities/SLE_12/incron.ymp/repo/repoindex.xml'.

Abort, retry, ignore? [a/r/i] (r):
Trying again...

Unexpected exception.
Parse error: repoindex.xml[536] Couldn't find end of Start Tag div
History:
- repoindex.xml[536] attributes construct error
- repoindex.xml[536] AttValue: " or ' expected
- repoindex.xml[363] Entity 'nbsp' not defined
- repoindex.xml[362] Entity 'nbsp' not defined
- repoindex.xml[361] Entity 'nbsp' not defined
- repoindex.xml[360] Entity 'nbsp' not defined
- repoindex.xml[359] Entity 'nbsp' not defined
- repoindex.xml[338] Entity 'nbsp' not defined
- repoindex.xml[338] Entity 'nbsp' not defined
- repoindex.xml[187] Entity 'nbsp' not defined
- repoindex.xml[187] Entity 'nbsp' not defined

Please file a bug report about this.
See http://en.opensuse.org/Zypper/Troubleshooting for instructions.

-Frank

malcolmlewis
22-Oct-2015, 23:41
On Thu 22 Oct 2015 07:14:02 PM CDT, frankrams wrote:


Additional detail:

# zypper ref -s
Refreshing service 'Advanced_Systems_Management_Module_12_s390x'.
Refreshing service 'Legacy_Module_12_s390x'.
Refreshing service 'Public_Cloud_Module_12_s390x'.
Refreshing service 'SUSE_Linux_Enterprise_Server_12_s390x'.
Refreshing service
'SUSE_Linux_Enterprise_Software_Development_Kit_12 _s390x'.
Refreshing service 'Web_and_Scripting_Module_12_s390x'.
Refreshing service 'service'.
Timeout exceeded when accessing
'http://software.opensuse.org/ymp/utilities/SLE_12/incron.ymp/repo/repoindex.xml'.

Abort, retry, ignore? [a/r/i] (r):
Trying again...

Unexpected exception.
Parse error: repoindex.xml[536] Couldn't find end of Start Tag div
History:
- repoindex.xml[536] attributes construct error
- repoindex.xml[536] AttValue: " or ' expected
- repoindex.xml[363] Entity 'nbsp' not defined
- repoindex.xml[362] Entity 'nbsp' not defined
- repoindex.xml[361] Entity 'nbsp' not defined
- repoindex.xml[360] Entity 'nbsp' not defined
- repoindex.xml[359] Entity 'nbsp' not defined
- repoindex.xml[338] Entity 'nbsp' not defined
- repoindex.xml[338] Entity 'nbsp' not defined
- repoindex.xml[187] Entity 'nbsp' not defined
- repoindex.xml[187] Entity 'nbsp' not defined

Please file a bug report about this.
See http://en.opensuse.org/Zypper/Troubleshooting for instructions.

-Frank




Hi
Run the command;


zypper --no-refresh lr

You can the see the offending repo in the list, then use the rr command
to remove the uri number(#), first column in the list;


zypper rr <uri_#>


--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 | GNOME 3.10.1 | 3.12.48-52.27-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

malcolmlewis
23-Oct-2015, 04:06
On Thu 22 Oct 2015 07:14:02 PM CDT, frankrams wrote:

Refreshing service 'SUSE_Linux_Enterprise_Server_12_s390x'.


Hi
Also, since your on s390x, if you grab the src rpm and rebuild locally
you may get a better result... only needed aside from the rpm build
environment is gcc-c++.

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 | GNOME 3.10.1 | 3.12.48-52.27-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

frankrams
23-Oct-2015, 16:25
Hi
Run the command;


zypper --no-refresh lr

You can the see the offending repo in the list, then use the rr command
to remove the uri number(#), first column in the list;


zypper rr <uri_#>


--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 | GNOME 3.10.1 | 3.12.48-52.27-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!


Thanks for your response, Malcolm


....tried that, but I don't see anything that resembles the offending repo reference:


# zypper --no-refresh lr
# | Alias | Name | Enabled | GPG Check | Refresh
---+---------------------------------------------------------------------------------------------------+-------------------------------------------------------+---------+-----------+--------
1 | Advanced_Systems_Management_Module_12_s390x:SLE-Module-Adv-Systems-Management12-Debuginfo-Pool | SLE-Module-Adv-Systems-Management12-Debuginfo-Pool | No | ---- | No
2 | Advanced_Systems_Management_Module_12_s390x:SLE-Module-Adv-Systems-Management12-Debuginfo-Updates | SLE-Module-Adv-Systems-Management12-Debuginfo-Updates | No | ---- | Yes
3 | Advanced_Systems_Management_Module_12_s390x:SLE-Module-Adv-Systems-Management12-Pool | SLE-Module-Adv-Systems-Management12-Pool | Yes | ( p) Yes | No
4 | Advanced_Systems_Management_Module_12_s390x:SLE-Module-Adv-Systems-Management12-Updates | SLE-Module-Adv-Systems-Management12-Updates | Yes | (r ) Yes | Yes
5 | Legacy_Module_12_s390x:SLE-Module-Legacy12-Debuginfo-Pool | SLE-Module-Legacy12-Debuginfo-Pool | No | ---- | No
6 | Legacy_Module_12_s390x:SLE-Module-Legacy12-Debuginfo-Updates | SLE-Module-Legacy12-Debuginfo-Updates | No | ---- | Yes
7 | Legacy_Module_12_s390x:SLE-Module-Legacy12-Pool | SLE-Module-Legacy12-Pool | Yes | ( p) Yes | No
8 | Legacy_Module_12_s390x:SLE-Module-Legacy12-Updates | SLE-Module-Legacy12-Updates | Yes | (r ) Yes | Yes
9 | Public_Cloud_Module_12_s390x:SLE-Module-Public-Cloud12-Debuginfo-Pool | SLE-Module-Public-Cloud12-Debuginfo-Pool | No | ---- | No
10 | Public_Cloud_Module_12_s390x:SLE-Module-Public-Cloud12-Debuginfo-Updates | SLE-Module-Public-Cloud12-Debuginfo-Updates | No | ---- | Yes
11 | Public_Cloud_Module_12_s390x:SLE-Module-Public-Cloud12-Pool | SLE-Module-Public-Cloud12-Pool | Yes | ( p) Yes | No
12 | Public_Cloud_Module_12_s390x:SLE-Module-Public-Cloud12-Updates | SLE-Module-Public-Cloud12-Updates | Yes | (r ) Yes | Yes
13 | SLES12-12-0 | SLES12-12-0 | Yes | ( p) Yes | Yes
14 | SUSE_Linux_Enterprise_Server_12_s390x:SLES12-Debuginfo-Pool | SLES12-Debuginfo-Pool | No | ---- | No
15 | SUSE_Linux_Enterprise_Server_12_s390x:SLES12-Debuginfo-Updates | SLES12-Debuginfo-Updates | No | ---- | Yes
16 | SUSE_Linux_Enterprise_Server_12_s390x:SLES12-Pool | SLES12-Pool | Yes | ( p) Yes | No
17 | SUSE_Linux_Enterprise_Server_12_s390x:SLES12-Updates | SLES12-Updates | Yes | (r ) Yes | Yes
18 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ s390x:SLE-SDK12-Debuginfo-Pool | SLE-SDK12-Debuginfo-Pool | No | ---- | No
19 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ s390x:SLE-SDK12-Debuginfo-Updates | SLE-SDK12-Debuginfo-Updates | No | ---- | Yes
20 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ s390x:SLE-SDK12-Pool | SLE-SDK12-Pool | Yes | ( p) Yes | No
21 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ s390x:SLE-SDK12-Updates | SLE-SDK12-Updates | Yes | (r ) Yes | Yes
22 | Web_and_Scripting_Module_12_s390x:SLE-Module-Web-Scripting12-Debuginfo-Pool | SLE-Module-Web-Scripting12-Debuginfo-Pool | No | ---- | No
23 | Web_and_Scripting_Module_12_s390x:SLE-Module-Web-Scripting12-Debuginfo-Updates | SLE-Module-Web-Scripting12-Debuginfo-Updates | No | ---- | Yes
24 | Web_and_Scripting_Module_12_s390x:SLE-Module-Web-Scripting12-Pool | SLE-Module-Web-Scripting12-Pool | Yes | ( p) Yes | No
25 | Web_and_Scripting_Module_12_s390x:SLE-Module-Web-Scripting12-Updates | SLE-Module-Web-Scripting12-Updates | Yes | (r ) Yes | Yes

Maybe 13?

-Frank

malcolmlewis
23-Oct-2015, 16:52
Hi
13 would be the install media and since you have the online repos can be disabled (I would leave in case needed);


zypper mr -d -R -p 101 13


You can also do that for any of the debug repos to move them out of the way, just use the uri number, to get them back if needed;


zypper mr -e -r -p 99 <uri>


I would now try forcing a refresh of the meta data;


zypper ref --force

frankrams
23-Oct-2015, 18:44
You are suggesting all of the 'Debuginfo' items?

# zypper --no-refresh lr | grep Debuginfo
1 | Advanced_Systems_Management_Module_12_s390x:SLE-Module-Adv-Systems-Management12-Debuginfo-Pool | SLE-Module-Adv-Systems-Management12-Debuginfo-Pool | No | ---- | No
2 | Advanced_Systems_Management_Module_12_s390x:SLE-Module-Adv-Systems-Management12-Debuginfo-Updates | SLE-Module-Adv-Systems-Management12-Debuginfo-Updates | No | ---- | Yes
5 | Legacy_Module_12_s390x:SLE-Module-Legacy12-Debuginfo-Pool | SLE-Module-Legacy12-Debuginfo-Pool | No | ---- | No
6 | Legacy_Module_12_s390x:SLE-Module-Legacy12-Debuginfo-Updates | SLE-Module-Legacy12-Debuginfo-Updates | No | ---- | Yes
9 | Public_Cloud_Module_12_s390x:SLE-Module-Public-Cloud12-Debuginfo-Pool | SLE-Module-Public-Cloud12-Debuginfo-Pool | No | ---- | No
10 | Public_Cloud_Module_12_s390x:SLE-Module-Public-Cloud12-Debuginfo-Updates | SLE-Module-Public-Cloud12-Debuginfo-Updates | No | ---- | Yes
14 | SUSE_Linux_Enterprise_Server_12_s390x:SLES12-Debuginfo-Pool | SLES12-Debuginfo-Pool | No | ---- | No
15 | SUSE_Linux_Enterprise_Server_12_s390x:SLES12-Debuginfo-Updates | SLES12-Debuginfo-Updates | No | ---- | Yes
18 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ s390x:SLE-SDK12-Debuginfo-Pool | SLE-SDK12-Debuginfo-Pool | No | ---- | No
19 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ s390x:SLE-SDK12-Debuginfo-Updates | SLE-SDK12-Debuginfo-Updates | No | ---- | Yes
22 | Web_and_Scripting_Module_12_s390x:SLE-Module-Web-Scripting12-Debuginfo-Pool | SLE-Module-Web-Scripting12-Debuginfo-Pool | No | ---- | No
23 | Web_and_Scripting_Module_12_s390x:SLE-Module-Web-Scripting12-Debuginfo-Updates | SLE-Module-Web-Scripting12-Debuginfo-Updates | No | ---- | Yes


-Frank

malcolmlewis
23-Oct-2015, 19:27
Hi
Yes, as you can see they are all disabled anyway, it just moves them out of the picture until needed. But it doesn't matter, your call ;)

frankrams
23-Oct-2015, 21:17
Malcolm,

Getting the same error during "Initializing Online Update. I don't think it's showing up in the list and is "cached" somewhere?

Any other ideas?

-Frank

malcolmlewis
23-Oct-2015, 22:00
On Fri 23 Oct 2015 08:24:02 PM CDT, frankrams wrote:


Malcolm,

Getting the same error during "Initializing Online Update. I don't
think it's showing up in the list and is "cached" somewhere?

Any other ideas?

-Frank




Hi
Is this error via zypper or YaST? If via YaST, can you use zypper to
update?


--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 | GNOME 3.10.1 | 3.12.48-52.27-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

frankrams
26-Oct-2015, 18:44
Hi
Is this error via zypper or YaST? If via YaST, can you use zypper to
update?


--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 | GNOME 3.10.1 | 3.12.48-52.27-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

This occurs from YAST (text user interface), after I select, "Software" then "Online Update".

-Frank

malcolmlewis
28-Oct-2015, 01:07
On Mon 26 Oct 2015 05:54:02 PM CDT, frankrams wrote:

malcolmlewis;30129 Wrote:
> Hi
> Is this error via zypper or YaST? If via YaST, can you use zypper to
> update?
>
>
> --
> Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter
> #276890)
> SUSE Linux Enterprise Desktop 12 | GNOME 3.10.1 |
> 3.12.48-52.27-default If you find this post helpful and are logged
> into the web interface, please show your appreciation and click on
> the star below... Thanks!

This occurs from YAST (text user interface), after I select, "Software"
then "Online Update".

-Frank




Hi
And if you use zypper instead?

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 | GNOME 3.10.1 | 3.12.48-52.27-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

frankrams
28-Oct-2015, 16:30
Pretty much the same as before:

zypper ref -s
Refreshing service 'Advanced_Systems_Management_Module_12_s390x'.
Refreshing service 'Legacy_Module_12_s390x'.
Refreshing service 'Public_Cloud_Module_12_s390x'.
Refreshing service 'SUSE_Linux_Enterprise_Server_12_s390x'.
Refreshing service 'SUSE_Linux_Enterprise_Software_Development_Kit_12 _s390x'.
Refreshing service 'Web_and_Scripting_Module_12_s390x'.
Refreshing service 'service'.
Unexpected exception.
Parse error: repoindex.xml[536] Couldn't find end of Start Tag div
History:
- repoindex.xml[536] attributes construct error
- repoindex.xml[536] AttValue: " or ' expected
- repoindex.xml[363] Entity 'nbsp' not defined
- repoindex.xml[362] Entity 'nbsp' not defined
- repoindex.xml[361] Entity 'nbsp' not defined
- repoindex.xml[360] Entity 'nbsp' not defined
- repoindex.xml[359] Entity 'nbsp' not defined
- repoindex.xml[338] Entity 'nbsp' not defined
- repoindex.xml[338] Entity 'nbsp' not defined
- repoindex.xml[187] Entity 'nbsp' not defined
- repoindex.xml[187] Entity 'nbsp' not defined

Please file a bug report about this.
See http://en.opensuse.org/Zypper/Troubleshooting for instructions.

-Frank

jmozdzen
29-Oct-2015, 16:39
Hi Frank,

you might have a look at /etc/zypp/repos.d and compared the files there with what you're seeing in the repos list - if there's any extra, that may well be your bad repos.

Have you run "zypper --clean -a" to clear any zypper cache?

Regards,
Jens

frankrams
02-Nov-2015, 17:50
zypper clean -a didn't help

Will compar /etc/zypp/repos to those listed.

Thanks,
Frank

frankrams
02-Nov-2015, 17:58
I'm just not seeing it:

┌───────────────────────────────────────────────── ────────────────────────────────────────────────── ───────────────┐
│Priority │Enabled│Autorefresh│Name │Service │
│ 99 (Default)│ x │ x │SLE-Module-Web-Scripting12-Updates │Web_and_Scripting_Module_1│
│ 99 (Default)│ x │ │SLE-Module-Adv-Systems-Management12-Debuginfo-Pool │Advanced_Systems_Managemen│
│ 99 (Default)│ x │ │SLES12-Debuginfo-Pool │SUSE_Linux_Enterprise_Serv│
│ 99 (Default)│ x │ │SLE-Module-Adv-Systems-Management12-Pool │Advanced_Systems_Managemen│
│ 99 (Default)│ x │ x │SLES12-Debuginfo-Updates │SUSE_Linux_Enterprise_Serv│
│ 99 (Default)│ x │ │SLE-Module-Legacy12-Debuginfo-Pool │Legacy_Module_12_s390x │
│ 99 (Default)│ x │ │SLES12-Pool │SUSE_Linux_Enterprise_Serv│
│ 99 (Default)│ x │ │SLE-Module-Legacy12-Pool │Legacy_Module_12_s390x │
│ 99 (Default)│ x │ x │SLES12-Updates │SUSE_Linux_Enterprise_Serv│
│ 99 (Default)│ x │ │SLE-Module-Public-Cloud12-Debuginfo-Pool │Public_Cloud_Module_12_s39│
│ 99 (Default)│ x │ │SLE-SDK12-Debuginfo-Pool │SUSE_Linux_Enterprise_Soft│
│ 99 (Default)│ x │ │SLE-Module-Public-Cloud12-Pool │Public_Cloud_Module_12_s39│
│ 99 (Default)│ x │ x │SLE-SDK12-Debuginfo-Updates │SUSE_Linux_Enterprise_Soft│
│ 99 (Default)│ x │ x │SLE-Module-Adv-Systems-Management12-Debuginfo-Updates│Advanced_Systems_Managemen│
│ 99 (Default)│ x │ │SLE-SDK12-Pool │SUSE_Linux_Enterprise_Soft│
│ 99 (Default)│ x │ x │SLE-Module-Legacy12-Debuginfo-Updates │Legacy_Module_12_s390x │
│ 99 (Default)│ x │ x │SLE-SDK12-Updates │SUSE_Linux_Enterprise_Soft│
│ 99 (Default)│ x │ x │SLE-Module-Public-Cloud12-Debuginfo-Updates │Public_Cloud_Module_12_s39│
│ 99 (Default)│ x │ │SLE-Module-Web-Scripting12-Debuginfo-Pool │Web_and_Scripting_Module_1│
│ 99 (Default)│ x │ x │SLE-Module-Adv-Systems-Management12-Updates │Advanced_Systems_Managemen│
│ 99 (Default)│ x │ x │SLE-Module-Web-Scripting12-Debuginfo-Updates │Web_and_Scripting_Module_1│
│ 99 (Default)│ x │ x │SLE-Module-Public-Cloud12-Updates │Public_Cloud_Module_12_s39│
│ 99 (Default)│ x │ │SLE-Module-Web-Scripting12-Pool │Web_and_Scripting_Module_1│
│ 99 (Default)│ x │ x │SLE-Module-Legacy12-Updates │Legacy_Module_12_s390x │
│101 │ │ │SLES12-12-0 │ │
------------------------------------------------------------------
/etc/zypp/repos.d # ls -l
total 100
-rw-r--r-- 1 root root 539 Nov 2 10:54 Advanced_Systems_Management_Module_12_s390x:SLE-Module-Adv-Systems-Management12-Debuginfo-Pool.repo
-rw-r--r-- 1 root root 540 Nov 2 10:54 Advanced_Systems_Management_Module_12_s390x:SLE-Module-Adv-Systems-Management12-Debuginfo-Updates.repo
-rw-r--r-- 1 root root 505 Nov 2 10:54 Advanced_Systems_Management_Module_12_s390x:SLE-Module-Adv-Systems-Management12-Pool.repo
-rw-r--r-- 1 root root 506 Nov 2 10:54 Advanced_Systems_Management_Module_12_s390x:SLE-Module-Adv-Systems-Management12-Updates.repo
-rw-r--r-- 1 root root 427 Nov 2 10:54 Legacy_Module_12_s390x:SLE-Module-Legacy12-Debuginfo-Pool.repo
-rw-r--r-- 1 root root 429 Nov 2 10:54 Legacy_Module_12_s390x:SLE-Module-Legacy12-Debuginfo-Updates.repo
-rw-r--r-- 1 root root 393 Nov 2 10:54 Legacy_Module_12_s390x:SLE-Module-Legacy12-Pool.repo
-rw-r--r-- 1 root root 395 Nov 2 10:54 Legacy_Module_12_s390x:SLE-Module-Legacy12-Updates.repo
-rw-r--r-- 1 root root 465 Nov 2 10:54 Public_Cloud_Module_12_s390x:SLE-Module-Public-Cloud12-Debuginfo-Pool.repo
-rw-r--r-- 1 root root 467 Nov 2 10:54 Public_Cloud_Module_12_s390x:SLE-Module-Public-Cloud12-Debuginfo-Updates.repo
-rw-r--r-- 1 root root 431 Nov 2 10:54 Public_Cloud_Module_12_s390x:SLE-Module-Public-Cloud12-Pool.repo
-rw-r--r-- 1 root root 433 Nov 2 10:54 Public_Cloud_Module_12_s390x:SLE-Module-Public-Cloud12-Updates.repo
-rw-r--r-- 1 root root 188 Nov 2 10:54 SLES12-12-0.repo
-rw-r--r-- 1 root root 415 Nov 2 10:54 SUSE_Linux_Enterprise_Server_12_s390x:SLES12-Debuginfo-Pool.repo
-rw-r--r-- 1 root root 416 Nov 2 10:54 SUSE_Linux_Enterprise_Server_12_s390x:SLES12-Debuginfo-Updates.repo
-rw-r--r-- 1 root root 381 Nov 2 10:54 SUSE_Linux_Enterprise_Server_12_s390x:SLES12-Pool.repo
-rw-r--r-- 1 root root 382 Nov 2 10:54 SUSE_Linux_Enterprise_Server_12_s390x:SLES12-Updates.repo
-rw-r--r-- 1 root root 450 Nov 2 10:54 SUSE_Linux_Enterprise_Software_Development_Kit_12_ s390x:SLE-SDK12-Debuginfo-Pool.repo
-rw-r--r-- 1 root root 451 Nov 2 10:54 SUSE_Linux_Enterprise_Software_Development_Kit_12_ s390x:SLE-SDK12-Debuginfo-Updates.repo
-rw-r--r-- 1 root root 416 Nov 2 10:54 SUSE_Linux_Enterprise_Software_Development_Kit_12_ s390x:SLE-SDK12-Pool.repo
-rw-r--r-- 1 root root 417 Nov 2 10:54 SUSE_Linux_Enterprise_Software_Development_Kit_12_ s390x:SLE-SDK12-Updates.repo
-rw-r--r-- 1 root root 480 Nov 2 10:54 Web_and_Scripting_Module_12_s390x:SLE-Module-Web-Scripting12-Debuginfo-Pool.repo
-rw-r--r-- 1 root root 481 Nov 2 10:54 Web_and_Scripting_Module_12_s390x:SLE-Module-Web-Scripting12-Debuginfo-Updates.repo
-rw-r--r-- 1 root root 446 Nov 2 10:54 Web_and_Scripting_Module_12_s390x:SLE-Module-Web-Scripting12-Pool.repo
-rw-r--r-- 1 root root 447 Nov 2 10:54 Web_and_Scripting_Module_12_s390x:SLE-Module-Web-Scripting12-Updates.repo


-Frank

malcolmlewis
02-Nov-2015, 18:04
Hi
I think you might have to go through and disable all repo's and refresh, then add them back one at a time and force a cache refresh....



zypper mr -d -R -a

The above will disable them all and disable refresh, then add one by one;


zypper mr -e -r 1
zypper ref -f
zypper mr -e -r 2
zypper ref -f
etc...

frankrams
02-Nov-2015, 18:11
Appears the reference is comeing from /etc/zypp/services.d/service:

/etc/zypp/services.d # cat service.service
[service]
name=service
enabled=1
autorefresh=1
url = http://software.opensuse.org/ymp/utilities/SLE_12/incron.ymp
type = ris

-Frank

frankrams
03-Nov-2015, 19:49
Appears the reference is comeing from /etc/zypp/services.d/service:

/etc/zypp/services.d # cat service.service
[service]
name=service
enabled=1
autorefresh=1
url = http://software.opensuse.org/ymp/utilities/SLE_12/incron.ymp
type = ris

-Frank

I simply 'mv /etc/zypp/services.d/service ~' and everything seems to be good!

Thanks all,
Frank