PDA

View Full Version : SLES 11 SP4 Update to SLES 11 SP4 - x2go disappeared



berndgsflinux
04-Nov-2015, 13:35
Hi,

i have the impression that the update from SLES 11 SP3 to SP4 had the effect that the packages from x2go disappeared. Is anyone else experiencing the same ? Is there a log from the update to see what it did ?

Thanks.


Bernd

berndgsflinux
04-Nov-2015, 13:59
I checked it with a backup. And yes, files from x2go disappeared. Why did that happen ? The release notes don't tell anything about x2go ! Is there a log to check what the update did ?

Bernd

malcolmlewis
04-Nov-2015, 15:13
On Wed 04 Nov 2015 01:04:02 PM CST, berndgsflinux wrote:

I checked it with a backup. And yes, files from x2go disappeared. Why
did that happen ? The release notes don't tell anything about x2go ! Is
there a log to check what the update did ?

Bernd




Hi
If they are not part of the SP4 update (as in manually installed), then
yes you will need to re-install any third party items...


--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 | GNOME 3.10.1 | 3.12.48-52.27-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

berndgsflinux
04-Nov-2015, 15:59
Hi,

i found out several things:

zypper logs to /var/log/zypp and to /var/log/zypper.log.
It seems that the update to SLES 11 SP4 removed the package:
/var/log/zypp/history says:

# 2015-11-03 18:06:47 Sicherung /mnt/var/adm/backup/x2goserver-4.0.1.8-2.5.x86_64-20151103-0.tar.gz erstellt
# 2015-11-03 18:06:47 x2goserver-4.0.1.8-2.5.x86_64 removed ok
# Additional rpm output:
# warning: /etc/x2go/x2goserver.conf saved as /etc/x2go/x2goserver.conf.rpmsave
#
2015-11-03 18:06:47|remove |x2goserver|4.0.1.8-2.5|x86_64||



Before the update i had a repo for x2go, this has also vanished.
I also have a packet x2goagent-3.5.0.32-3.1, this was not uninstalled.

Is this behaviour by design ? I don't like the imagination that an update removes packages and repositories.


Bernd

berndgsflinux
04-Nov-2015, 16:09
Hi
If they are not part of the SP4 update (as in manually installed), then
yes you will need to re-install any third party items...


Hi,
Malcom, are you sure ? This can't be. E.g. i have a backup software (lgtoclnt-8.0.1.1-1) which did not need to be reinstalled. Also some HP management stuff (hpsim-C.07.04.00.00-1) did not need to be re-installed. It's absolut unthinkable that an update to a higher release of SLES deletes all third party items. That never happened before, and i startet with SLES 10.

Bernd

berndgsflinux
04-Nov-2015, 18:08
Hi,

i tried to re-install x2go-server. Zypper blaims about missing dependencies:

=========================================
pc60181:~ # zypper -v in x2goserver-4.0.1.8-2.6.x86_64.rpm
Verbosity: 1
Non-option program arguments: 'x2goserver-4.0.1.8-2.6.x86_64.rpm'
'x2goserver-4.0.1.8-2.6.x86_64.rpm' looks like an RPM file. Will try to download it.
Initializing Target
Refreshing service 'nu_novell_com'.
Retrieving: repoindex.xml [done]
Checking whether to refresh metadata for Plain RPM files cache
Checking whether to refresh metadata for SLES11-SP4-Pool
Checking whether to refresh metadata for SLES11-SP4-Updates
Loading repository data...
Reading installed packages...
Force resolution: No
Selecting 'x2goserver-4.0.1.8-2.6.x86_64' from repository 'Plain RPM files cache' for installation.
Resolving package dependencies...
Force resolution: No

Problem: x2goserver-4.0.1.8-2.6.x86_64 requires perl(DBD::SQLite) >= 1.27, but this requirement cannot be provided
uninstallable providers: perl-DBD-SQLite-1.40-30.1.x86_64[_tmpRPMcache_]
Solution 1: install perl-DBD-SQLite-1.40-30.1.x86_64 (with vendor change)
SUSE LINUX Products GmbH, Nuernberg, Germany --> obs://build.opensuse.org/devel:languages:perl
Solution 2: do not install x2goserver-4.0.1.8-2.6.x86_64
Solution 3: break x2goserver-4.0.1.8-2.6.x86_64 by ignoring some of its dependencies
================================================== ===

I choosed 1 and something strange happened:

================================================== ===
Choose from above solutions by number or cancel [1/2/3/c] (c): 1
Applying solution 1
Resolving dependencies...
Resolving package dependencies...
Force resolution: No

The following NEW package is going to be installed:
x2goserver 4.0.1.8-2.6


The following package is going to be upgraded:
perl-DBD-SQLite 1.14-11.14 -> 1.40-30.1


The following package is going to change vendor:
perl-DBD-SQLite 1.14-11.14 -> 1.40-30.1 SUSE LINUX Products GmbH, Nuernberg, Germany -> obs://build.opensuse.org/devel:languages:perl


The following packages are not supported by their vendor:
perl-DBD-SQLite 1.40-30.1
x2goserver 4.0.1.8-2.6
================================================== ===

Zypper finds a newer version of perl-DBD-SQLite. But "zypper se -s dbd shows just an old version:

================================================== ===
pc60181:~ # zypper se -s dbd
Refreshing service 'nu_novell_com'.
Loading repository data...
Reading installed packages...

S | Name | Type | Version | Arch | Repository
--+--------------------------+------------+-------------------------+--------+-------------------------------------------------
| libapr-util1-dbd-sqlite3 | package | 1.3.4-12.22.23.1 | x86_64 | SLES11-SP4-Pool
| libapr-util1-dbd-sqlite3 | package | 1.3.4-12.22.23.1 | x86_64 | SUSE-Linux-Enterprise-Server-11-SP4 11.4.4-1.109
i | perl-DBD-Pg | package | 2.19.2-1.5.388.g2d256b3 | x86_64 | (System Packages)
i | perl-DBD-SQLite | package | 1.14-11.14 | x86_64 | SLES11-SP4-Pool
i | perl-DBD-SQLite | package | 1.14-11.14 | x86_64 | SUSE-Linux-Enterprise-Server-11-SP4 11.4.4-1.109
| perl-DBD-SQLite | srcpackage | 1.14-11.14 | noarch | SUSE-Linux-Enterprise-Server-11-SP4 11.4.4-1.109
| perl-DBD-mysql | package | 4.008-4.3 | x86_64 | SLES11-SP4-Pool
| perl-DBD-mysql | package | 4.008-4.3 | x86_64 | SUSE-Linux-Enterprise-Server-11-SP4 11.4.4-1.109
| perl-DBD-mysql | srcpackage | 4.008-4.3 | noarch | SUSE-Linux-Enterprise-Server-11-SP4 11.4.4-1.109
================================================== ====

Where does it find version 1.40 ? It seems that it comes from the Open Build Service from OpenSuSE.
But this is not configured as a repository:

=================================================
pc60181:~ # zypper sl
# | Alias | Name | Enabled | Refresh | Type
--+--------------------------------------------------+--------------------------------------------------+---------+---------+------
1 | nu_novell_com | nu_novell_com | Yes | Yes | ris
2 | SUSE-Linux-Enterprise-Server-11-SP4 11.4.4-1.109 | SUSE-Linux-Enterprise-Server-11-SP4 11.4.4-1.109 | Yes | No | yast2

pc60181:~ # zypper lr
# | Alias | Name | Enabled | Refresh
---+--------------------------------------------------+--------------------------------------------------+---------+--------
1 | SUSE-Linux-Enterprise-Server-11-SP4 11.4.4-1.109 | SUSE-Linux-Enterprise-Server-11-SP4 11.4.4-1.109 | Yes | No
2 | nu_novell_com:SLE11-Public-Cloud-Module | SLE11-Public-Cloud-Module | No | Yes
3 | nu_novell_com:SLE11-SP1-Debuginfo-Pool | SLE11-SP1-Debuginfo-Pool | No | Yes
4 | nu_novell_com:SLE11-SP1-Debuginfo-Updates | SLE11-SP1-Debuginfo-Updates | No | Yes
5 | nu_novell_com:SLE11-SP2-Debuginfo-Core | SLE11-SP2-Debuginfo-Core | No | Yes
6 | nu_novell_com:SLE11-SP2-Debuginfo-Updates | SLE11-SP2-Debuginfo-Updates | No | Yes
7 | nu_novell_com:SLE11-SP3-Debuginfo-Pool | SLE11-SP3-Debuginfo-Pool | No | Yes
8 | nu_novell_com:SLE11-SP3-Debuginfo-Updates | SLE11-SP3-Debuginfo-Updates | No | Yes
9 | nu_novell_com:SLE11-SP4-Debuginfo-Pool | SLE11-SP4-Debuginfo-Pool | No | Yes
10 | nu_novell_com:SLE11-SP4-Debuginfo-Updates | SLE11-SP4-Debuginfo-Updates | No | Yes
11 | nu_novell_com:SLE11-Security-Module | SLE11-Security-Module | No | Yes
12 | nu_novell_com:SLE11-WebYaST-SP2-Pool | SLE11-WebYaST-SP2-Pool | No | Yes
13 | nu_novell_com:SLE11-WebYaST-SP2-Updates | SLE11-WebYaST-SP2-Updates | No | Yes
14 | nu_novell_com:SLES11-Extras | SLES11-Extras | No | Yes
15 | nu_novell_com:SLES11-SP1-Pool | SLES11-SP1-Pool | No | Yes
16 | nu_novell_com:SLES11-SP1-Updates | SLES11-SP1-Updates | No | Yes
17 | nu_novell_com:SLES11-SP2-Core | SLES11-SP2-Core | No | Yes
18 | nu_novell_com:SLES11-SP2-Extension-Store | SLES11-SP2-Extension-Store | No | Yes
19 | nu_novell_com:SLES11-SP2-Updates | SLES11-SP2-Updates | No | Yes
20 | nu_novell_com:SLES11-SP3-Extension-Store | SLES11-SP3-Extension-Store | No | Yes
21 | nu_novell_com:SLES11-SP3-Pool | SLES11-SP3-Pool | No | Yes
22 | nu_novell_com:SLES11-SP3-Updates | SLES11-SP3-Updates | No | Yes
23 | nu_novell_com:SLES11-SP4-Pool | SLES11-SP4-Pool | Yes | Yes
24 | nu_novell_com:SLES11-SP4-Updates | SLES11-SP4-Updates | Yes | Yes
================================================== =====

How does it find the desired package, and why does it connect to the OBS from OpenSuSE ?

Bernd

malcolmlewis
04-Nov-2015, 18:41
On Wed 04 Nov 2015 05:14:02 PM CST, berndgsflinux wrote:

Hi,

i tried to re-install x2go-server. Zypper blaims about missing
dependencies:



pc60181:~ # zypper -v in x2goserver-4.0.1.8-2.6.x86_64.rpm
Verbosity: 1
Non-option program arguments: 'x2goserver-4.0.1.8-2.6.x86_64.rpm'
'x2goserver-4.0.1.8-2.6.x86_64.rpm' looks like an RPM file. Will try to
download it.
Initializing Target
Refreshing service 'nu_novell_com'.
Retrieving: repoindex.xml [done]
Checking whether to refresh metadata for Plain RPM files cache
Checking whether to refresh metadata for SLES11-SP4-Pool
Checking whether to refresh metadata for SLES11-SP4-Updates
Loading repository data...
Reading installed packages...
Force resolution: No
Selecting 'x2goserver-4.0.1.8-2.6.x86_64' from repository 'Plain RPM
files cache' for installation.
Resolving package dependencies...
Force resolution: No

Problem: x2goserver-4.0.1.8-2.6.x86_64 requires perl(DBD::SQLite) >=
1.27, but this requirement cannot be provided
uninstallable providers:
perl-DBD-SQLite-1.40-30.1.x86_64[_tmpRPMcache_]
Solution 1: install perl-DBD-SQLite-1.40-30.1.x86_64 (with vendor
change)
SUSE LINUX Products GmbH, Nuernberg, Germany -->
obs://build.opensuse.org/devel:languages:perl
Solution 2: do not install x2goserver-4.0.1.8-2.6.x86_64
Solution 3: break x2goserver-4.0.1.8-2.6.x86_64 by ignoring some of its
dependencies


How does it find the desired package, and why does it connect to the OBS
from OpenSuSE ?

Bernd




Hi
Sounds like it was configured (devel:languages:perl) as a repository at
some point. Check down in /etc/zypp/repos.d, also run zypper lr -d
command and check the url's.

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 | GNOME 3.10.1 | 3.12.48-52.27-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

berndgsflinux
04-Nov-2015, 19:31
Hi
Sounds like it was configured (devel:languages:perl) as a repository at
some point. Check down in /etc/zypp/repos.d, also run zypper lr -d
command and check the url's.


Hi,
i can't remember having configured this repository. And a backup from before the update to SLES 11 SP4 just have a x2go repository beneath the repositories from novell, no repository from OpenSuSE.

The current situation is:

================================================== =
pc60181:~ # l /etc/zypp/repos.d/
total 104
drwxr-xr-x 2 root root 4096 Nov 4 17:54 ./
drwxr-xr-x 5 root root 4096 Nov 3 16:30 ../
-rw-r--r-- 1 root root 194 Nov 3 17:17 SUSE-Linux-Enterprise-Server-11-SP4 11.4.4-1.109.repo
-rw-r--r-- 1 root root 236 Nov 3 17:17 nu_novell_com:SLE11-Public-Cloud-Module.repo
-rw-r--r-- 1 root root 233 Nov 3 17:17 nu_novell_com:SLE11-SP1-Debuginfo-Pool.repo
-rw-r--r-- 1 root root 242 Nov 3 17:17 nu_novell_com:SLE11-SP1-Debuginfo-Updates.repo
-rw-r--r-- 1 root root 233 Nov 3 17:17 nu_novell_com:SLE11-SP2-Debuginfo-Core.repo
-rw-r--r-- 1 root root 242 Nov 3 17:17 nu_novell_com:SLE11-SP2-Debuginfo-Updates.repo
-rw-r--r-- 1 root root 233 Nov 3 17:17 nu_novell_com:SLE11-SP3-Debuginfo-Pool.repo
-rw-r--r-- 1 root root 242 Nov 3 17:17 nu_novell_com:SLE11-SP3-Debuginfo-Updates.repo
-rw-r--r-- 1 root root 233 Nov 3 17:17 nu_novell_com:SLE11-SP4-Debuginfo-Pool.repo
-rw-r--r-- 1 root root 242 Nov 3 17:17 nu_novell_com:SLE11-SP4-Debuginfo-Updates.repo
-rw-r--r-- 1 root root 224 Nov 3 17:17 nu_novell_com:SLE11-Security-Module.repo
-rw-r--r-- 1 root root 227 Nov 3 17:17 nu_novell_com:SLE11-WebYaST-SP2-Pool.repo
-rw-r--r-- 1 root root 236 Nov 3 17:17 nu_novell_com:SLE11-WebYaST-SP2-Updates.repo
-rw-r--r-- 1 root root 200 Nov 3 17:17 nu_novell_com:SLES11-Extras.repo
-rw-r--r-- 1 root root 206 Nov 3 17:17 nu_novell_com:SLES11-SP1-Pool.repo
-rw-r--r-- 1 root root 215 Nov 3 17:17 nu_novell_com:SLES11-SP1-Updates.repo
-rw-r--r-- 1 root root 206 Nov 3 17:17 nu_novell_com:SLES11-SP2-Core.repo
-rw-r--r-- 1 root root 239 Nov 3 17:17 nu_novell_com:SLES11-SP2-Extension-Store.repo
-rw-r--r-- 1 root root 215 Nov 3 17:17 nu_novell_com:SLES11-SP2-Updates.repo
-rw-r--r-- 1 root root 239 Nov 3 17:17 nu_novell_com:SLES11-SP3-Extension-Store.repo
-rw-r--r-- 1 root root 206 Nov 3 17:17 nu_novell_com:SLES11-SP3-Pool.repo
-rw-r--r-- 1 root root 215 Nov 3 17:17 nu_novell_com:SLES11-SP3-Updates.repo
-rw-r--r-- 1 root root 208 Nov 3 17:17 nu_novell_com:SLES11-SP4-Pool.repo
-rw-r--r-- 1 root root 217 Nov 3 17:17 nu_novell_com:SLES11-SP4-Updates.repo

pc60181:~ # l /etc/zypp/services.d/
total 12
drwxr-xr-x 2 root root 4096 May 25 23:24 ./
drwxr-xr-x 5 root root 4096 Nov 3 16:30 ../
-rw-r--r-- 1 root root 126 Nov 3 17:17 nu_novell_com.service


pc60181:~ # zypper lr -d
# | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
---+--------------------------------------------------+--------------------------------------------------+---------+---------+----------+--------+------------------------------------------------------------------------------------------------------+--------------
1 | SUSE-Linux-Enterprise-Server-11-SP4 11.4.4-1.109 | SUSE-Linux-Enterprise-Server-11-SP4 11.4.4-1.109 | Yes | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
2 | nu_novell_com:SLE11-Public-Cloud-Module | SLE11-Public-Cloud-Module | No | Yes | 99 | NONE | https://nu.novell.com/repo/$RCE/SLE11-Public-Cloud-Module/sle-11-x86_64?credentials=NCCcredentials | nu_novell_com
3 | nu_novell_com:SLE11-SP1-Debuginfo-Pool | SLE11-SP1-Debuginfo-Pool | No | Yes | 99 | NONE | https://nu.novell.com/repo/$RCE/SLE11-SP1-Debuginfo-Pool/sle-11-x86_64?credentials=NCCcredentials | nu_novell_com
4 | nu_novell_com:SLE11-SP1-Debuginfo-Updates | SLE11-SP1-Debuginfo-Updates | No | Yes | 99 | NONE | https://nu.novell.com/repo/$RCE/SLE11-SP1-Debuginfo-Updates/sle-11-x86_64?credentials=NCCcredentials | nu_novell_com
5 | nu_novell_com:SLE11-SP2-Debuginfo-Core | SLE11-SP2-Debuginfo-Core | No | Yes | 99 | NONE | https://nu.novell.com/repo/$RCE/SLE11-SP2-Debuginfo-Core/sle-11-x86_64?credentials=NCCcredentials | nu_novell_com
6 | nu_novell_com:SLE11-SP2-Debuginfo-Updates | SLE11-SP2-Debuginfo-Updates | No | Yes | 99 | NONE | https://nu.novell.com/repo/$RCE/SLE11-SP2-Debuginfo-Updates/sle-11-x86_64?credentials=NCCcredentials | nu_novell_com
7 | nu_novell_com:SLE11-SP3-Debuginfo-Pool | SLE11-SP3-Debuginfo-Pool | No | Yes | 99 | NONE | https://nu.novell.com/repo/$RCE/SLE11-SP3-Debuginfo-Pool/sle-11-x86_64?credentials=NCCcredentials | nu_novell_com
8 | nu_novell_com:SLE11-SP3-Debuginfo-Updates | SLE11-SP3-Debuginfo-Updates | No | Yes | 99 | NONE | https://nu.novell.com/repo/$RCE/SLE11-SP3-Debuginfo-Updates/sle-11-x86_64?credentials=NCCcredentials | nu_novell_com
9 | nu_novell_com:SLE11-SP4-Debuginfo-Pool | SLE11-SP4-Debuginfo-Pool | No | Yes | 99 | NONE | https://nu.novell.com/repo/$RCE/SLE11-SP4-Debuginfo-Pool/sle-11-x86_64?credentials=NCCcredentials | nu_novell_com
10 | nu_novell_com:SLE11-SP4-Debuginfo-Updates | SLE11-SP4-Debuginfo-Updates | No | Yes | 99 | NONE | https://nu.novell.com/repo/$RCE/SLE11-SP4-Debuginfo-Updates/sle-11-x86_64?credentials=NCCcredentials | nu_novell_com
11 | nu_novell_com:SLE11-Security-Module | SLE11-Security-Module | No | Yes | 99 | NONE | https://nu.novell.com/repo/$RCE/SLE11-Security-Module/sle-11-x86_64?credentials=NCCcredentials | nu_novell_com
12 | nu_novell_com:SLE11-WebYaST-SP2-Pool | SLE11-WebYaST-SP2-Pool | No | Yes | 99 | NONE | https://nu.novell.com/repo/$RCE/SLE11-WebYaST-SP2-Pool/sle-11-x86_64?credentials=NCCcredentials | nu_novell_com
13 | nu_novell_com:SLE11-WebYaST-SP2-Updates | SLE11-WebYaST-SP2-Updates | No | Yes | 99 | NONE | https://nu.novell.com/repo/$RCE/SLE11-WebYaST-SP2-Updates/sle-11-x86_64?credentials=NCCcredentials | nu_novell_com
14 | nu_novell_com:SLES11-Extras | SLES11-Extras | No | Yes | 99 | NONE | https://nu.novell.com/repo/$RCE/SLES11-Extras/sle-11-x86_64?credentials=NCCcredentials | nu_novell_com
15 | nu_novell_com:SLES11-SP1-Pool | SLES11-SP1-Pool | No | Yes | 99 | NONE | https://nu.novell.com/repo/$RCE/SLES11-SP1-Pool/sle-11-x86_64?credentials=NCCcredentials | nu_novell_com
16 | nu_novell_com:SLES11-SP1-Updates | SLES11-SP1-Updates | No | Yes | 99 | NONE | https://nu.novell.com/repo/$RCE/SLES11-SP1-Updates/sle-11-x86_64?credentials=NCCcredentials | nu_novell_com
17 | nu_novell_com:SLES11-SP2-Core | SLES11-SP2-Core | No | Yes | 99 | NONE | https://nu.novell.com/repo/$RCE/SLES11-SP2-Core/sle-11-x86_64?credentials=NCCcredentials | nu_novell_com
18 | nu_novell_com:SLES11-SP2-Extension-Store | SLES11-SP2-Extension-Store | No | Yes | 99 | NONE | https://nu.novell.com/repo/$RCE/SLES11-SP2-Extension-Store/sle-11-x86_64?credentials=NCCcredentials | nu_novell_com
19 | nu_novell_com:SLES11-SP2-Updates | SLES11-SP2-Updates | No | Yes | 99 | NONE | https://nu.novell.com/repo/$RCE/SLES11-SP2-Updates/sle-11-x86_64?credentials=NCCcredentials | nu_novell_com
20 | nu_novell_com:SLES11-SP3-Extension-Store | SLES11-SP3-Extension-Store | No | Yes | 99 | NONE | https://nu.novell.com/repo/$RCE/SLES11-SP3-Extension-Store/sle-11-x86_64?credentials=NCCcredentials | nu_novell_com
21 | nu_novell_com:SLES11-SP3-Pool | SLES11-SP3-Pool | No | Yes | 99 | NONE | https://nu.novell.com/repo/$RCE/SLES11-SP3-Pool/sle-11-x86_64?credentials=NCCcredentials | nu_novell_com
22 | nu_novell_com:SLES11-SP3-Updates | SLES11-SP3-Updates | No | Yes | 99 | NONE | https://nu.novell.com/repo/$RCE/SLES11-SP3-Updates/sle-11-x86_64?credentials=NCCcredentials | nu_novell_com
23 | nu_novell_com:SLES11-SP4-Pool | SLES11-SP4-Pool | Yes | Yes | 99 | rpm-md | https://nu.novell.com/repo/$RCE/SLES11-SP4-Pool/sle-11-x86_64?credentials=NCCcredentials | nu_novell_com
24 | nu_novell_com:SLES11-SP4-Updates | SLES11-SP4-Updates | Yes | Yes | 99 | rpm-md | https://nu.novell.com/repo/$RCE/SLES11-SP4-Updates/sle-11-x86_64?credentials=NCCcredentials | nu_novell_com
================================================== ===============


Bernd

smflood
05-Nov-2015, 11:39
Problem: x2goserver-4.0.1.8-2.6.x86_64 requires perl(DBD::SQLite) >= 1.27, but this requirement cannot be provided
uninstallable providers: perl-DBD-SQLite-1.40-30.1.x86_64[_tmpRPMcache_]

Given there doesn't appear to be any configured repo in the outputs you've posted I wonder if the reference to "_tmpRPMcache" above is significant. What does the following report?
find /var/cache/zypper -iname '*dbd*'

HTH.

berndgsflinux
05-Nov-2015, 11:52
Given there doesn't appear to be any configured repo in the outputs you've posted I wonder if the reference to "_tmpRPMcache" above is significant. What does the following report?
find /var/cache/zypper -iname '*dbd*'

HTH.

Hi,

pc60181:~ # find /var/cache/zypper -iname '*dbd*' -exec ls -la {} \;

-rwxr-xr-x 1 root root 147289 May 24 2013 /var/cache/zypper/RPMS/perl-DBD-Pg-2.19.2-1.5.388.g2d256b3.x86_64.rpm
-rwxr-xr-x 1 root root 505193 Mar 17 2014 /var/cache/zypper/RPMS/perl-DBD-SQLite-1.40-30.1.x86_64.rpm

Interesting. Where do these files come from ? Rudiments from previous installations ?


Bernd

smflood
05-Nov-2015, 12:11
pc60181:~ # find /var/cache/zypper -iname '*dbd*' -exec ls -la {} \;

-rwxr-xr-x 1 root root 147289 May 24 2013 /var/cache/zypper/RPMS/perl-DBD-Pg-2.19.2-1.5.388.g2d256b3.x86_64.rpm
-rwxr-xr-x 1 root root 505193 Mar 17 2014 /var/cache/zypper/RPMS/perl-DBD-SQLite-1.40-30.1.x86_64.rpm

Interesting. Where do these files come from ? Rudiments from previous installations ?

I'm guessing that those files remain from when x2go was originally installed under SLES11 SP3 if perl-DBD-SQLite was a required package and need upgrading. /var/log/zypp/history should show some evidence of whether these were added in the past and where from plus should also show whether the OBS repo was ever added (search for "radd").

HTH.

berndgsflinux
05-Nov-2015, 15:25
Hi,

i found out some interesting points.
/var/cache/zypper/RPM contains all the rpm's i installed manually. Among others there is perl-DBD-SQLite-1.40-30.1.x86_64.rpm.

rpm -qip perl-DBD-SQLite-1.40-30.1.x86_64.rpm says:

Name : perl-DBD-SQLite Relocations: (not relocatable)
================================================== ===
Version : 1.40 Vendor: obs://build.opensuse.org/devel:languages:perl
================================================== ===
Release : 30.1 Build Date: Thu Dec 12 02:12:17 2013
Install Date: (not installed) Build Host: build13
...

The obs://build.opensuse.org/devel:languages:perl is not a configured repository (and never was) but it is an information from the package itself.


Zypper found it because it was manullay installed before, situated in /var/cache/zypper/RPM and could fulfill this dependency (see my previous posting).

Here is an excerpt from the manual installation: /var/log/zypp/history:
...
2014-03-17 15:22:52|radd |_tmpRPMcache_|dir:///var/cache/zypper/RPMS|
# 2014-03-17 15:23:03 perl-DBD-SQLite-1.40-30.1.x86_64.rpm installed ok
# Additional rpm output:
# warning: /var/cache/zypp/packages/_tmpRPMcache_/perl-DBD-SQLite-1.40-30.1.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID dcef338c
#
2014-03-17 15:23:03|install|perl-DBD-SQLite|1.40-30.1|x86_64|root@pc60181|_tmpRPMcache_||
2014-03-17 15:23:03|rremove|_tmpRPMcache_|
...

The repository "_tmpRPMcahce" is always added when installing software manually and directly afterwards removed.


And why has x2goserver been uninstalled ? Well, the update to SLES 11 SP4 installed perl-DBD-SQLite-1.14-11.14. While doing that, perl-DBD-SQLite-1.40 was uninstalled. But the newer version was a dependency for x2goserver:

pc60181:/var/cache/zypper/RPMS # rpm -qR x2goserver
...
perl(DBD::SQLite) >= 1.27
...

So x2goserver was broken because of missing dependency and due to that it was uninstalled:


/var/log/zypp/history:
...
2015-11-03 18:06:46|install|uuid-runtime|2.19.1-6.72.1|x86_64||SUSE-Linux-Enterprise-Server-11-SP4 11.4.4-1.109|e45118be5ab1814dad4beb548777a666acee6acb|
2015-11-03 18:06:46|install|perl-SNMP|5.4.2.1-8.12.22.1|x86_64||SUSE-Linux-Enterprise-Server-11-SP4 11.4.4-1.109|299fa378effb83a642df0fea811eb906d8d0dfc4|

2015-11-03 18:06:47|install|perl-DBD-SQLite|1.14-11.14|x86_64||SUSE-Linux-Enterprise-Server-11-SP4 11.4.4-1.109|f3e6f7a7668efc35b8ac7e4c8cb71f5d96bbcfbf|
# 2015-11-03 18:06:47 Sicherung /mnt/var/adm/backup/x2goserver-4.0.1.8-2.5.x86_64-20151103-0.tar.gz erstellt

# 2015-11-03 18:06:47 x2goserver-4.0.1.8-2.5.x86_64 removed ok

# Additional rpm output:
# warning: /etc/x2go/x2goserver.conf saved as /etc/x2go/x2goserver.conf.rpmsave
#
2015-11-03 18:06:47|remove |x2goserver|4.0.1.8-2.5|x86_64||
...


Bernd

berndgsflinux
05-Nov-2015, 15:30
Hi,

sorry for the stupid smiley. I don't know from where it comes.


Bernd