PDA

View Full Version : SLES11SP2 through YaST



April
29-Feb-2012, 22:32
Why do I not see sp2 available through YaST\online update? Do I need to
do some additional configuration before I can sp2?

Please advise! Thank you very much!

malcolmlewis
02-Mar-2012, 04:08
Why do I not see sp2 available through YaST\online update?
Do I need to do some additional configuration before I can sp2?

Please advise! Thank you very much!

Hi
It's detailed in the README using YaST wagon;
http://www.novell.com/linux/releasenotes/i386/SUSE-SLES/11-SP2/#fate-311994

--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
up 5 days 0:13, 2 users, load average: 0.01, 0.03, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

gehne
02-Mar-2012, 12:03
I've tried "yast2 wagon" several times, but the repositories did not change (still sles11sp1-repos).
The registration is still valid, all patches installed - what's wrong? I have no idea.


Hi
It's detailed in the README using YaST wagon;
http://www.novell.com/linux/releasenotes/i386/SUSE-SLES/11-SP2/#fate-311994

--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
up 5 days 0:13, 2 users, load average: 0.01, 0.03, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

April
02-Mar-2012, 16:38
On 3/2/2012 5:04 AM, gehne wrote:
>
> I've tried "yast2 wagon" several times, but the repositories did not
> change (still sles11sp1-repos).
> The registration is still valid, all patches installed - what's wrong?
> I have no idea.
>
> malcolmlewis;2761 Wrote:
>> Hi
>> It's detailed in the README using YaST wagon;
>> http://www.novell.com/linux/releasenotes/i386/SUSE-SLES/11-SP2/#fate-311994
>>
>> --
>> Cheers Malcolm °¿° (Linux Counter #276890)
>> SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
>> up 5 days 0:13, 2 users, load average: 0.01, 0.03, 0.05
>> CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU
>
>
I have the exactly same problem after I ran wagon. Something must not be
right!!!I even re-did registration and had the same problem.:-(

Please advise!

horiba
02-Mar-2012, 17:22
I'm seeing the same problem. "SP2-Core" and "SP2-Updates" Repositories are already mirrored to the SMT - but there's no migration package available.
To me it looks like the SP2 migration package wasn't rolled out to the update channels yet.
Neither the "yast wagon" nor the "zypper" method (from the deployment guide) work because in my repositories there's no migration package.

malcolmlewis
02-Mar-2012, 17:36
I'm seeing the same problem. "SP2-Core" and "SP2-Updates" Repositories
are already mirrored to the SMT - but there's no migration package
available.
To me it looks like the SP2 migration package wasn't rolled out to the
update channels yet.
Neither the "yast wagon" nor the "zypper" method (from the deployment
guide) work because in my repositories there's no migration package.



Hi
There is no 'migration' package, the existence of the repositories will
trigger an upgrade of the current packages (well that's the intent).

Is this a test system?

--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
up 5 days 13:41, 3 users, load average: 0.01, 0.04, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

salisburyk
02-Mar-2012, 17:39
5.7.1. Performing On-line Migration with yast2-wagon

YaST wagon offers to perform on-line migration from SLES11-SP1 to SLES11-SP2. Wagon provides two possibilities to perform migration:

Minimal migration provides update of installed packages to newer version, which is provided by SLES11-SP2. It makes sure that your system is updated to SLES11-SP2, but does not assure that after the migration your system is fully up-to-date.

Full migration performs, in addition to the minimal migration, also application of all patches which are relevant for your system. This assures that your system is fully up-to-date, on the latest possible patch level.

To make sure that your system has all security patches installed and therefore is not vulnerable, either run the full migration, or make sure to run on-line update after performing the minimal migration.

yast2-wagon version 2.17.17.8-0.3.1 is installed on my system - is this the version that will supposedly allow me to perform a full migration from SP1 to SP2 as discussed above?

markgard
02-Mar-2012, 19:39
Why do I not see sp2 available through YaST\online update? Do I need to
do some additional configuration before I can sp2?


Looks like the current wagon packages does NOT change the repositories to the new SP2 repositories. (I was able to use the SP2 DVD iso and perform a Service Pack Upgrade using the DVD)

Still want wagon to work correctly. (either wagon is broken or the migration packages have not been released yet) That's what I think at least.

horiba
05-Mar-2012, 11:52
Hi
There is no 'migration' package, the existence of the repositories will
trigger an upgrade of the current packages (well that's the intent).

Is this a test system?


Yes it's a test system.

The deployment guide (see http://www.suse.com/documentation/sles11/book_sle_deployment/data/sec_update_migration_yast2-wagon.html) says, yast wagon will pick up the new repositores when a migration patch was installed.

So either yast wagon needs to be updated to work without a migration patch or the migration patch is missing or I did get something completely wrong. The repositories (Core & Updates) are there but neither wagon nor suseregister will add them.

Am I supposed to add the new repositories manually? I never had to do that with NU-Update sources...

markgard
05-Mar-2012, 23:00
I just Found out through the Beta Channel that the SLES SP1 to SP2 online migration has not been release yet. But will be made available sometime next week.

horiba
06-Mar-2012, 08:02
Thanks a lot markgard.

To Suse: Is this kind of information in the open? Did I miss it or did you miss it?

carco
06-Mar-2012, 11:12
I did not try with SP2 yet, but I tried with SLES 11 SP2 FOR VMware but I got an error when booting from the Installation DVD and when I tried to add the ISO files to the repositories. It might be a conincidence or the same error/behaviour in both SLES 11 distributions?

Rosario

bh2kt
06-Mar-2012, 14:11
I can confirm:

At this time the online updating process is not activated. You can download the updates from the download page but you will need to boot from the SLES 11 SP2 media and choose upgrade instead of installation.
With zypper you can try an update but you get the message "beta repository"
Suse ist expecting the online updating feature to be ready by next week.

markgard
06-Mar-2012, 14:48
I was lucky enough to be on the SLES 11.2 Beta testing team!
It was released yesterday on the betas mailing list that the Online Upgrade path was not ready yet (migration packages). As of yesterday they were planning on releasing the packages late next week.

markgard
06-Mar-2012, 15:00
either wagon is broken or the migration packages have not been released yet) That's what I think at least.

You are thinking correctly. Migration packages will be release late next week.

A13923
13-Mar-2012, 15:28
Anything new? Seems to me that the online update is still inactive.

A13923
16-Mar-2012, 13:00
Still no online update :(

Did they need so much time for former service packs, too?

allenb_1121
21-Mar-2012, 22:12
I can confirm it still seems to not be there today.

Allen Beddingfield
Systems Engineer
The University of Alabama

enovaklbank
22-Mar-2012, 08:23
I can confirm it still seems to not be there today.


It's already there.
http://download.novell.com/Download?buildid=plJTe3jSHDQ~

allenb_1121
22-Mar-2012, 14:32
Yeah, I just found it. I think my SMT server had not synced it down yet. I tried it, and it worked just fine.
So...
1. Install migration package.
2. zypper dup
3. Reboot.
4. Profit?!