PDA

View Full Version : SLED12 with GeForce 920M



naren_bishayee
19-Nov-2015, 13:43
Hi All,

I've installed the SLED12 x86_64 on a Dell Inspiron Laptop, but the system can't able to use the NVIDIA graphics card.
several times I've tried to install it (using yast2 Software Management, and downloaded the driver), after the installation, system booted & lastly a white screen with 'LOGOUT' button without mouse display & saying, Oh! NO, something went wrong, try to reboot to solve
After reboot nothing happen.
Lastly, I need to rollback, then reboot, but still the same thing, then I need to boot with recovery from the 'Advance boot' & then the GUI login appear. But no NVIDIA (no window animation)
Can anyone help me to figure this out the problem & how do i use the NVIDIA graphics card
I can't even change the screen brightness.


linux-swhw:~ # lspci
00:00.0 Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
00:14.0 USB controller: Intel Corporation Wildcat Point-LP USB xHCI Controller (rev 03)
00:16.0 Communication controller: Intel Corporation Wildcat Point-LP MEI Controller #1 (rev 03)
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #1 (rev e3)
00:1c.2 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #3 (rev e3)
00:1c.3 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #4 (rev e3)
00:1c.4 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #5 (rev e3)
00:1d.0 USB controller: Intel Corporation Wildcat Point-LP USB EHCI Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation Wildcat Point-LP LPC Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation Wildcat Point-LP SATA Controller [AHCI Mode] (rev 03)
00:1f.3 SMBus: Intel Corporation Wildcat Point-LP SMBus Controller (rev 03)
06:00.0 Network controller: Intel Corporation Wireless 3160 (rev 83)
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 07)
08:00.0 3D controller: NVIDIA Corporation GK208M [GeForce 920M] (rev a1)




linux-swhw:~ # lspci -v -s 08:00.0
08:00.0 3D controller: NVIDIA Corporation GK208M [GeForce 920M] (rev a1)
Subsystem: Dell Device 06ae
Flags: fast devsel, IRQ 16
Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
Memory at e0000000 (64-bit, prefetchable) [size=256M]
Memory at f0000000 (64-bit, prefetchable) [size=32M]
I/O ports at d000 [size=128]
Expansion ROM at f7000000 [disabled] [size=512K]
Capabilities: [60] Power Management version 3
Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [78] Express Endpoint, MSI 00
Capabilities: [100] Virtual Channel
Capabilities: [128] Power Budgeting <?>
Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
Capabilities: [900] #19
Kernel modules: nouveau




linux-swhw:~ # lspci -v -s 00:02.0
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09) (prog-if 00 [VGA controller])
Subsystem: Dell Device 06ae
Flags: bus master, fast devsel, latency 0, IRQ 255
Memory at f5000000 (64-bit, non-prefetchable) [size=16M]
Memory at d0000000 (64-bit, prefetchable) [size=256M]
I/O ports at f000 [size=64]
Expansion ROM at <unassigned> [disabled]
Capabilities: [90] MSI: Enable- Count=1/1 Maskable- 64bit-
Capabilities: [d0] Power Management version 2
Capabilities: [a4] PCI Advanced Features


thanks

malcolmlewis
19-Nov-2015, 14:11
On Thu 19 Nov 2015 12:44:01 PM CST, naren bishayee wrote:

Hi All,

I've installed the SLED12 x86_64 on a Dell Inspiron Laptop, but the
system can't able to use the NVIDIA graphics card.
several times I've tried to install it (using yast2 Software Management,
and downloaded the driver), after the installation, system booted &
lastly a white screen with 'LOGOUT' button without mouse display &
saying, Oh! NO, something went wrong, try to reboot to solve
After reboot nothing happen.
Lastly, I need to rollback, then reboot, but still the same thing, then
I need to boot with recovery from the 'Advance boot' & then the GUI
login appear. But no NVIDIA (no window animation)
Can anyone help me to figure this out the problem & how do i use the
NVIDIA graphics card
I can't even change the screen brightness.

Code:
--------------------

linux-swhw:~ # lspci
00:00.0 Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI
(rev 09) 00:02.0 VGA compatible controller: Intel Corporation
Broadwell-U Integrated Graphics (rev 09) 00:03.0 Audio device: Intel
Corporation Broadwell-U Audio Controller (rev 09) 00:14.0 USB
controller: Intel Corporation Wildcat Point-LP USB xHCI Controller (rev
03) 00:16.0 Communication controller: Intel Corporation Wildcat
Point-LP MEI Controller #1 (rev 03) 00:1b.0 Audio device: Intel
Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root
Port #1 (rev e3) 00:1c.2 PCI bridge: Intel Corporation Wildcat Point-LP
PCI Express Root Port #3 (rev e3) 00:1c.3 PCI bridge: Intel Corporation
Wildcat Point-LP PCI Express Root Port #4 (rev e3) 00:1c.4 PCI bridge:
Intel Corporation Wildcat Point-LP PCI Express Root Port #5 (rev e3)
00:1d.0 USB controller: Intel Corporation Wildcat Point-LP USB EHCI
Controller (rev 03) 00:1f.0 ISA bridge: Intel Corporation Wildcat
Point-LP LPC Controller (rev 03) 00:1f.2 SATA controller: Intel
Corporation Wildcat Point-LP SATA Controller [AHCI Mode] (rev 03)
00:1f.3 SMBus: Intel Corporation Wildcat Point-LP SMBus Controller (rev
03) 06:00.0 Network controller: Intel Corporation Wireless 3160 (rev
83) 07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 07)
08:00.0 3D controller: NVIDIA Corporation GK208M [GeForce 920M] (rev
a1) --------------------



Code:
--------------------

linux-swhw:~ # lspci -v -s 08:00.0
08:00.0 3D controller: NVIDIA Corporation GK208M [GeForce 920M] (rev
a1) Subsystem: Dell Device 06ae
Flags: fast devsel, IRQ 16
Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
Memory at e0000000 (64-bit, prefetchable) [size=256M]
Memory at f0000000 (64-bit, prefetchable) [size=32M]
I/O ports at d000 [size=128]
Expansion ROM at f7000000 [disabled] [size=512K]
Capabilities: [60] Power Management version 3
Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [78] Express Endpoint, MSI 00
Capabilities: [100] Virtual Channel
Capabilities: [128] Power Budgeting <?>
Capabilities: [600] Vendor Specific Information: ID=0001
Rev=1 Len=024 <?> Capabilities: [900] #19
Kernel modules: nouveau

--------------------



Code:
--------------------

linux-swhw:~ # lspci -v -s 00:02.0
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U
Integrated Graphics (rev 09) (prog-if 00 [VGA controller]) Subsystem:
Dell Device 06ae Flags: bus master, fast devsel, latency 0, IRQ 255
Memory at f5000000 (64-bit, non-prefetchable) [size=16M]
Memory at d0000000 (64-bit, prefetchable) [size=256M]
I/O ports at f000 [size=64]
Expansion ROM at <unassigned> [disabled]
Capabilities: [90] MSI: Enable- Count=1/1 Maskable- 64bit-
Capabilities: [d0] Power Management version 2
Capabilities: [a4] PCI Advanced Features

--------------------


thanks




Hi
So you have hybrid graphics, intel/nvidia. AFAIK you need to use
bumblebee and switch;
https://en.opensuse.org/SDB:NVIDIA_Bumblebee

The link you need to use for the driver is;
http://download.opensuse.org/repositories/X11:/Bumblebee/SLE_12/

You do need to uninstall the nvidia driver first.

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 | GNOME 3.10.1 | 3.12.48-52.27-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

naren_bishayee
21-Nov-2015, 17:55
Hi Malcolm,

Thanks for the quick response.
I've faced some error during the installation/configuration, and after that I fade up with all these. Anyway, I've decided to not use this Geforce card. So, I've reinstalled SLED12 on my laptop from scratch with Intel graphics, and this time I've disable the 'SWITCH' graphics from the GUI enable BIOS.
Now, my question is, I cant change the screen brightness, and normally i need to work approx 8-9 hours in-front of my laptop screen.
SO, is there any way to activate the laptop's in-built brightness low-high button with SLED12.

Thanks

malcolmlewis
21-Nov-2015, 18:45
On Sat 21 Nov 2015 05:04:02 PM CST, naren bishayee wrote:

Hi Malcolm,

Thanks for the quick response.
I've faced some error during the installation/configuration, and after
that I fade up with all these. Anyway, I've decided to not use this
Geforce card. So, I've reinstalled SLED12 on my laptop from scratch with
Intel graphics, and this time I've disable the 'SWITCH' graphics from
the GUI enable BIOS.
Now, my question is, I cant change the screen brightness, and normally i
need to work approx 8-9 hours in-front of my laptop screen.
SO, is there any way to activate the laptop's in-built brightness
low-high button with SLED12.

Thanks




Hi
Try adding the following via YaST bootloader kernel options and
rebooting;


acpi_osi=\"!Windows 2012\"



--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 | GNOME 3.10.1 | 3.12.48-52.27-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!