PDA

View Full Version : SLES-Other SMT Register Problem / Hangs



bendeichp
01-Dec-2015, 11:45
Hi Forum,

smt-2.0.13-9.3
smt-support-2.0.13-9.3

since a couple of weeks smt has stopped working. I'm trying to figure out why but could not find any error messages.
I see a lot of processes because cron starts it ever 15 minutes. But obviously doesn't finish:



root 5751 0.0 0.0 48316 1232 ? S 10:30 0:00 /usr/sbin/cron
root 5752 0.0 0.0 11320 1292 ? Ss 10:30 0:00 /bin/sh /usr/lib/SMT/bin/smt-repeated-register
root 5764 0.0 0.5 91828 11616 ? S 10:30 0:00 /usr/bin/perl /usr/sbin/smt-register -r -L /var/log/smt/smt-register.log --mail
root 6459 0.0 0.0 48316 1232 ? S 10:45 0:00 /usr/sbin/cron
root 6461 0.0 0.0 11320 1288 ? Ss 10:45 0:00 /bin/sh /usr/lib/SMT/bin/smt-repeated-register
root 6464 0.0 0.5 91828 11616 ? S 10:45 0:00 /usr/bin/perl /usr/sbin/smt-register -r -L /var/log/smt/smt-register.log --mail
root 7889 0.0 0.0 48316 1224 ? S 11:00 0:00 /usr/sbin/cron
root 7891 0.0 0.0 11320 1296 ? Ss 11:00 0:00 /bin/sh /usr/lib/SMT/bin/smt-repeated-register
root 7895 0.0 0.5 91828 11616 ? S 11:00 0:00 /usr/bin/perl /usr/sbin/smt-register -r -L /var/log/smt/smt-register.log --mail
root 10740 0.0 0.0 48316 1228 ? S 11:30 0:00 /usr/sbin/cron
root 10741 0.0 0.0 11320 1292 ? Ss 11:30 0:00 /bin/sh /usr/lib/SMT/bin/smt-repeated-register
root 10745 0.0 0.5 91828 11612 ? S 11:30 0:00 /usr/bin/perl /usr/sbin/smt-register -r -L /var/log/smt/smt-register.log --mail


I tried to start smt register manually in the debug mode with

/usr/sbin/smt-register --debug --reseterror
Unfortunately nothing happens for 30 minutes so I cancelled it.

I started an strace of that command to find out that it tries to open some ssl libs which where not existing. So I created a symlink to the obvious lib

/usr/lib64/.libssl.so.0.9.8.hmac
ln -s /usr/lib64/libssl.so.0.9.8 /usr/lib64/.libssl.so.0.9.8.hmac
/usr/lib64/.libcrypto.so.0.9.8.hmac
ln -s /usr/lib64/libcrypto.so.0.9.8 /usr/lib64/.libcrypto.so.0.9.8.hmac

Now these errors are gone but again the process hangs an does nothing.
I traced the network traffic with tcpdump on port 80/443 but can't see any packets. Problem should be earlier in the smt-register process...

How can I figure out where or what the problem is?

Thanks,
Pascal

jmozdzen
01-Dec-2015, 13:00
Hi Pascal,

which version of SLES is the SMT server running on?

> I started an strace of that command to find out that it tries to open some ssl libs which where not existing. So I created a symlink to the obvious lib

I don't believe this was a good idea - SMT would have failed if it had encountered missing libs, and by creating those symlinks you simulated have a feature available on the server that isn't installed. This may very well confuse other programs.

I guess you already had a look at /var/log/smt/smt-register.log - is that file empty?

As /usr/sbin/smt-register is written in Perl, you might be able to debug where program hangs... or leave that to SUSE engineers, by opening a service request ;)

Regards,
Jens

bendeichp
01-Dec-2015, 13:43
Hi Jens,

SUSE Linux Enterprise Server 11 (x86_64)
VERSION = 11
PATCHLEVEL = 4

Symlinks are removed, didn't change anything...
Logfile has only two (old) entries:

2015-10-08 10:04:12 SMT::SCCSync - [info] Register 1 new clients.
2015-10-08 10:04:13 SMT::SCCSync - [info] Registration success: 'SCC_98eea5e505764970b2108b5dae25b5fa'.

Yeah, I guess I'm going to examine the perl code and look where it hangs. Thanks so far :)

Cheers,
Pascal

timstein
02-Dec-2015, 11:04
Hi Pascal,

I had strange SMT problems a few weeks ago, too. In the end it turned out to be a problem related to curl. The latest patch for curl fixed my SMT problems.

Regards
Tim

bendeichp
11-Dec-2015, 10:29
Hi,

server (SLES11 SP4) is up 2 date. Curl is curl-7.19.7-1.42.1.
I break down my problem to one perl module: Net::SSLeay.
For clarification:
SMT::Utils uses NET::SMTP which uses IO::Socket::SSL with uses Net:SSLeay ant this module hangs in line 92:

Net::SSLeay::SSLeay_add_ssl_algorithms();
IO::Socket::SSL is installed in version 2.022
Net:SSLeay is installed in version 1.64 but I tested also with 1.72 (or 1.74, in short the newest version downloaded via CPAN. Did a downgrade after all testings to version shipped with sles)
Found some posts in the internet related to "add_ssl_algorithms" but was not able to fix it...

Finally I commented the line 28 (see below) in Module NET::SMTP.pm and the rest of the SMT Modules seem to run without an error. Even mail were received with smt reports last night with this "workaround".

# require IO::Socket::SSL;

Also found some posts to update openssl. After that some had solved their problem with Net:SSLeay. I don't want to compile openssl by myself, want to use the version of sles...
Maybe there is an rpm for sles11 with a newer version.... if someone want to research, feel free to do so ;)

In the end SMT seems to work proper and thats what I needed.

Thanks for reporting back!

Cheers,
Pascal