PDA

View Full Version : no sound under SLED12



albumns
13-Dec-2015, 07:14
Hello:

I've installed SLED 12 for my HP pavilion SE 15 laptop.

It seems that there is no any sound output from my system. I can open the volume controller from task bar, and there is a "analog output-build-in autdio" in the output tab. I don't know why there is no any sound. I tested for my skype and youtube....

thank you very muchy

Automatic reply
18-Dec-2015, 06:30
albumns,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team
http://forums.suse.com

hcp_dk
12-Mar-2017, 18:03
You might try in Yast, Sound. There are sound cards defined.
Check if they are setup. Pulse Audio might be a good idea.
Maybe you can test if there is sound in general. You can do that via Yast. Test sound.
Be sure the is a hole through. :-)

You can in fact use Rythmbox. This piece of software can more than you believe. As usual, not good documented. But there are and can be established radio stations you can listen. They work.
This might be a good tool for test too.

But this is not enough. All music on Web and otherwise comes packed in codecs. These Codecs are not part of SUSE.
I think I wrote somewhere here how I installed my system (against all SUSE rules).
My experiences is best to install:
Adobe Flash for be able to see video.
Install VLC player, but NOT from SUSE or OpenSuse. Only from original VLC-Player in version Leap 42.1 or Leap 42.2 or from packman repository that have some repository for SLED12 too. (I used the original videolan.org)
Further I installed ffmpeg too - think it was from packman too.
VLC brings most of needed codecs and is a standard in PC world, both Linux, Android and Windows. This works. (Eventually you need in Yast Software Management search for VLC or codec install codes extra)

To make installation not to a pain, I pre-installed Leap42.2 OSS, NON-OSS repositories. Otherwise you end up in many missing dependencies - a really mess!
VLC will install some new repositories.
All these I placed in priority 100 in Yast respository , so the system takes SUSE software repository before Leap and videolan (priority higher means lower in choice)
When all is installed I disable the foreign repositories again, but keep them when needed later. So they get not selected when running updates.

There is a risk for instability. But unfortunately Linux still is made more for developer and less for user. There is a lot of "standard software" missing. But we have 3 types of terminals in SLED!
I hope this will change over time so SUSE get's a competitive product. Basically it works well - after some effort. :-)
Be aware, SLES has a software Hub that works on SLED too. here, lot of proven software can be found too.

KBOYLE
12-Mar-2017, 22:06
This thread is 15 months old. I would hope this is no longer an issue.

There is a risk for instability.
SLES and SLED are SUSE Linux Enterprise products. They are designed for stability and reliability. If software is installed from repositories other than those that SUSE provides for SLE products, a user may lose all support for his product. If a user needs software from an unsupported repository, it is up to him/her to assess the risk and insure all necessary dependencies are resolved.

A better approach might be to implement one of the OpenSUSE products instead.