PDA

View Full Version : HWCCT scripts



dvramakrishna123
21-Dec-2015, 14:53
Hi All,

I was trying to execute the hwcct scripts after installing the SUSE linux :
But some how the following error is popping :

./hwval -f apols.json
./hwval: error while loading shared libraries: libhdbversion.so: cannot open shared object file: No such file or directory
<REMOVED HOSTNAME>:/hana/shared/51050456/DATA_UNITS/SAP_HANA_HWCCT_LINUX_X86_64/hwcct #


I have checked the env variable, it was correctly mentioned the path where the libhdbdversion.so file is there.
<REMOVED>:/usr/sap/SCP/HDB00/exe # ls -latr libhdbversion.so
-r-xr-xr-x 1 scpadm sapsys 81600 Nov 4 22:05 libhdbversion.so
<REMOVED HOSTNAME>:/usr/sap/SCP/HDB00/exe #

PATH=/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib64/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin:/usr/sap/SCP/HDB00/exe/


Thanks & Regards,
Venkata Ramakrishna

thomasmerz
21-Dec-2015, 16:39
Hi,

your should start the HWCCT like this:

# as root:
cd /hana/shared/hwcct
. ./envprofile.sh
./hwval -f test_config.json



# more ./envprofile.sh

#!/bin/bash

BASE="$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )"

export SAP_RETRIEVAL_PATH="${BASE}/"
export DIR_EXECUTABLE="${BASE}/lib"
export PYTHONHOME="${BASE}/lib/Python"
export PYTHONPATH="${BASE}/"
export LD_LIBRARY_PATH="${BASE}/lib"

Kind regards
Thomas

dvramakrishna123
22-Dec-2015, 16:17
Hi Thomas,

After executing envprofile.sh, it is working fine thanks a lot.:)

Best Regards,
Venkata Ramakrishna

nvt007
11-Oct-2016, 22:02
I am running to the same problem and did run the script envprofile.sh but it didn't work.
I did also try this,

source envprofile.sh

then ran the command, which usued to work for me.
The little different is, I'm running on SUSE 12 SP1, not working with the same error,
and SUSE 11 SP4, one server worked when the other not.
I played around with the envinronmental variable,
I found HWCCT brought in its own paython, 2.7.10
When my OS has 2.7.9, but I still don't know
why it's not launching python module.

Any idea would be greatly appricated.

Thanks,
NT

smflood
13-Oct-2016, 14:29
On 11/10/2016 22:04, nvt007 wrote:

> I am running to the same problem and did run the script envprofile.sh
> but it didn't work.
> I did also try this,
>
> source envprofile.sh
>
> then ran the command, which usued to work for me.
> The little different is, I'm running on SUSE 12 SP1, not working with
> the same error,
> and SUSE 11 SP4, one server worked when the other not.
> I played around with the envinronmental variable,
> I found HWCCT brought in its own paython, 2.7.10
> When my OS has 2.7.9, but I still don't know
> why it's not launching python module.
>
> Any idea would be greatly appricated.

Perhaps post the contents of your envprofile.sh files?

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------