PDA

View Full Version : AMD Driver on SLED 12 SP1



hlaroes
01-Jan-2016, 19:26
Hello,

I have been trying to install SLED12 SP1 for a week now, but regardless of trying to do a clean install or an upgrade of the existing SLED12 installation, the AMD driver repository no longer seems to be added during the installation. Does anyone know whether this driver has been dropped from SP1? If so, this would be very inconvenient for me. In that case, is there another way to install the proprietary AMD driver on a SLED12 SP1 system?

A reply is greatly appreciated. Many thanks in advance.

malcolmlewis
01-Jan-2016, 20:12
On Fri 01 Jan 2016 06:34:01 PM CST, hlaroes wrote:

Hello,

I have been trying to install SLED12 SP1 for a week now, but regardless
of trying to do a clean install or an upgrade of the existing SLED12
installation, the AMD driver repository no longer seems to be added
during the installation. Does anyone know whether this driver has been
dropped from SP1? If so, this would be very inconvenient for me. In that
case, is there another way to install the proprietary AMD driver on a
SLED12 SP1 system?

A reply is greatly appreciated. Many thanks in advance.




Hi
I use the build my own rpm method from;
https://en.opensuse.org/SDB:AMD_fglrx

I've yet to upgrade to SP1, so haven't tested the above, plus I use the
15.9 driver since they dropped support for my AMD GPU....

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 | GNOME 3.10.1 | 3.12.51-52.31-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

hlaroes
02-Jan-2016, 12:35
Hi Malcolm,

Your answer proved to be most helpful.

I am afraid that it might be my graphics chip as well. Probably isn't supported anymore by the newest AMD driver, which is likely to be the one that is installed via the official repository.

I switched to openSUSE Leap 42.1 as a result, as I do not feel comfortable with having to manually build my own driver.
Probably as a result of the newer kernel on the latest openSUSE I do not really need the proprietary AMD driver on this operating system.

Have a nice day and thank you!