PDA

View Full Version : SLES 12 Update SLES 12 to SLES 12 sp1



hoe_rpearson
08-Jan-2016, 23:01
Please forgive what must be a really simple question, but I'm having no luck upgrading my SLES 12 installs to SP1. I've not found any online instructions in an hour of looking, and the one thing that I tried in the system ("Online Migration") returns many, many errors about repositories not being available.

Any advice is appreciated.

malcolmlewis
08-Jan-2016, 23:13
On Fri 08 Jan 2016 10:04:01 PM CST, hoe rpearson wrote:

Please forgive what must be a really simple question, but I'm having no
luck upgrading my SLES 12 installs to SP1. I've not found any online
instructions in an hour of looking, and the one thing that I tried in
the system ("Online Migration") returns many, many errors about
repositories not being available.

Any advice is appreciated.




Hi
Are the systems all up to date and have valid registrations as well as
internet access?

If you have any third party repositories (as in not from SCC), then
those would need to be disabled, or manually switched to an SP1 repo,
then all the SCC ones from the command line run;


zypper dup


Else, if you download the install media and do an offline upgrade.

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 SP1|GNOME 3.10.2|3.12.51-60.20-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

ab
08-Jan-2016, 23:25
Also, chapter eighteen (18) of the deployment guide covers this:

https://www.suse.com/documentation/sles-12/book_sle_deployment/data/cha_update_spmigration.html


--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...

hoe_rpearson
08-Jan-2016, 23:40
Thank you! That was exactly what I was looking for. I will give that a try.

hoe_rpearson
08-Jan-2016, 23:57
Hm. I'm still running into issues using zypper migration. I keep having errors returned that valid metadata does not exist at the repository URL.

As near as I can tell, I don't need a different registration key for 12sp1 from 12.

I will try the upgrade with the DVD and post those results.