PDA

View Full Version : XEN Live migration issue - migrate_to option not selectable



6529034
19-Jan-2016, 04:11
Hello,

I am setting up SLES 12 SP1 with XEN and High Availability. I been able to configure HA resources using HAWK2, although it is more cumbersome than HAWK v1. I use DRBD, and this, as a HA resource only works (for active-active DRBD) using the Wizard option for DRBD. If I create the DRBD primative and MS resources manually, using the exact same options as the one created by the Wizard, it will not work.

Anyway, I have issues live migrating XEN VM's - when I do so through HAWK2, the VM becomes active on both nodes and corrupts. I need to configure migrate_to and migrate_from options for the 'VirtualDomain' resource representing my XEN VM. However, when I choose either of these options and try to 'Apply'/save in, I get an error stating something like 'illegal attribute...' and the option will not set.

I have pass-wordless SSH setup and working fine. What I would do if I could get the pacemaker python GUI CRM back.. It just seemed to work.

Why can I not set the migrate_to and migrate_from options for my VirtualDomain' HA resource?

John

jmozdzen
19-Jan-2016, 13:29
Hi John,

while I have no SLES12SP1 Xen cluster running ATM, I strongly advise to set up inter-node locking for Xen (see "(xend-domain-lock yes)" and "(xend-domain-lock-path /var/lib/images/vm_locks)" in /etc/xen/xend-config.sxp). That way, the xends on your Xen cluster nodes can verify that no other node is currently running the VM. Of course that directory which lock-path is pointing to needs to be on a shared disk with a cluster FS, i.e. OCFS2.

May I assume that you have set the meta attribute "allow-migrate" to "true" for the resources in question?

Regards,
Jens