PDA

View Full Version : SLES 11 SP3 Installing Arial font for X11



asavran
20-Jan-2016, 05:02
We are hosting reporting services on Weblogic server from Oracle on SLES 11. Our reports are messed up because we are missing some fonts on SUSE. During our investigation, we learned that WEBlogic reporting server inherits the fonts from X11.

Long story short we have been trying to install Arial font under X11 but had no success so far.

the output for command "xset q" is supposed to return the Font Path for X11; and no matter what we did we keep only seeing "Built-ins" for "font-paths".

We added all the fonts under /usr/share/fonts/TrueType folder and whenever we try to use the "xset +fp" to add the folder in X11 path, we keep getting the "bad font path element (#23)" error.
Can somebody please point us to the right direction.

Thanks.

malcolmlewis
20-Jan-2016, 05:25
Hi
After adding the font(s) did you run the command;


SuSEconfig fonts


This should cleanup and add them (as well as the path).

asavran
20-Jan-2016, 15:11
Thanks for the reply.

We cannot run the command you suggested. Following is what we get:

ifcssuse:/usr/share/fonts/TrueType # ls
ARIALN.ttf ARIALNI.ttf arblwgl.ttf arialbd.ttf ariblk.ttf
ARIALNB.ttf ARIALUNI.ttf arial.ttf arialbi.ttf
ARIALNBI.ttf ARLRDBD.ttf arial.ttf.orig ariali.ttf

ifcssuse:/usr/share/fonts/TrueType # SuSEconfig fonts
Starting SuSEconfig, the SuSE Configuration Tool...
Unknown parameter fonts.
Usage: SuSEconfig [--quick|--nonewpackage|--force|--verbose] [--module name] [--listmodules]

ifcssuse:/usr/share/fonts/TrueType #

malcolmlewis
20-Jan-2016, 15:31
On Wed 20 Jan 2016 02:14:01 PM CST, asavran wrote:

Thanks for the reply.

We cannot run the command you suggested. Following is what we get:

ifcssuse:/usr/share/fonts/TrueType # ls
ARIALN.ttf ARIALNI.ttf arblwgl.ttf arialbd.ttf ariblk.ttf
ARIALNB.ttf ARIALUNI.ttf arial.ttf arialbi.ttf
ARIALNBI.ttf ARLRDBD.ttf arial.ttf.orig ariali.ttf

ifcssuse:/usr/share/fonts/TrueType # SuSEconfig fonts
Starting SuSEconfig, the SuSE Configuration Tool...
Unknown parameter fonts.
Usage: SuSEconfig [--quick|--nonewpackage|--force|--verbose] [--module
name] [--listmodules]

ifcssuse:/usr/share/fonts/TrueType #




Hi
Maybe it's font, check the output from for correct syntax;


SuSEconfig --listmodules

Then when you run the xset -q command it should be in the font path.

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 SP1|GNOME 3.10.4|3.12.51-60.20-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

asavran
20-Jan-2016, 18:15
Thanks.. I was executing the command wrong, but still no luck. Still only "built-ins" is listed under X11 as the fonts; isn't it supposed to be listing all the fonts instead?

Please see the output for xset q:

ifcssuse:/usr/share/fonts/TrueType # xset q
Keyboard Control:
auto repeat: on key click percent: 0 LED mask: 00000000
auto repeat delay: 500 repeat rate: 30
auto repeating keys: oofeffffdffffbbf
fadfffffffdfe5ef
ffffffffffffffff
ffffffffffffffff
bell percent: 50 bell pitch: 400 bell duration: 100
Pointer Control:
acceleration: 2/1 threshold: 4
Screen Saver:
prefer blanking: yes allow exposures: yes
timeout: 0 cycle: 0
Colors:
default colormap: ox20 BlackPixel: 0 WhitePixel: 65535
Font Path:
built-ins
DPMS (Energy Star):
Display is not capable of DPMS
Font cache:
Server does not have the FontCache Extension

ifcssuse:/usr/share/fonts/TrueType #[/B]

malcolmlewis
20-Jan-2016, 19:32
On Wed 20 Jan 2016 05:24:02 PM CST, asavran wrote:

Thanks.. I was executing the command wrong, but still no luck. Still
only "built-ins" is listed under X11 as the fonts; isn't it supposed to
be listing all the fonts instead?

Please see the output for xset q:

ifcssuse:/usr/share/fonts/TrueType # xset q
Keyboard Control:
auto repeat: on key click percent: 0 LED mask: 00000000
auto repeat delay: 500 repeat rate: 30
auto repeating keys: oofeffffdffffbbf
fadfffffffdfe5ef
ffffffffffffffff
ffffffffffffffff
bell percent: 50 bell pitch: 400 bell duration: 100
Pointer Control:
acceleration: 2/1 threshold: 4
Screen Saver:
prefer blanking: yes allow exposures: yes
timeout: 0 cycle: 0
Colors:
default colormap: ox20 BlackPixel: 0 WhitePixel: 65535
Font Path:
built-ins
DPMS (Energy Star):
Display is not capable of DPMS
Font cache:
Server does not have the FontCache Extension

ifcssuse:/usr/share/fonts/TrueType #[/B]




Hi
The truetype folder should be /usr/share/fonts/truetype/ not TrueType.

Can you install xorg-x11-fonts package?

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 SP1|GNOME 3.10.4|3.12.51-60.20-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

asavran
20-Jan-2016, 19:54
We created a folder called truetype as well.

I went into that folder just like I did with TrueType. Executed the same set of commands but still the same output :(

I also checked YasT for installed packages. The package you mentioned (xorg-x11-fonts) is already installed (v7.4.1.20).

I don't know what is wrong?!?!

malcolmlewis
20-Jan-2016, 21:47
On Wed 20 Jan 2016 07:04:01 PM CST, asavran wrote:

We created a folder called truetype as well.

I went into that folder just like I did with TrueType. Executed the same
set of commands but still the same output :(

I also checked YasT for installed packages. The package you mentioned
(xorg-x11-fonts) is already installed (v7.4.1.20).

I don't know what is wrong?!?!




Hi
If you run the following command (as root user) if should provide more
info on where it's looking and how many fonts etc.


fc-cache -v (or -fv)



--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 SP1|GNOME 3.10.4|3.12.51-60.20-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

asavran
21-Jan-2016, 16:05
Based on this everything is fine:

ifcssuse:~ # fc-cache -v
/usr/share/fonts: skipping, existing cache is valid: 1 fonts, 10 dirs
/usr/share/fonts/100dpi: skipping, existing cache is valid: 398 fonts, 0 dirs
/usr/share/fonts/75dpi: skipping, existing cache is valid: 398 fonts, 0 dirs
/usr/share/fonts/Speedo: skipping, existing cache is valid: 0 fonts, 0 dirs
/usr/share/fonts/TrueType: skipping, existing cache is valid: 13 fonts, 0 dirs
/usr/share/fonts/Type1: skipping, existing cache is valid: 29 fonts, 0 dirs
/usr/share/fonts/URW: skipping, existing cache is valid: 43 fonts, 0 dirs
/usr/share/fonts/cyrillic: skipping, existing cache is valid: 0 fonts, 0 dirs
/usr/share/fonts/encodings: skipping, existing cache is valid: 0 fonts, 1 dirs
/usr/share/fonts/encodings/large: skipping, existing cache is valid: 0 fonts, 0 dirs
/usr/share/fonts/misc: skipping, existing cache is valid: 136 fonts, 0 dirs
/usr/share/fonts/truetype: skipping, existing cache is valid: 142 fonts, 0 dirs
/usr/X11R6/lib/X11/fonts: skipping, no such directory
/opt/kde3/share/fonts: skipping, no such directory
/usr/local/share/fonts: skipping, no such directory
/usr/share/fonts/truetype: skipping, looped directory detected
/usr/share/fonts/TrueType: skipping, looped directory detected
/root/.fonts: skipping, existing cache is valid: 2 fonts, 0 dirs
/usr/share/fonts/misc: skipping, looped directory detected
/usr/share/fonts/100dpi: skipping, looped directory detected
/usr/share/fonts/Type1: skipping, looped directory detected
/usr/share/fonts/cyrillic: skipping, looped directory detected
/usr/share/fonts/Speedo: skipping, looped directory detected
/usr/share/fonts/75dpi: skipping, looped directory detected
/usr/share/fonts/encodings: skipping, looped directory detected
/usr/share/fonts/encodings/large: skipping, looped directory detected
/var/cache/fontconfig: cleaning cache directory
/root/.fontconfig: not cleaning non-existent cache directory
fc-cache: succeeded


*****************************

Both truetype and TrueType are read. But that is not the case...

malcolmlewis
21-Jan-2016, 16:45
On Thu 21 Jan 2016 03:14:01 PM CST, asavran wrote:

Based on this everything is fine:

ifcssuse:~ # fc-cache -v
/usr/share/fonts: skipping, existing cache is valid: 1 fonts, 10 dirs
/usr/share/fonts/100dpi: skipping, existing cache is valid: 398 fonts, 0
dirs
/usr/share/fonts/75dpi: skipping, existing cache is valid: 398 fonts, 0
dirs
/usr/share/fonts/Speedo: skipping, existing cache is valid: 0 fonts, 0
dirs
/usr/share/fonts/TrueType: skipping, existing cache is valid: 13 fonts,
0 dirs
/usr/share/fonts/Type1: skipping, existing cache is valid: 29 fonts, 0
dirs
/usr/share/fonts/URW: skipping, existing cache is valid: 43 fonts, 0
dirs
/usr/share/fonts/cyrillic: skipping, existing cache is valid: 0 fonts, 0
dirs
/usr/share/fonts/encodings: skipping, existing cache is valid: 0 fonts,
1 dirs
/usr/share/fonts/encodings/large: skipping, existing cache is valid: 0
fonts, 0
dirs
/usr/share/fonts/misc: skipping, existing cache is valid: 136 fonts, 0
dirs
/usr/share/fonts/truetype: skipping, existing cache is valid: 142 fonts,
0 dirs
/usr/X11R6/lib/X11/fonts: skipping, no such directory
/opt/kde3/share/fonts: skipping, no such directory
/usr/local/share/fonts: skipping, no such directory
/usr/share/fonts/truetype: skipping, looped directory detected
/usr/share/fonts/TrueType: skipping, looped directory detected
/root/.fonts: skipping, existing cache is valid: 2 fonts, 0 dirs
/usr/share/fonts/misc: skipping, looped directory detected
/usr/share/fonts/100dpi: skipping, looped directory detected
/usr/share/fonts/Type1: skipping, looped directory detected
/usr/share/fonts/cyrillic: skipping, looped directory detected
/usr/share/fonts/Speedo: skipping, looped directory detected
/usr/share/fonts/75dpi: skipping, looped directory detected
/usr/share/fonts/encodings: skipping, looped directory detected
/usr/share/fonts/encodings/large: skipping, looped directory detected
/var/cache/fontconfig: cleaning cache directory
/root/.fontconfig: not cleaning non-existent cache directory
fc-cache: succeeded


*****************************

Both truetype and TrueType are read. But that is not the case...




Hi
Try the -rv option to force a rebuild (really-force). The only other
thought is to install a system truetype (zypper se font) font and see if
it sets things up....


--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 SP1|GNOME 3.10.4|3.12.51-60.25-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!