PDA

View Full Version : SLES 12 Online update error after updating to SLES 12 SP1



ttrcf
28-Jan-2016, 15:04
I migrated from SLES 12 to SLES 12SP1 using the YaST migration tool and all appeared to go well. However, if i now run the yast2 online update applet I get an error message:

UI Syntax Error Couldn't load plug-in qt-pkg. Check the log file!

If I run Online update from the text version of yast I get:

UI Syntax Error Couldn't load plug-in ncurses.pkg. Check the log file!


If I run zypper patch it seems to update correctly.

Advice would be appreciated.

Rob

malcolmlewis
28-Jan-2016, 20:24
On Thu 28 Jan 2016 02:14:01 PM CST, ttrcf wrote:

I migrated from SLES 12 to SLES 12SP1 using the YaST migration tool and
all appeared to go well. However, if i now run the yast2 online update
applet I get an error message:

-UI Syntax Error Couldn't load plug-in qt-pkg. Check the log file!-

If I run Online update from the text version of yast I get:

-UI Syntax Error Couldn't load plug-in ncurses.pkg. Check the log
file!
-

If I run zypper patch it seems to update correctly.

Advice would be appreciated.

Rob




Hi
What happens if you force a cache rebuild and verify, run;


zypper ref -f
zypper ve



--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 SP1|GNOME 3.10.4|3.12.51-60.25-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

ttrcf
29-Jan-2016, 10:18
No change, I'm afraid.

zypper ref -f gives:

Forcing raw metadata refresh
Retrieving repository 'SLE-Module-Legacy12-Pool' metadata ...............................[done]
Forcing building of repository cache
Building repository 'SLE-Module-Legacy12-Pool' cache ....................................[done]
Forcing raw metadata refresh
Retrieving repository 'SLE-Module-Legacy12-Updates' metadata ............................[done]
Forcing building of repository cache
Building repository 'SLE-Module-Legacy12-Updates' cache .................................[done]
Forcing raw metadata refresh
Retrieving repository 'SLES12-SP1-Pool' metadata ........................................[done]
Forcing building of repository cache
Building repository 'SLES12-SP1-Pool' cache .............................................[done]
Forcing raw metadata refresh
Retrieving repository 'SLES12-SP1-Updates' metadata .....................................[done]
Forcing building of repository cache
Building repository 'SLES12-SP1-Updates' cache ..........................................[done]
Forcing raw metadata refresh
Retrieving repository 'SLE-SDK12-SP1-Pool' metadata .....................................[done]
Forcing building of repository cache
Building repository 'SLE-SDK12-SP1-Pool' cache ..........................................[done]
Forcing raw metadata refresh
Retrieving repository 'SLE-SDK12-SP1-Updates' metadata ..................................[done]
Forcing building of repository cache
Building repository 'SLE-SDK12-SP1-Updates' cache .......................................[done]
All repositories have been refreshed.

zypper ve gives:

Refreshing service 'Legacy_Module_12_x86_64'.
Refreshing service 'SUSE_Linux_Enterprise_Server_12_SP1_x86_64'.
Refreshing service 'SUSE_Linux_Enterprise_Software_Development_Kit_12 _SP1_x86_64'.
Loading repository data...
Reading installed packages...
6 Problems:
Problem: nothing provides appdata(vmware-player.appdata.xml) needed by application:VMware Player-.noarch
Problem: nothing provides appdata(libreoffice-writer.appdata.xml) needed by application:libreoffice-writer-.noarch
Problem: nothing provides appdata(libreoffice-impress.appdata.xml) needed by application:libreoffice-impress-.noarch
Problem: nothing provides appdata(libreoffice-base.appdata.xml) needed by application:libreoffice-base-.noarch
Problem: nothing provides appdata(libreoffice-calc.appdata.xml) needed by application:libreoffice-calc-.noarch
Problem: nothing provides appdata(libreoffice-draw.appdata.xml) needed by application:libreoffice-draw-.noarch

Problem: nothing provides appdata(vmware-player.appdata.xml) needed by application:VMware Player-.noarch
Solution 1: deinstallation of application:VMware Player-.noarch
Solution 2: break application:VMware Player-.noarch by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 2

Problem: nothing provides appdata(libreoffice-writer.appdata.xml) needed by application:libreoffice-writer-.noarch
Solution 1: deinstallation of application:libreoffice-writer-.noarch
Solution 2: break application:libreoffice-writer-.noarch by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 2

Problem: nothing provides appdata(libreoffice-impress.appdata.xml) needed by application:libreoffice-impress-.noarch
Solution 1: deinstallation of application:libreoffice-impress-.noarch
Solution 2: break application:libreoffice-impress-.noarch by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 2

Problem: nothing provides appdata(libreoffice-base.appdata.xml) needed by application:libreoffice-base-.noarch
Solution 1: deinstallation of application:libreoffice-base-.noarch
Solution 2: break application:libreoffice-base-.noarch by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 2

Problem: nothing provides appdata(libreoffice-calc.appdata.xml) needed by application:libreoffice-calc-.noarch
Solution 1: deinstallation of application:libreoffice-calc-.noarch
Solution 2: break application:libreoffice-calc-.noarch by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 2

Problem: nothing provides appdata(libreoffice-draw.appdata.xml) needed by application:libreoffice-draw-.noarch
Solution 1: deinstallation of application:libreoffice-draw-.noarch
Solution 2: break application:libreoffice-draw-.noarch by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 2
Resolving dependencies...

Dependencies of all installed packages are satisfied.

Rob

malcolmlewis
29-Jan-2016, 14:24
Hi
Hopefully those appdata ones will disappear.... It looks like the libyui packages did not upgrade...?


Reading installed packages...

S | Name | Summary | Type
--+---------------------+-----------------------------------------------------------+--------
i | libyui-ncurses-pkg7 | Libyui - yast2 package selector widget for the ncurses UI | package
i | libyui-ncurses6 | Libyui - Character Based User Interface | package
i | libyui-ncurses7 | Libyui - Character Based User Interface | package
i | libyui-qt-pkg7 | Libyui - Qt Package Selector | package
i | libyui-qt6 | Libyui - Qt User Interface | package
i | libyui-qt7 | Libyui - Qt User Interface | package
i | libyui6 | Libyui - GUI-abstraction library | package
i | libyui7 | Libyui - GUI-abstraction library | package

Are the above installed and from SP1 repositories.

ttrcf
29-Jan-2016, 17:36
If I run:

zypper install -f libyui-ncurses-pkg7

I get:

Refreshing service 'Legacy_Module_12_x86_64'.
Refreshing service 'SUSE_Linux_Enterprise_Server_12_SP1_x86_64'.
Refreshing service 'SUSE_Linux_Enterprise_Software_Development_Kit_12 _SP1_x86_64'.
Retrieving repository 'SLE-SDK12-SP1-Updates' metadata ..................................[done]
Building repository 'SLE-SDK12-SP1-Updates' cache .......................................[done]
Loading repository data...
Reading installed packages...
Forcing installation of 'libyui-ncurses-pkg7-2.48.2-1.2.x86_64' from repository 'SLES12-SP1-Pool'.
Resolving package dependencies...

Problem: libyui-ncurses-pkg7-2.48.2-1.2.x86_64 requires libzypp.so.1519()(64bit), but this requirement cannot be provided
uninstallable providers: libzypp-15.19.5-1.14.x86_64[SUSE_Linux_Enterprise_Server_12_SP1_x86_64:SLES12-SP1-Pool]
Solution 1: Following actions will be done:
deinstallation of libyui-ncurses-pkg6-2.46.1-3.4.x86_64
deinstallation of libyui-qt-pkg6-2.44.7-3.2.x86_64
Solution 2: do not install libyui-ncurses-pkg7-2.48.2-1.2.x86_64
Solution 3: break libyui-ncurses-pkg7-2.48.2-1.2.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/c] (c):

What should I do?

ROB

malcolmlewis
29-Jan-2016, 17:59
Hi
So it looks like you don't have all the repositories, plus an old one.

What does the output from;


zypper lr


You could also try re-registering the system, but lets have a look at the above first.

ttrcf
01-Feb-2016, 12:24
zypper lr gives:

# | Alias | Name | Enabled | GPG Check | Refresh
---+----------------------------------------------------------------------------------------------+---------------------------------------+---------+-----------+--------
1 | Legacy_Module_12_x86_64:SLE-Module-Legacy12-Debuginfo-Pool | SLE-Module-Legacy12-Debuginfo-Pool | No | ---- | No
2 | Legacy_Module_12_x86_64:SLE-Module-Legacy12-Debuginfo-Updates | SLE-Module-Legacy12-Debuginfo-Updates | No | ---- | Yes
3 | Legacy_Module_12_x86_64:SLE-Module-Legacy12-Pool | SLE-Module-Legacy12-Pool | Yes | (r ) Yes | No
4 | Legacy_Module_12_x86_64:SLE-Module-Legacy12-Updates | SLE-Module-Legacy12-Updates | Yes | (r ) Yes | Yes
5 | SLES12-12-0 | SLES12-12-0 | No | ---- | No
6 | SUSE_Linux_Enterprise_Server_12_SP1_x86_64:SLES12-SP1-Debuginfo-Pool | SLES12-SP1-Debuginfo-Pool | No | ---- | No
7 | SUSE_Linux_Enterprise_Server_12_SP1_x86_64:SLES12-SP1-Debuginfo-Updates | SLES12-SP1-Debuginfo-Updates | No | ---- | Yes
8 | SUSE_Linux_Enterprise_Server_12_SP1_x86_64:SLES12-SP1-Pool | SLES12-SP1-Pool | Yes | (r ) Yes | No
9 | SUSE_Linux_Enterprise_Server_12_SP1_x86_64:SLES12-SP1-Source-Pool | SLES12-SP1-Source-Pool | No | ---- | No
10 | SUSE_Linux_Enterprise_Server_12_SP1_x86_64:SLES12-SP1-Updates | SLES12-SP1-Updates | Yes | (r ) Yes | Yes
11 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ SP1_x86_64:SLE-SDK12-SP1-Debuginfo-Pool | SLE-SDK12-SP1-Debuginfo-Pool | No | ---- | No
12 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ SP1_x86_64:SLE-SDK12-SP1-Debuginfo-Updates | SLE-SDK12-SP1-Debuginfo-Updates | No | ---- | Yes
13 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ SP1_x86_64:SLE-SDK12-SP1-Pool | SLE-SDK12-SP1-Pool | Yes | (r ) Yes | No
14 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ SP1_x86_64:SLE-SDK12-SP1-Source-Pool | SLE-SDK12-SP1-Source-Pool | No | ---- | No
15 | SUSE_Linux_Enterprise_Software_Development_Kit_12_ SP1_x86_64:SLE-SDK12-SP1-Updates | SLE-SDK12-SP1-Updates | Yes | (r ) Yes | Yes

Regards

ROB

PS Many thanks for your help.

ttrcf
17-Feb-2016, 15:55
Have now got exactly the same issue updating a SLED12 machine to SP1.

ROB

CraigS
09-Mar-2016, 13:05
Hi Guys,

This solved it for me: https://www.suse.com/communities/blog/upgrading-running-demand-instances-public-cloud/

Here is the good part:

Problem: zypper-1.12.23-1.3.x86_64 requires libzypp.so.1519()(64bit), but this requirement cannot be provided

There is nothing to worry about the package that provides the necessary library was renamed and the proper (libyui-ncurses-pkg7) will automatically be pulled in. Therefore the solution is to select Solution: 1

Solution 1: deinstallation of libyui-ncurses-pkg6-2.46.1-3.4.x86_64

by entering 1 at the prompt. Then enter y at the next prompt

Cheers,
Craig.

ttrcf
14-Mar-2016, 13:33
That sorted it.

Many thanks

ROB