PDA

View Full Version : SLES-Other SLES 11 sp1 clone wont register



philhess
29-Jan-2016, 16:17
Hello I have two SLES 11.1 servers. The first one is registered successfully on scc.suse.com but its subscription is expired, Im in the process of purchasing another year. I then have a Vmware clone of this same machine for testing purposes. Id like to get it registered and under support as well but I cannot get it to show up on scc.suse.com. suse_register fails with SSL connect error 35. Trying through YAST and Novell customer center sends me to a browser and it does nothing, I cant click continue. I realize these servers are out of date, but they were not setup by me and Im trying to get them up to date. Ive tried to manually add repos with zypper ar but I dont have any solid repos to add. I just want to get this server registered and get support renewed. Any suggestions? Thanks!

philhess
29-Jan-2016, 17:04
I think I found the issue and the differences between my servers. OpenSSL needs updated on the one that wont register. Its at 0.9.8h. The one that does register is at 0.9.8j.

Is there anyway to manually update openssl without an active support subscription so I can get this registered and start getting updates. My update repo doesnt contain this update. Then Ill got to SP2 and up to SP4.

malcolmlewis
29-Jan-2016, 17:30
I think I found the issue and the differences between my servers. OpenSSL needs updated on the one that wont register. Its at 0.9.8h. The one that does register is at 0.9.8j.

Is there anyway to manually update openssl without an active support subscription so I can get this registered and start getting updates. My update repo doesnt contain this update. Then Ill got to SP2 and up to SP4.
Hi
If one system is registered, then you should be able to down load the individual rpms...
https://download.suse.com/patch/finder/#bu=suse&familyId=7261&productId=26322&dateRange=&startDate=&endDate=&priority=&architecture=&keywords=OpenSSL

philhess
29-Jan-2016, 19:24
Unfortunately upgrading openssl to 0.9.8j did not help. Even though this article explains my exact issue and upgrading to 0.9.8j is the solution for sles 11.1

philhess
29-Jan-2016, 20:33
I went to 0.9.8t that I got from evergreen, registration somewhat works now, no SSL error. I used a reg code from an eval link and I know see that under my scc.suse.com page, but the system itself is not registering there.

philhess
29-Jan-2016, 20:50
Now I get this error when attempting to register

Apache Tomcat/5.5

400 An improper GUID was provided.

Im going to assume because Im attempting to use an SLES 11 SP4 eval code and my server is SLES 11 SP1. At this point I have no idea how to get this machine under my account so I can renew support for it and get updates. I appreciate any help. Thanks.

malcolmlewis
29-Jan-2016, 22:59
Hi
No the codes are not release dependent, it's because it's out of general support, so no online repositories....

You might have to re-think the upgrade vs a fresh install? Or maybe an offline upgrade via the DVD's?

philhess
01-Feb-2016, 14:57
I agree I may just have to download sp2 and sp3 isos and upgrade that way to get up to sp4.

philhess
01-Feb-2016, 15:42
This article worked for me and got me to issue the suse_register command without any errors. I used the SLE 11 steps.

https://www.novell.com/support/kb/doc.php?id=3303599

However this system is still not showing up under my scc.suse.com site. The eval code is there but my system is not tied to it. I made sure to use -a moniker as part of the suse_register command too.

philhess
01-Feb-2016, 16:04
Everything is showing up correctly now in scc.suse.com I hope that link helps someone else with the same issue.