View Full Version : SLES 11 SP3 HELP!! tcp auto_tuning long fat pipe doesn't work

01-Feb-2016, 19:14
Hello everybody,
i'm experiencing a very poor performance using a leased line of 155Mbps and a RTT of 270ms between the endpoints.. The transfer is by ftp.. I'm not able to use more than 3/4 Mbps for single transfering.. I already set the tcp Window size of the sender(sles11) and receiver (sles10), setting default tcp_wmem and tcp_rmem equal to BDP ( around 11MB). i set on both sides the max_tcp_rmem and max_tcp_wmem to 16M.. i enabled on both sides the Window scaling, the timestamp using, i also increase the txqueuelen of the sender network driver, but nothing change.. I tried to disable the autotuning of the receiver, and i tried also to increase the initcwnd of the sender to avoid slow start at the begin..
I also replicated that behaviour using two virtual server and adding a delay by "tc" Linux command..

I capture a dump using wireshark and i tried to analyze that using tcptrace.. It seems that sender's congestion window doesn't increase even if the receiver advertised window is great almost like BDP ..
Could somebody help me to set the optimal setting to permit full-capacity trhoughput of the link using one single transfer?

How can I attach you wireshark dump and the sysctl params of sender/receiver?

Thanks for your great help!


03-Feb-2016, 23:28
I have only SLED12 machines and this sysctl-settings works fine:

# more /etc/sysctl.conf

# 16 MegaByte TCP-Window Size
net.ipv4.tcp_rmem = 4096 87380 33554432
net.ipv4.tcp_wmem = 4096 16384 33554432

For more information about this sysctl-settings please read:

# man tcp

Test your new sysctl-settings with one of this ftp servers:

ftp://ftp-stud.hs-esslingen.de Server details: http://ftp-stud.hs-esslingen.de/info/

ftp://mirror.switch.ch/ Server details: http://mirror.switch.ch/about.html

ftp://ftp.jaist.ac.jp/ Server details: http://ftp.jaist.ac.jp/

04-Feb-2016, 00:36
Here an example "TCP Window Size = 6 MegaByte" => Win=6322176