PDA

View Full Version : neutron proposal install failed



huaweisoftware
02-Feb-2016, 02:06
I want to install suse cloud5,and when i installed neutron proposal,i failed.Here is the details:
error: Failed dependencies:
kernel(default:vmlinux) = 57ef2900a08ba774 is needed by openvswitch-kmp-default-2.1.2_3.0.101_0.46-0.10.19.x86_64
kernel(default:net_netfilter_netfilter) = a5ad2a7f92413255 is needed by openvswitch-kmp-default-2.1.2_3.0.101_0.46-0.10.19.x86_64
kernel(default:net_ipv4_inet_connection_sock) = 1e6a3c851d3acb01 is needed by openvswitch-kmp-default-2.1.2_3.0.101_0.46-0.10.19.x86_64
kernel(default:drivers_char_random) = 50836c34780c0a80 is needed by openvswitch-kmp-default-2.1.2_3.0.101_0.46-0.10.19.x86_64
kernel(default:kernel_module) = 03d42e983912f49a is needed by openvswitch-kmp-default-2.1.2_3.0.101_0.46-0.10.19.x86_64

so,what repo or anything else i lack? And where can i get? i was comfused for a long time, and waitting for some help.

huaweisoftware
02-Feb-2016, 03:01
i do not have SLES11-SP3-Pool/Updates and SUSE-Cloud-5-Pool/Updates repos, so it is the matter?And i really want to know how to get the repos i lack.

eblock
02-Feb-2016, 17:01
Hi,

first of all, you should not create several threads for the same topic, this won't enforce anyone to answer sooner ;-)

Did you follow the documentation for cloud 5 (https://www.suse.com/documentation/suse-cloud-5/singlehtml/book_cloud_deploy/book_cloud_deploy.html)? I was able to deploy a running cloud following the instructions there.
Your error messages sound like you don't have the latest packages installed, so I would say "yes", you should have access to the respective repositories. Did you follow the hardware and software requirements (Admin Server and Control Node should run on SUSE Linux Enterprise Server 11 SP3)?

bmwiedemann
03-Feb-2016, 07:56
I want to install suse cloud5,and when i installed neutron proposal,i failed.Here is the details:
error: Failed dependencies:
kernel(default:vmlinux) = 57ef2900a08ba774 is needed by openvswitch-kmp-default-2.1.2_3.0.101_0.46-0.10.19.x86_64

so,what repo or anything else i lack? And where can i get? i was comfused for a long time, and waitting for some help.

looking at the name of the openvswitch-kmp, you will need kernel-default-3.0.101-0.46 or newer from the SLES11-SP3-Updates repo, which you should mirror with SMT and have crowbar provide it to other cloud nodes as documented in:

https://www.suse.com/documentation/suse-cloud-5/singlehtml/book_cloud_deploy/book_cloud_deploy.html#sec.depl.adm_inst.smt