PDA

View Full Version : neutron proposal install failed again



huaweisoftware
02-Feb-2016, 06:04
I want to install suse cloud5,and when i installed neutron proposal,i failed.Here is the details:

Failed to apply the proposal to: de4-11-5b-b4-51-8a.site
Most recent logged lines from the Chef run:
================================================== ==============================

Mixlib::ShellOut::ShellCommandFailed
------------------------------------
Expected process to exit with [0], but received '1'
---- Begin output of ovs-vsctl del-port br-public eth0 ; ovs-vsctl add-port br-public eth0 ----
STDOUT:
STDERR: ovs-vsctl: bridge br-public does not have a port eth0
ovs-vsctl: cannot create a port named eth0 because a port named eth0 already exists on bridge br-fixed
---- End output of ovs-vsctl del-port br-public eth0 ; ovs-vsctl add-port br-public eth0 ----
Ran ovs-vsctl del-port br-public eth0 ; ovs-vsctl add-port br-public eth0 returned 1

Resource Declaration:
---------------------
# In /var/chef/cache/cookbooks/neutron/recipes/common_agent.rb

248: execute "Neutron: add #{bound_if} to #{name}" do
249: command "ovs-vsctl del-port #{name} #{bound_if} ; ovs-vsctl add-port #{name} #{bound_if}"
250: not_if "ovs-dpctl show system@#{name} | grep -q #{bound_if}"
251: end
252: ruby_block "Have #{name} usurp config from #{bound_if}" do

Compiled Resource:
------------------
# Declared in /var/chef/cache/cookbooks/neutron/recipes/common_agent.rb:248:in `block in from_file'

execute("Neutron: add eth0 to br-public") do
action "run"
retries 0
retry_delay 2
command "ovs-vsctl del-port br-public eth0 ; ovs-vsctl add-port br-public eth0"
backup 5
returns 0
cookbook_name "neutron"
recipe_name "common_agent"
not_if "ovs-dpctl show system@br-public | grep -q eth0"
end

[2016-01-31T22:50:01-05:00] ERROR: Running exception handlers
[2016-01-31T22:50:01-05:00] FATAL: Saving node information to /var/chef/cache/failed-run-data.json
[2016-01-31T22:50:01-05:00] ERROR: Exception handlers complete
[2016-01-31T22:50:01-05:00] FATAL: Stacktrace dumped to /var/chef/cache/chef-stacktrace.out
[2016-01-31T22:50:01-05:00] FATAL: Mixlib::ShellOut::ShellCommandFailed: execute[Neutron: add eth0 to br-public] (neutron::common_agent line 248) had an error: Mixlib::ShellOut::ShellCommandFailed: Expected process to exit with [0], but received '1'
---- Begin output of ovs-vsctl del-port br-public eth0 ; ovs-vsctl add-port br-public eth0 ----
STDOUT:
STDERR: ovs-vsctl: bridge br-public does not have a port eth0
ovs-vsctl: cannot create a port named eth0 because a port named eth0 already exists on bridge br-fixed
---- End output of ovs-vsctl del-port br-public eth0 ; ovs-vsctl add-port br-public eth0 ----
Ran ovs-vsctl del-port br-public eth0 ; ovs-vsctl add-port br-public eth0 returned 1

I was comfused for a long time, and waitting for some help.

Automatic reply
08-Feb-2016, 06:30
huaweisoftware,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- Open a service request: https://www.suse.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot..

Good luck!

Your SUSE Forums Team
http://forums.suse.com