PDA

View Full Version : SLES 11 SP4 Upgrading PHP 5.2.14 to 5.3.3



KingGoon
05-Feb-2016, 22:19
Hi Folks,

I am in the middle of getting dokuwiki up and running on my SUSE 11 server, but ran into a php problem.

I followed a php guide to install php, and that pretty much said to:

zypper in php5 php5-mysql apache2-mod_php5 THEN use a2enmod php5( to enable the mod)

Everything works. and now I currently have php 5.2.14 installed. I went to try to install dokuwiki, and it says I need 5.3.3. I searched everywhere for a tutorial or guide or something to help me in upgrading and I cannot find anything. At this point, I am debating whether I should continue with the upgrade, or remove the old version and install a newer version. I am fine with either, but just wanted some more expert advice, or some good links to follow on doing either the upgrade or installing brand new.

Let me know if you guys need me to clarify anything.

Thanks in advance for you're help.

malcolmlewis
06-Feb-2016, 23:12
Hi
Have you added the SLE 11 SDK SP4 'Add On' repositories? If not, you need to add this repo and the update one, then upgrade to the php53-* packages.

KingGoon
08-Feb-2016, 16:13
I'm not too familiar with where the repositories are on SUSE. I know ubuntu, its sources.list, but what is it on SUSE?

Also, is there a guide/tutorial or something that I can look at while I do so, so I know what exactly to add and where to add. Also, is there a guide for the upgrade process?

Thanks for you're time and response, malcolmlewis

KingGoon
08-Feb-2016, 16:57
Hi
Have you added the SLE 11 SDK SP4 'Add On' repositories? If not, you need to add this repo and the update one, then upgrade to the php53-* packages.

So I went ahead and tried to install the SLE 11 SDK SP4 repositories, and it said they were already installed.

I then followed another link and it said to just simple run
zypper in php53* to upgrade the php version. It ran into some conflicts for the previous version, but it pretty much said to remove them so I did.

I now run
php -v , and the version installed is 5.3.17, except I am getting two errors when I run that command. Here are the errors.



PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php5/extensions/pdo_pgsql.so' - libpq.so.5: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php5/extensions/pgsql.so' - libpq.so.5: cannot open shared object file: No such file or directory in Unknown on line 0

malcolmlewis
08-Feb-2016, 17:21
On Mon 08 Feb 2016 04:04:01 PM CST, KingGoon wrote:

malcolmlewis;31419 Wrote:
> Hi
> Have you added the SLE 11 SDK SP4 'Add On' repositories? If not, you
> need to add this repo and the update one, then upgrade to the php53-*
> packages.

So I went ahead and tried to install the SLE 11 SDK SP4 repositories,
and it said they were already installed.

I then followed another link and it said to just simple run
Code:
--------------------
zypper in php53*
--------------------
to upgrade the php version. It ran into some conflicts for the previous
version, but it pretty much said to remove them so I did.

I now run
Code:
--------------------
php -v
--------------------
, and the version installed is 5.3.17, except I am getting two errors
when I run that command. Here are the errors.


Code:
--------------------

PHP Warning: PHP Startup: Unable to load dynamic library
'/usr/lib64/php5/extensions/pdo_pgsql.so' - libpq.so.5: cannot open
shared object file: No such file or directory in Unknown on line 0 PHP
Warning: PHP Startup: Unable to load dynamic library
'/usr/lib64/php5/extensions/pgsql.so' - libpq.so.5: cannot open shared
object file: No such file or directory in Unknown on line 0
--------------------




Hi
Have you installed php53-pgsql?

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 SP1|GNOME 3.10.4|3.12.51-60.25-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

KingGoon
08-Feb-2016, 17:43
zypper in php53-pgsql


with results :



OFPlayGround:/etc/products.d # zypper in php53-pgsql
Refreshing service 'spacewalk'.
Loading repository data...
Reading installed packages...
'php53-pgsql' is already installed.
No update candidate for 'php53-pgsql-5.3.17-48.1.x86_64'. The highest available version is already installed.
Resolving package dependencies...

Nothing to do.

malcolmlewis
08-Feb-2016, 18:02
On Mon 08 Feb 2016 04:44:01 PM CST, KingGoon wrote:

Code:
--------------------

zypper in php53-pgsql

--------------------


with results :


Code:
--------------------

OFPlayGround:/etc/products.d # zypper in php53-pgsql
Refreshing service 'spacewalk'.
Loading repository data...
Reading installed packages...
'php53-pgsql' is already installed.
No update candidate for 'php53-pgsql-5.3.17-48.1.x86_64'. The highest
available version is already installed. Resolving package
dependencies...
Nothing to do.

--------------------




Hi
OK, so did libpq5 get updated?

Can you run;


zypper ref
zypper ve

Just to verify everything is ok?


--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 SP1|GNOME 3.10.4|3.12.51-60.25-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

KingGoon
08-Feb-2016, 20:20
zypper ref




Refreshing service 'spacewalk'.
Repository 'sle11-sdk-sp1-pool-x86_64-sdk-sp3-20151208' is up to date.
Repository 'sle11-sdk-sp1-updates-x86_64-sdk-sp3-20151208' is up to date.
Repository 'sle11-sdk-sp2-core-x86_64-sdk-sp3-20151208' is up to date.
Repository 'sle11-sdk-sp2-updates-x86_64-sdk-sp3-20151208' is up to date.
Repository 'sle11-sdk-sp3-pool-x86_64-20151208' is up to date.
Repository 'sle11-sdk-sp3-updates-x86_64-20151208' is up to date.
Repository 'sles11-sp1-pool-x86_64-sles-sp3-20151208' is up to date.
Repository 'sles11-sp1-updates-x86_64-sles-sp3-20151208' is up to date.
Repository 'sles11-sp2-core-x86_64-sles-sp3-20151208' is up to date.
Repository 'sles11-sp2-suse-manager-tools-x86_64-sp3-20151208' is up to date.
Repository 'sles11-sp2-updates-x86_64-sles-sp3-20151208' is up to date.
Repository 'sles11-sp3-adp-x86_64-20151208' is up to date.
Repository 'sles11-sp3-pool-x86_64-20151208' is up to date.
Repository 'sles11-sp3-updates-x86_64-20151208' is up to date.
All repositories have been refreshed.





zypper ve


products code


Refreshing service 'spacewalk'.
Loading repository data...
Reading installed packages...

Problem: rhncfg-client-5.10.27.12-0.5.1.noarch requires rhncfg = 5.10.27.12-0.5.1, but this requirement cannot be provided
uninstallable providers: rhncfg-5.10.27.12-0.5.1.noarch[spacewalk:sles11-sp2-suse-manager-tools-x86_64-sp3-20151208]
Solution 1: Following actions will be done:
downgrade of rhnlib-2.5.69.7-0.7.1.x86_64 to rhnlib-2.5.51.5-0.5.1.x86_64
downgrade of spacewalk-client-tools-2.1.16.9-12.1.noarch to spacewalk-client-tools-1.7.14.19-0.5.3.noarch
downgrade of spacewalk-client-setup-2.1.16.9-12.1.noarch to spacewalk-client-setup-1.7.14.19-0.5.3.noarch
downgrade of spacewalk-check-2.1.16.9-12.1.noarch to spacewalk-check-1.7.14.19-0.5.3.noarch
Solution 2: deinstallation of rhncfg-client-5.10.27.12-0.5.1.noarch
Solution 3: break rhncfg-client-5.10.27.12-0.5.1.noarch by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/c] (c):

malcolmlewis
08-Feb-2016, 22:23
On Mon 08 Feb 2016 07:24:01 PM CST, KingGoon wrote:



Refreshing service 'spacewalk'.
Repository 'sle11-sdk-sp1-pool-x86_64-sdk-sp3-20151208' is up to date.
Repository 'sle11-sdk-sp1-updates-x86_64-sdk-sp3-20151208' is up to
date. Repository 'sle11-sdk-sp2-core-x86_64-sdk-sp3-20151208' is up to
date. Repository 'sle11-sdk-sp2-updates-x86_64-sdk-sp3-20151208' is up
to date. Repository 'sle11-sdk-sp3-pool-x86_64-20151208' is up to date.
Repository 'sle11-sdk-sp3-updates-x86_64-20151208' is up to date.
Repository 'sles11-sp1-pool-x86_64-sles-sp3-20151208' is up to date.
Repository 'sles11-sp1-updates-x86_64-sles-sp3-20151208' is up to
date. Repository 'sles11-sp2-core-x86_64-sles-sp3-20151208' is up to
date. Repository 'sles11-sp2-suse-manager-tools-x86_64-sp3-20151208' is
up to date. Repository 'sles11-sp2-updates-x86_64-sles-sp3-20151208' is
up to date. Repository 'sles11-sp3-adp-x86_64-20151208' is up to date.
Repository 'sles11-sp3-pool-x86_64-20151208' is up to date.
Repository 'sles11-sp3-updates-x86_64-20151208' is up to date.
All repositories have been refreshed.



Hi
This is a pure SLES 11 SP3 system (Not OES?), with active older
repositories?

And the status of libpq5?

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 SP1|GNOME 3.10.4|3.12.51-60.25-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

KingGoon
09-Feb-2016, 16:15
Yes this is an SLES 11 SP3 system. I decided this is too much trouble, so I am going to try the same on my SUSE 12 box. I will create a new thread for help .