PDA

View Full Version : HANA ./hdbinst - Perl Complation Error



Sakuranes
16-Feb-2016, 13:55
Hello SAP Gurus,

I need help with the HANA Database Installation. When I start the SAP_Hana_Database Installation on our SUSE Linux System via Terminal with ./hdbinst I get the follwing error:

SAP HANA Installer runtime Error:
perl compilation error (loading SAP: :Install):
Can't locate SAPDB/Install.pm in /usr/hana/HANA_Server_100/SAP_HANA_DATABASE/instruntime/SDBINST.TGZ at SDBRUN.pl line 370.

Any Idea how I can fix that? :confused:

Automatic reply
22-Feb-2016, 06:30
Sakuranes,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- Open a service request: https://www.suse.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot..

Good luck!

Your SUSE Forums Team
http://forums.suse.com

dvramakrishna123
26-Feb-2016, 09:48
Hi,
Can we know why you are using the hdbinst, instead use the hdblcm and let us see if you face the same error.

Best Regards,
Venkata

Sakuranes
29-Feb-2016, 15:03
Hi,
Can we know why you are using the hdbinst, instead use the hdblcm and let us see if you face the same error.

Best Regards,
Venkata

Hi,

I want to avoid the Hardware Check thats the reason why I dont use hdblcm. :)

Best Regards,

Sakuranes

Sakuranes
17-Mar-2016, 11:00
Hello SAP Gurus,

I need help with the HANA Database Installation. When I start the SAP_Hana_Database Installation on our SUSE Linux System via Terminal with ./hdbinst I get the follwing error:

SAP HANA Installer runtime Error:
perl compilation error (loading SAP: :Install):
Can't locate SAPDB/Install.pm in /usr/hana/HANA_Server_100/SAP_HANA_DATABASE/instruntime/SDBINST.TGZ at SDBRUN.pl line 370.

Any Idea how I can fix that? :confused:

Still no one who has the same problem?

jmozdzen
17-Mar-2016, 13:08
Hi Sakuranes,

what did the SAP folks say? The issue seems to be related to the SAP installer, rather than the base system...

Regards,
Jens

Sakuranes
18-Mar-2016, 08:20
Hi Sakuranes,

what did the SAP folks say? The issue seems to be related to the SAP installer, rather than the base system...

Regards,
Jens

Nothing usefull. So that means I should download the SAP HANA packages again? Or setup the whole SUSE Server new?

Thanks for help!

Regards,
Sakuranes

jmozdzen
18-Mar-2016, 13:27
Hi Sakuranes,

the message seems to imply that some SAP installer class could not be found:

SAP HANA Installer runtime Error:
perl compilation error (loading SAP: :Install):
Can't locate SAPDB/Install.pm in /usr/hana/HANA_Server_100/SAP_HANA_DATABASE/instruntime/SDBINST.TGZ at SDBRUN.pl line 370.

The file name "/usr/hana/HANA_Server_100/SAP_HANA_DATABASE/instruntime/SDBINST.TGZ" indicates that it is a compress tar archive, rather than a directory structure - did you specify that name somewhere? Then probably you should have unpacked that file and have pointed the installer at the location where the files were extracted to.

I'm no SAP pro, this is all from looking at the message you provided.

Regards,
Jens

Sakuranes
18-Mar-2016, 14:39
Hi Sakuranes,

the message seems to imply that some SAP installer class could not be found:

SAP HANA Installer runtime Error:
perl compilation error (loading SAP: :Install):
Can't locate SAPDB/Install.pm in /usr/hana/HANA_Server_100/SAP_HANA_DATABASE/instruntime/SDBINST.TGZ at SDBRUN.pl line 370.

The file name "/usr/hana/HANA_Server_100/SAP_HANA_DATABASE/instruntime/SDBINST.TGZ" indicates that it is a compress tar archive, rather than a directory structure - did you specify that name somewhere? Then probably you should have unpacked that file and have pointed the installer at the location where the files were extracted to.

I'm no SAP pro, this is all from looking at the message you provided.

Regards,
Jens

Hello Jens,

Yes you are right there is a file SDBINST.TGZ and I've extracted it already but then the installation fails with the Message that SDBINST.TGZ ist missed - means that the installer need this compressed archive as it is... I see that there is no Install.pm ind de SAPDB folder, where he search it... but its a folder deeper in the structure...
Perhaps I really should download the whole hana setup again...

Thanks for your help - if you have other tips please answer ;)

jmozdzen
18-Mar-2016, 15:31
Hi Sakuranes,


Hello Jens,

Yes you are right there is a file SDBINST.TGZ and I've extracted it already but then the installation fails with the Message that SDBINST.TGZ ist missed - means that the installer need this compressed archive as it is... I see that there is no Install.pm ind de SAPDB folder, where he search it... but its a folder deeper in the structure...
Perhaps I really should download the whole hana setup again...

Thanks for your help - if you have other tips please answer ;)

if the installer script you're invoking is some bash script, have you tried running it via "bash -x yourscript"? That will turn on bash tracing and show what the script tries to do. Maybe that way you'll see some hint on what the author of the script intended to do, and find a way around the problem?

IOW - if I were in your position, I'd try to debug the installation script (at least the bash part)... that may take some time, but as it seems you're not getting any help from SAP, that may be your only chance to make it work.

Regards,
Jens