PDA

View Full Version : SLES 11 SP3 Security Module not available in SLES 11 for VMware



canavan
07-Mar-2016, 19:45
I'd like to install the Security Module on a Server that is currently running the "VMware edition" of SLES 11 SP3.
I have update the server from sp2 to sp3, and I would have expected the security module to become available automatically as a repository, as described in https://www.suse.com/communities/blog/introducing-the-suse-linux-enterprise-11-security-module/

However, zypper -lr doesn't list the security module, and my attempts so far to fabricate a repository file with baseurl=https://nu.novell.com/repo/$RCE/SLE11-Security-Module/sle-11-x86_64?credentials=NCCcredentials have only resulted in the message Visit the Novell Customer Center to check whether your registration is valid and has not expired. Since the update to Sp3 worked and zypper refresh doesn't complain about any other repositories, I believe that my registration (the one that is tied to VMware) is still valid. Are there any special procedures to get the security module on SLES 11 for VMware? Any other hints how to proceed?



# zypper lr -u
# | Alias | Name | Enabled | Refresh | URI
---+---------------------------------------------------------------------+-------------------------------------------------------+---------+---------+-----------------------------------------------------------------------------------------------------
1 | SUSE-Linux-Enterprise-Server-11-SP2 11.2.2-1.234 | SUSE-Linux-Enterprise-Server-11-SP2 11.2.2-1.234 | No | No | cd:///?devices=/dev/sr0
2 | SUSE-Linux-Enterprise-Software-Development-Kit-11-SP2_11.2.2-1.66 | SUSE Linux Enterprise Software Development Kit 11 SP2 | No | No | cd:///
3 | SUSE-Linux-Enterprise-Software-Development-Kit-11-SP2_11.2.2-1.66_1 | SUSE Linux Enterprise Software Development Kit 11 SP2 | No | No | cd:///?devices=/dev/sr1
4 | nu_novell_com:SLE-Likewise-5.3-Updates | SLE-Likewise-5.3-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLE-Likewise-5.3-Updates/sle-11-x86_64?credentials=NCCcredentials
5 | nu_novell_com:SLE11-SDK-SP1-Pool | SLE11-SDK-SP1-Pool | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP1-Pool/sle-11-x86_64?credentials=NCCcredentials
6 | nu_novell_com:SLE11-SDK-SP1-Updates | SLE11-SDK-SP1-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP1-Updates/sle-11-x86_64?credentials=NCCcredentials
7 | nu_novell_com:SLE11-SDK-SP2-Core | SLE11-SDK-SP2-Core | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP2-Core/sle-11-x86_64?credentials=NCCcredentials
8 | nu_novell_com:SLE11-SDK-SP2-Updates | SLE11-SDK-SP2-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP2-Updates/sle-11-x86_64?credentials=NCCcredentials
9 | nu_novell_com:SLE11-SDK-SP3-Pool | SLE11-SDK-SP3-Pool | Yes | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP3-Pool/sle-11-x86_64?credentials=NCCcredentials
10 | nu_novell_com:SLE11-SDK-SP3-Updates | SLE11-SDK-SP3-Updates | Yes | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP3-Updates/sle-11-x86_64?credentials=NCCcredentials
11 | nu_novell_com:SLE11-SP1-Debuginfo-Pool | SLE11-SP1-Debuginfo-Pool | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SP1-Debuginfo-Pool/sle-11-x86_64?credentials=NCCcredentials
12 | nu_novell_com:SLE11-SP1-Debuginfo-Updates | SLE11-SP1-Debuginfo-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SP1-Debuginfo-Updates/sle-11-x86_64?credentials=NCCcredentials
13 | nu_novell_com:SLE11-SP2-Debuginfo-Core | SLE11-SP2-Debuginfo-Core | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SP2-Debuginfo-Core/sle-11-x86_64?credentials=NCCcredentials
14 | nu_novell_com:SLE11-SP2-Debuginfo-Updates | SLE11-SP2-Debuginfo-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SP2-Debuginfo-Updates/sle-11-x86_64?credentials=NCCcredentials
15 | nu_novell_com:SLE11-SP3-Debuginfo-Pool | SLE11-SP3-Debuginfo-Pool | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SP3-Debuginfo-Pool/sle-11-x86_64?credentials=NCCcredentials
16 | nu_novell_com:SLE11-SP3-Debuginfo-Updates | SLE11-SP3-Debuginfo-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SP3-Debuginfo-Updates/sle-11-x86_64?credentials=NCCcredentials
17 | nu_novell_com:SLED11-Extras | SLED11-Extras | No | Yes | https://nu.novell.com/repo/$RCE/SLED11-Extras/sle-11-x86_64?credentials=NCCcredentials
18 | nu_novell_com:SLED11-SP1-Pool | SLED11-SP1-Pool | No | Yes | https://nu.novell.com/repo/$RCE/SLED11-SP1-Pool/sle-11-x86_64?credentials=NCCcredentials
19 | nu_novell_com:SLED11-SP1-Updates | SLED11-SP1-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLED11-SP1-Updates/sle-11-x86_64?credentials=NCCcredentials
20 | nu_novell_com:SLES11-Extras | SLES11-Extras | No | Yes | https://nu.novell.com/repo/$RCE/SLES11-Extras/sle-11-x86_64?credentials=NCCcredentials
21 | nu_novell_com:SLES11-SP1-VMware-Pool | SLES11-SP1-VMware-Pool | No | Yes | https://nu.novell.com/repo/$RCE/SLES11-SP1-VMware-Pool/sle-11-x86_64?credentials=NCCcredentials
22 | nu_novell_com:SLES11-SP1-VMware-Updates | SLES11-SP1-VMware-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLES11-SP1-VMware-Updates/sle-11-x86_64?credentials=NCCcredentials
23 | nu_novell_com:SLES11-SP2-Extension-Store | SLES11-SP2-Extension-Store | No | Yes | https://nu.novell.com/repo/$RCE/SLES11-SP2-Extension-Store/sle-11-x86_64?credentials=NCCcredentials
24 | nu_novell_com:SLES11-SP2-VMware-Core | SLES11-SP2-VMware-Core | No | Yes | https://nu.novell.com/repo/$RCE/SLES11-SP2-VMware-Core/sle-11-x86_64?credentials=NCCcredentials
25 | nu_novell_com:SLES11-SP2-VMware-Updates | SLES11-SP2-VMware-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLES11-SP2-VMware-Updates/sle-11-x86_64?credentials=NCCcredentials
26 | nu_novell_com:SLES11-SP3-VMware-Pool | SLES11-SP3-VMware-Pool | Yes | Yes | https://nu.novell.com/repo/$RCE/SLES11-SP3-VMware-Pool/sle-11-x86_64?credentials=NCCcredentials
27 | nu_novell_com:SLES11-SP3-VMware-Updates | SLES11-SP3-VMware-Updates | Yes | Yes | https://nu.novell.com/repo/$RCE/SLES11-SP3-VMware-Updates/sle-11-x86_64?credentials=NCCcredentials

smflood
07-Mar-2016, 23:53
canavan Wrote in message:

> I'd like to install the Security Module on a Server that is currently
> running the "VMware edition" of SLES 11 SP3.
> I have update the server from sp2 to sp3, and I would have expected the
> security module to become available automatically as a repository, as
> described in
> https://www.suse.com/communities/blog/introducing-the-suse-linux-enterprise-11-security-module/
>
> However, zypper -lr doesn't list the security module, and my attempts so
> far to fabricate a repository file with
> baseurl=https://nu.novell.com/repo/$RCE/SLE11-Security-Module/sle-11-x86_64?credentials=NCCcredentials
> have only resulted in the message -Visit the Novell Customer Center to
> check whether your registration is valid and has not expired.- Since the
> update to Sp3 worked and zypper refresh doesn't complain about any other
> repositories, I believe that my registration (the one that is tied to
> VMware) is still valid. Are there any special procedures to get the
> security module on SLES 11 for VMware? Any other hints how to proceed?
>
>
> Code:
> --------------------
>
> # zypper lr -u
> # | Alias | Name | Enabled | Refresh | URI
> ---+---------------------------------------------------------------------+-------------------------------------------------------+---------+---------+-----------------------------------------------------------------------------------------------------
> 1 | SUSE-Linux-Enterprise-Server-11-SP2 11.2.2-1.234 | SUSE-Linux-Enterprise-Server-11-SP2 11.2.2-1.234 | No | No | cd:///?devices=/dev/sr0
> 2 | SUSE-Linux-Enterprise-Software-Development-Kit-11-SP2_11.2.2-1.66 | SUSE Linux Enterprise Software Development Kit 11 SP2 | No | No | cd:///
> 3 | SUSE-Linux-Enterprise-Software-Development-Kit-11-SP2_11.2.2-1.66_1 | SUSE Linux Enterprise Software Development Kit 11 SP2 | No | No | cd:///?devices=/dev/sr1
> 4 | nu_novell_com:SLE-Likewise-5.3-Updates | SLE-Likewise-5.3-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLE-Likewise-5.3-Updates/sle-11-x86_64?credentials=NCCcredentials
> 5 | nu_novell_com:SLE11-SDK-SP1-Pool | SLE11-SDK-SP1-Pool | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP1-Pool/sle-11-x86_64?credentials=NCCcredentials
> 6 | nu_novell_com:SLE11-SDK-SP1-Updates | SLE11-SDK-SP1-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP1-Updates/sle-11-x86_64?credentials=NCCcredentials
> 7 | nu_novell_com:SLE11-SDK-SP2-Core | SLE11-SDK-SP2-Core | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP2-Core/sle-11-x86_64?credentials=NCCcredentials
> 8 | nu_novell_com:SLE11-SDK-SP2-Updates | SLE11-SDK-SP2-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP2-Updates/sle-11-x86_64?credentials=NCCcredentials
> 9 | nu_novell_com:SLE11-SDK-SP3-Pool | SLE11-SDK-SP3-Pool | Yes | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP3-Pool/sle-11-x86_64?credentials=NCCcredentials
> 10 | nu_novell_com:SLE11-SDK-SP3-Updates | SLE11-SDK-SP3-Updates | Yes | Yes | https://nu.novell.com/repo/$RCE/SLE11-SDK-SP3-Updates/sle-11-x86_64?credentials=NCCcredentials
> 11 | nu_novell_com:SLE11-SP1-Debuginfo-Pool | SLE11-SP1-Debuginfo-Pool | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SP1-Debuginfo-Pool/sle-11-x86_64?credentials=NCCcredentials
> 12 | nu_novell_com:SLE11-SP1-Debuginfo-Updates | SLE11-SP1-Debuginfo-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SP1-Debuginfo-Updates/sle-11-x86_64?credentials=NCCcredentials
> 13 | nu_novell_com:SLE11-SP2-Debuginfo-Core | SLE11-SP2-Debuginfo-Core | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SP2-Debuginfo-Core/sle-11-x86_64?credentials=NCCcredentials
> 14 | nu_novell_com:SLE11-SP2-Debuginfo-Updates | SLE11-SP2-Debuginfo-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SP2-Debuginfo-Updates/sle-11-x86_64?credentials=NCCcredentials
> 15 | nu_novell_com:SLE11-SP3-Debuginfo-Pool | SLE11-SP3-Debuginfo-Pool | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SP3-Debuginfo-Pool/sle-11-x86_64?credentials=NCCcredentials
> 16 | nu_novell_com:SLE11-SP3-Debuginfo-Updates | SLE11-SP3-Debuginfo-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLE11-SP3-Debuginfo-Updates/sle-11-x86_64?credentials=NCCcredentials
> 17 | nu_novell_com:SLED11-Extras | SLED11-Extras | No | Yes | https://nu.novell.com/repo/$RCE/SLED11-Extras/sle-11-x86_64?credentials=NCCcredentials
> 18 | nu_novell_com:SLED11-SP1-Pool | SLED11-SP1-Pool | No | Yes | https://nu.novell.com/repo/$RCE/SLED11-SP1-Pool/sle-11-x86_64?credentials=NCCcredentials
> 19 | nu_novell_com:SLED11-SP1-Updates | SLED11-SP1-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLED11-SP1-Updates/sle-11-x86_64?credentials=NCCcredentials
> 20 | nu_novell_com:SLES11-Extras | SLES11-Extras | No | Yes | https://nu.novell.com/repo/$RCE/SLES11-Extras/sle-11-x86_64?credentials=NCCcredentials
> 21 | nu_novell_com:SLES11-SP1-VMware-Pool | SLES11-SP1-VMware-Pool | No | Yes | https://nu.novell.com/repo/$RCE/SLES11-SP1-VMware-Pool/sle-11-x86_64?credentials=NCCcredentials
> 22 | nu_novell_com:SLES11-SP1-VMware-Updates | SLES11-SP1-VMware-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLES11-SP1-VMware-Updates/sle-11-x86_64?credentials=NCCcredentials
> 23 | nu_novell_com:SLES11-SP2-Extension-Store | SLES11-SP2-Extension-Store | No | Yes | https://nu.novell.com/repo/$RCE/SLES11-SP2-Extension-Store/sle-11-x86_64?credentials=NCCcredentials
> 24 | nu_novell_com:SLES11-SP2-VMware-Core | SLES11-SP2-VMware-Core | No | Yes | https://nu.novell.com/repo/$RCE/SLES11-SP2-VMware-Core/sle-11-x86_64?credentials=NCCcredentials
> 25 | nu_novell_com:SLES11-SP2-VMware-Updates | SLES11-SP2-VMware-Updates | No | Yes | https://nu.novell.com/repo/$RCE/SLES11-SP2-VMware-Updates/sle-11-x86_64?credentials=NCCcredentials
> 26 | nu_novell_com:SLES11-SP3-VMware-Pool | SLES11-SP3-VMware-Pool | Yes | Yes | https://nu.novell.com/repo/$RCE/SLES11-SP3-VMware-Pool/sle-11-x86_64?credentials=NCCcredentials
> 27 | nu_novell_com:SLES11-SP3-VMware-Updates | SLES11-SP3-VMware-Updates | Yes | Yes | https://nu.novell.com/repo/$RCE/SLES11-SP3-VMware-Updates/sle-11-x86_64?credentials=NCCcredentials
>
> --------------------

I suspect you're not seeing the security module because it's
served via Novell Customer Center (NCC) and you're not registered
with that for your SLES licensing.

With support for SLES for VMware ending in August[1] you might
want to consider migrating from SLES for VMware to "regular" SLES
which should not only allow access to the security module but
also provide a route to SLES11 SP4.

HTH.

[1] http://blogs.vmware.com/vsphere/2014/06/sles
-vmware-end-availability-announcement.html (URL may break when
wrapping)
[2] https://www.suse.com/support/kb/doc.php?id=7015096
--
Simon Flood
SUSE Knowledge Partner


----Android NewsGroup Reader----
http://usenet.sinaapp.com/