PDA

View Full Version : System error code was: -4015



williamhanna
09-Mar-2012, 15:26
I was using yast2 to remove iscsi volume and the following error appeared on the desktop:

Failure occurred during following action:
Deleting logical volume /dev/vollinea00/logvol_iscsi_01
System error code was: -4015
/sbin/lvremove –f ‘/dev/vollinea00/logvol_iscsi_01’:
Can’t remove open logical volume “logvol_iscsi_01”


What’s the meaning of “System error code was: -4015”?
Sles11SP1 and all current updates installed.

Automatic reply
15-Mar-2012, 13:30
williamhanna,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team
http://forums.suse.com

Magic31
15-Mar-2012, 15:59
I Can’t remove open logical volume “logvol_iscsi_01”

...

What’s the meaning of “System error code was: -4015”?


As the message a little under it indicates... the system/a process still has an active/open LVM connection to the volume you are trying to delete.

Have you ensured all mounts to the volume have been unmounted and checked with 'lsof /dev/vollinea00/logvol_iscsi_01' what might me keeping a connection to the volume open?

If that's not clear, try rebooting the system (after having made sure there are not scripts/mount points set anymore) and deleting the volume after the reboot.

-Willem

williamhanna
22-Mar-2012, 15:31
As the message a little under it indicates... the system/a process still has an active/open LVM connection to the volume you are trying to delete.

Have you ensured all mounts to the volume have been unmounted and checked with 'lsof /dev/vollinea00/logvol_iscsi_01' what might me keeping a connection to the volume open?

If that's not clear, try rebooting the system (after having made sure there are not scripts/mount points set anymore) and deleting the volume after the reboot.

-Willem

I could manually remove the lvm. It seems that “System error was: -4015” is a generic yast error message, wich means the lvm is not free to be deleted..
Thanks,
William