PDA

View Full Version : SLES 11 SP4 Help me change parameter transparent_hugepage = never



siam_kubota
30-Mar-2016, 06:02
Please help ! i want to change status transparent_hugepage=never. Current default is transparent_hugepage=always .
this is command line for test. but not work after reboot suse enterprise server 11 sp4

1. solution
#echo never > /sys/kernel/mm/transparent_hugepage/enabled
#cat /sys/kernel/mm/transparent_hugepage/enabled
#always madvise [never]

****Current Suse 11 sp4 use ELILO is bootloader not use grub
*** use boot :> /boot/efi not use /boot

Thank you

ab
30-Mar-2016, 06:59
Anything under /proc or /sys or /dev is not real, so you must make it
persistent, and often that is done with the sysctl command, though in this
case I do not think that this is an option, so instead you can modify your
boot line in Grub, but since you're using LILO (or any boot loader you
could setup a service, or use after.local or something similar to run a
command at boot time. For more information, check out the thread here:

http://unix.stackexchange.com/questions/99154/disable-transparent-hugepages

While they are talking about RedHat Linux in particular, the options are
basically the same.

Note: Upgrade to SLES 12 SP1 and you'll have Grub2 so you can use the
solution there with Grub, or you could define a startup service with
systemd to do this very easily.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...