PDA

View Full Version : SLES 12 SP1 HA - Yast Cluster Config dependency on hawk



JNCService
13-Apr-2016, 17:58
So I just installed SLES 12 SP1 with the HA Extension Add-On. When I launch the Cluster configuration from yast, it prompts for the hawk package to be installed. When you click install it says there are unresolved dependencies.

It seems the Hawk2 package is installed, which I would expect, but the cluster configuration tool does not recognize that as the Hawk package it needs.

Is this an issue? Can i Just ignore the message and go on?

Thanks,

Jeff

thsundel
14-Apr-2016, 07:51
So I just installed SLES 12 SP1 with the HA Extension Add-On. When I launch the Cluster configuration from yast, it prompts for the hawk package to be installed. When you click install it says there are unresolved dependencies.

It seems the Hawk2 package is installed, which I would expect, but the cluster configuration tool does not recognize that as the Hawk package it needs.

Is this an issue? Can i Just ignore the message and go on?

Thanks,

Jeff

Does it say which packages are unresolved? Have you registered this system to receive updates from SUSE?

Thomas

JNCService
15-Apr-2016, 21:32
Thanks for your reply. After I launch the Cluster utility from Yast 2, the packages are;

Conflict Resolution: Option 1: deinstallation of hawk2-1.0.1+git.1447036244.df8e574-1.9.x86_64.. or Option 2: do not install hawk 1.0.0.git.1447036727.bf6a6e2-1.9.x86_64

I have not yet registered this instance to our SMT server. You think it will make a difference?

JNCService
15-Apr-2016, 22:05
Registered system and ran updates, dependency error still occurs.

smflood
18-Apr-2016, 10:45
On 15/04/16 22:14, JNCService wrote:

> Registered system and ran updates, dependency error still occurs.

From
https://www.suse.com/documentation/sle-ha-12/book_sleha/data/cha_conf_hawk2.html

--begin--
NOTE: Hawk Versions

SUSE Linux Enterprise High Availability Extension 12 SP1 ships with two
Hawk versions in parallel:

* Hawk version 1(included in RPM package: hawk).
* Hawk version 2 (included in RPM package hawk2).
---end---

Whilst I note the above says "in parallel" I suspect, particularly given
your experience, is that it's one version or the other but not both in
parallel. I'll feed this back to my contacts at SUSE.

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

JNCService
20-Apr-2016, 20:26
So after updating for real this time, I originally was not receiving the HA extension updates, this dependency error is now gone.

smflood
22-Apr-2016, 11:30
On 20/04/16 20:34, JNCService wrote:

> So after updating for real this time, I originally was not receiving the
> HA extension updates, this dependency error is now gone.

Thanks for the report back. I'm guessing SUSE fixed the hawk and/or
hawk2 packages to run in parallel.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------