PDA

View Full Version : SLES 11 SP3 Upgrade from 11SP3 to 11SP4 3 problems



gregn
22-Apr-2016, 08:15
Hi All,


zypper update -t patch
Refreshing service 'nu_novell_com'.
Loading repository data...
Reading installed packages...
Resolving package dependencies...
3 Problems:
Problem: openssh-askpass-6.2p2-0.24.1.x86_64 requires openssh = 6.2p2, but this requirement cannot be provided
Problem: hpsa-kmp-default-3.4.6-165.sles11sp3.x86_64 requires kernel(default:drivers_pci_pci-driver) = bf21952a8c267b28, but this requirement cannot be provided
Problem: hp-hpwdt-kmp-default-1.3.2_3.0.76_0.11-6.2.x86_64 requires kernel(default:drivers_pci_pci-driver) = bf21952a8c267b28, but this requirement cannot be provided

what should I do now?
1) do not install patch
2) downgrade/deinstallation
3) break dependencies

Regards
GN

smflood
22-Apr-2016, 10:42
On 22/04/16 08:24, gregn wrote:

> Code:
> --------------------
> zypper update -t patch
> Refreshing service 'nu_novell_com'.
> Loading repository data...
> Reading installed packages...
> Resolving package dependencies...
> 3 Problems:
> Problem: openssh-askpass-6.2p2-0.24.1.x86_64 requires openssh = 6.2p2, but this requirement cannot be provided
> Problem: hpsa-kmp-default-3.4.6-165.sles11sp3.x86_64 requires kernel(default:drivers_pci_pci-driver) = bf21952a8c267b28, but this requirement cannot be provided
> Problem: hp-hpwdt-kmp-default-1.3.2_3.0.76_0.11-6.2.x86_64 requires kernel(default:drivers_pci_pci-driver) = bf21952a8c267b28, but this requirement cannot be provided
> --------------------
>
>
> what should I do now?
> 1) do not install patch
> 2) downgrade/deinstallation
> 3) break dependencies

At what point in the SLES11 SP3 to SP4 upgrade process[1] are you seeing
these errors, at the beginning?

Addressing the first problem, what does "rpm -qa openssh*" report?

As for the second and third problem, is this an HP server by any chance?
If so, which model and which version of any HP Service Pack for ProLiant
(SPP) do you have installed?

HTH.

[1]
https://www.suse.com/documentation/sles11/book_sle_deployment/data/sec_update_sle11sp3.html
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

gregn
22-Apr-2016, 11:16
At what point in the SLES11 SP3 to SP4 upgrade process[1] are you seeing
these errors, at the beginning?
yes - at the very beginning.



Addressing the first problem, what does "rpm -qa openssh*" report??

rpm -qa openssh*
openssh-6.2p2-0.24.1
openssh-askpass-6.2p2-0.24.1



As for the second and third problem, is this an HP server by any chance?
If so, which model and which version of any HP Service Pack for ProLiant
(SPP) do you have installed?
YES - this is HP Server.
SLES was initially installed from hp_proliant_gen9-sle11sp3-x86_64-1.0

Regards
GN

smflood
22-Apr-2016, 11:57
On 22/04/16 11:24, gregn wrote:

> smflood;32300 Wrote:
>> Addressing the first problem, what does "rpm -qa openssh*" report??
>
> Code:
> --------------------
> rpm -qa openssh*
> openssh-6.2p2-0.24.1
> openssh-askpass-6.2p2-0.24.1
>
> --------------------

So I was expecting the openssh version to be different. However grabbing
both the patch files from download.suse.com/patch/finder I can see the
problem:

--begin--
> rpm -qp --provides Downloads/openssh-6.2p2-0.24.1.x86_64.rpm | grep
openssh
openssh = 6.2p2-0.24.1
> rpm -qp --requires Downloads/openssh-askpass-6.2p2-0.24.1.x86_64.rpm
| grep openssh
openssh = 6.2p2
---end---

The openssh package is offering openssh 6.2p2 but openssh-askpass wants
6.2p2-0.24.1.

Let me ask my SUSE contacts about this.

> smflood;32300 Wrote:
>> As for the second and third problem, is this an HP server by any chance?
>> If so, which model and which version of any HP Service Pack for ProLiant
>> (SPP) do you have installed?
> YES - this is HP Server.
> SLES was initially installed from hp_proliant_gen9-sle11sp3-x86_64-1.0

I don't have an HP server but I see at
https://drivers.suse.com/hp/HP-ProLiant-Gen9/ they reference a Bootable
Driver Kit for SLES11 SP3 hp_proliant_gen9-sle11sp3-x86_64-2.0-9 so I'm
guessing that may need to be updated.

However on the same page it says that there is no Installation Kit for
SLES11 SP4.

It's also possible you need to install a (later) HP SPP plus there seems
to be a SUSE Linux Enterprise Server 11 SP4 Supplement for HP Service
Pack for ProLiant 2015.06.0[1].

HTH.

[1]
https://ftp.hp.com/pub/softlib2/software1/doc/p1573183033/v111860/SLES11SP4Supplement-SPP2015.06.0ReleaseNotes.pdf
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

CIREX
25-Apr-2016, 10:45
Can I just "break" all this 3 dependencies and go with upgrade to SP4?

Regards
GN

gathagan
12-Aug-2016, 00:39
Was a resolution ever found for this?
I have an OES11SP3/SLES11SP4 server with the same message when I attempt to install the latest patches.
In my case, it's a Sun Sunfire X4170 server

jlobom
18-Oct-2016, 11:43
Was a resolution ever found for this?
I have an OES11SP3/SLES11SP4 server with the same message when I attempt to install the latest patches.
In my case, it's a Sun Sunfire X4170 server

Hi there:

I uninstalled all the packages with --force, and then I restared doing the upgrade with the DVD offline.

In the last upgrade window I changed the Grub location to "root from this partition".