PDA

View Full Version : SLES LTSS Upgrade from SLES11-SP1 (LTSS) to SLES11-SP2 (and further)



jmroth
10-May-2016, 16:46
Hi,

I used the official docs (https://www.suse.com/documentation/sled11/book_sle_deployment/data/sec_update_sle11sp1.html) but it doesn't work that way. I suspect the problem being LTSS repos.

On distupgrade the following happens:


# zypper dup --from SLES11-SP2-Core --from SLES11-SP2-Updates
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
3 Problems:
Problem: hp-be2iscsi-kmp-default-2.104.225.7_2.6.32.12_0.7-1.x86_64 requires kernel(default:kernecef0760c385, but this requirement cannot be provided
Problem: hp-igb-kmp-default-2.4.11_2.6.32.12_0.7-1.x86_64 requires kernel(default:drivers_dca_dc057c08, but this requirement cannot be provided
Problem: kernel-default-3.0.13-0.27.1.x86_64 requires kernel-default-base_x86_64 = 3.0.13-0.27.1irement cannot be provided

Problem: hp-be2iscsi-kmp-default-2.104.225.7_2.6.32.12_0.7-1.x86_64 requires kernel(default:kernecef0760c385, but this requirement cannot be provided
uninstallable providers: kernel-default-base-2.6.32.59-0.13.1.x86_64[SMT-http_smt:SUpdates]
kernel-default-base-2.6.32.59-0.15.2.x86_64[SMT-http_smt:SLES11-SP
kernel-default-base-2.6.32.59-0.17.1.x86_64[SMT-http_smt:SLES11-SP
kernel-default-base-2.6.32.59-0.9.1.x86_64[SMT-http_smt:SLES11-SP1
kernel-default-base-2.6.32.12-0.7.1.x86_64[SMT-http_smt:SLES11-SP1
kernel-default-base-2.6.32.13-0.4.1.x86_64[SMT-http_smt:SLES11-SP1
kernel-default-base-2.6.32.13-0.5.1.x86_64[SMT-http_smt:SLES11-SP1
kernel-default-base-2.6.32.19-0.2.1.x86_64[SMT-http_smt:SLES11-SP1
kernel-default-base-2.6.32.19-0.3.1.x86_64[SMT-http_smt:SLES11-SP1
kernel-default-base-2.6.32.23-0.3.1.x86_64[SMT-http_smt:SLES11-SP1
kernel-default-base-2.6.32.24-0.2.1.x86_64[SMT-http_smt:SLES11-SP1
kernel-default-base-2.6.32.27-0.2.2.x86_64[SMT-http_smt:SLES11-SP1
kernel-default-base-2.6.32.29-0.3.1.x86_64[SMT-http_smt:SLES11-SP1
kernel-default-base-2.6.32.36-0.5.2.x86_64[SMT-http_smt:SLES11-SP1
kernel-default-base-2.6.32.43-0.4.1.x86_64[SMT-http_smt:SLES11-SP1
kernel-default-base-2.6.32.45-0.3.2.x86_64[SMT-http_smt:SLES11-SP1
kernel-default-base-2.6.32.46-0.3.1.x86_64[SMT-http_smt:SLES11-SP1
kernel-default-base-2.6.32.49-0.3.1.x86_64[SMT-http_smt:SLES11-SP1
kernel-default-base-2.6.32.54-0.3.1.x86_64[SMT-http_smt:SLES11-SP1
kernel-default-base-2.6.32.59-0.3.1.x86_64[SMT-http_smt:SLES11-SP1
kernel-default-base-2.6.32.59-0.7.1.x86_64[SMT-http_smt:SLES11-SP1
Solution 1: Following actions will be done:
deinstallation of hp-be2iscsi-kmp-default-2.104.225.7_2.6.32.12_0.7-1.x86_64
deinstallation of hp-nx_nic-kmp-default-4.0.544_2.6.32.12_0.7-2.x86_64
deinstallation of hp-mlnx-en-kmp-default-1.5.5.7_2.6.32.12_0.7-6.x86_64
deinstallation of hp-e1000e-kmp-default-1.3.6_2.6.32.12_0.7-1.x86_64
deinstallation of hp-e1000-kmp-default-8.0.25_2.6.32.12_0.7-1.x86_64
deinstallation of hp-be2net-kmp-default-2.104.225.7_2.6.32.12_0.7-1.x86_64
Solution 2: keep obsolete kernel-default-base-2.6.32.59-0.19.1.x86_64
Solution 3: break hp-be2iscsi-kmp-default by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c):

Now, suse_register did not add any SLES11-SP2-LTSS repos, which maybe it should?
Or what else could be the problem?

Thanks,

Marki

jmroth
10-May-2016, 16:49
Forget it, those seem to be agents not even installed by SLES.

smflood
11-May-2016, 10:18
On 10/05/16 16:54, jmroth wrote:

> I used the official docs
> (https://www.suse.com/documentation/sled11/book_sle_deployment/data/sec_update_sle11sp1.html)
> but it doesn't work that way. I suspect the problem being LTSS repos.
>
> On distupgrade the following happens:
>
>
> Code:
> --------------------
> # zypper dup --from SLES11-SP2-Core --from SLES11-SP2-Updates
> Loading repository data...
> Reading installed packages...
> Computing distribution upgrade...
> 3 Problems:
> Problem: hp-be2iscsi-kmp-default-2.104.225.7_2.6.32.12_0.7-1.x86_64 requires kernel(default:kernecef0760c385, but this requirement cannot be provided
> Problem: hp-igb-kmp-default-2.4.11_2.6.32.12_0.7-1.x86_64 requires kernel(default:drivers_dca_dc057c08, but this requirement cannot be provided
> Problem: kernel-default-3.0.13-0.27.1.x86_64 requires kernel-default-base_x86_64 = 3.0.13-0.27.1irement cannot be provided
>
> Problem: hp-be2iscsi-kmp-default-2.104.225.7_2.6.32.12_0.7-1.x86_64 requires kernel(default:kernecef0760c385, but this requirement cannot be provided
> uninstallable providers: kernel-default-base-2.6.32.59-0.13.1.x86_64[SMT-http_smt:SUpdates]
> kernel-default-base-2.6.32.59-0.15.2.x86_64[SMT-http_smt:SLES11-SP
> kernel-default-base-2.6.32.59-0.17.1.x86_64[SMT-http_smt:SLES11-SP
> kernel-default-base-2.6.32.59-0.9.1.x86_64[SMT-http_smt:SLES11-SP1
> kernel-default-base-2.6.32.12-0.7.1.x86_64[SMT-http_smt:SLES11-SP1
> kernel-default-base-2.6.32.13-0.4.1.x86_64[SMT-http_smt:SLES11-SP1
> kernel-default-base-2.6.32.13-0.5.1.x86_64[SMT-http_smt:SLES11-SP1
> kernel-default-base-2.6.32.19-0.2.1.x86_64[SMT-http_smt:SLES11-SP1
> kernel-default-base-2.6.32.19-0.3.1.x86_64[SMT-http_smt:SLES11-SP1
> kernel-default-base-2.6.32.23-0.3.1.x86_64[SMT-http_smt:SLES11-SP1
> kernel-default-base-2.6.32.24-0.2.1.x86_64[SMT-http_smt:SLES11-SP1
> kernel-default-base-2.6.32.27-0.2.2.x86_64[SMT-http_smt:SLES11-SP1
> kernel-default-base-2.6.32.29-0.3.1.x86_64[SMT-http_smt:SLES11-SP1
> kernel-default-base-2.6.32.36-0.5.2.x86_64[SMT-http_smt:SLES11-SP1
> kernel-default-base-2.6.32.43-0.4.1.x86_64[SMT-http_smt:SLES11-SP1
> kernel-default-base-2.6.32.45-0.3.2.x86_64[SMT-http_smt:SLES11-SP1
> kernel-default-base-2.6.32.46-0.3.1.x86_64[SMT-http_smt:SLES11-SP1
> kernel-default-base-2.6.32.49-0.3.1.x86_64[SMT-http_smt:SLES11-SP1
> kernel-default-base-2.6.32.54-0.3.1.x86_64[SMT-http_smt:SLES11-SP1
> kernel-default-base-2.6.32.59-0.3.1.x86_64[SMT-http_smt:SLES11-SP1
> kernel-default-base-2.6.32.59-0.7.1.x86_64[SMT-http_smt:SLES11-SP1
> Solution 1: Following actions will be done:
> deinstallation of hp-be2iscsi-kmp-default-2.104.225.7_2.6.32.12_0.7-1.x86_64
> deinstallation of hp-nx_nic-kmp-default-4.0.544_2.6.32.12_0.7-2.x86_64
> deinstallation of hp-mlnx-en-kmp-default-1.5.5.7_2.6.32.12_0.7-6.x86_64
> deinstallation of hp-e1000e-kmp-default-1.3.6_2.6.32.12_0.7-1.x86_64
> deinstallation of hp-e1000-kmp-default-8.0.25_2.6.32.12_0.7-1.x86_64
> deinstallation of hp-be2net-kmp-default-2.104.225.7_2.6.32.12_0.7-1.x86_64
> Solution 2: keep obsolete kernel-default-base-2.6.32.59-0.19.1.x86_64
> Solution 3: break hp-be2iscsi-kmp-default by ignoring some of its dependencies
>
> Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c):
> --------------------
>
>
> Now, suse_register did not add any SLES11-SP2-LTSS repos, which maybe it
> should?
> Or what else could be the problem?

Whilst you've replied having realised the hp-* packages are not
installed by SLES (I'm guessing you have an HP ProLiant server with it's
support pack installed?) I just wanted to follow up about the LTSS repos
- provided you're using an LTSS activation code suse_register should add
the appropriate LTSS repos. Please see TID 7011670[1] for more
information and procedure.

HTH.

[1] https://www.suse.com/support/kb/doc.php?id=7011670
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------