PDA

View Full Version : SLES 12 SP1 Using an NFS Version 2 client with SLES 12 isn't working



kedlm
24-May-2016, 17:37
We are upgrading our old SLES and openSUSE boxes to SLES 12 SP1. Some of our old robot NFS clients are having problems with NFS because they use Version 2.

I figured out how to enable NVS Version 2 in /etc/sysconfig/nfs:
NFSD_OPTIONS="-V2"
MOUNTD_OPTIONS="-V2"
(and reboot just to be safe)

When I use a remote SLES box as the client and try to force NFS Ver 2 it appears to work fine.

But when I use our robot client (Adept V+ OS), I can mount the share from the client. But any ls or cat fail.

A trace in ethereal shows I get an error 13 from nfsd. But nothing useful shows up on the client or in the SLES 12 server /var/log/messages.

To get more debugging, I have run:
nfsd sock fh export svc proc fileop auth repcache xdr lockd

Here is all I get in the SLES 12 server /var/log/messages when I run ls on the ancient Adept client:
2016-05-24T12:22:00.623575-04:00 disslavetest kernel: [ 8034.588108] nfsd_dispatch: vers 2 proc 16
2016-05-24T12:22:00.623593-04:00 disslavetest kernel: [ 8034.588116] nfsd: READDIR 32: 00040001 035e05d4 955d8916 00000000 00000000 00000000 1394 bytes at 0
2016-05-24T12:22:00.623597-04:00 disslavetest kernel: [ 8034.588121] nfsd: fh_verify(32: 00040001 035e05d4 955d8916 00000000 00000000 00000000)
2016-05-24T12:22:00.623604-04:00 disslavetest kernel: [ 8034.588135] nfsd: fh_verify(32: 00040001 035e05d4 955d8916 00000000 00000000 00000000)

There are no updates to the Adept client and very little in the way of options.

I'm not sure how to proceed with troubleshooting and fixing the problem. The same client still works an old openSUSE server but that server is about to get upgraded.

I am currently dprintking my way thru the server module source code trying to figure what it doesn't like. But that is pretty slow as I can't get nfsd.ko to unload and have to reboot every time I recompile. Does anyone have any other ideas?

kedlm
24-May-2016, 21:22
Google finally came thru after I asked the right question.
Setting sec=none in /etc/exports for these machines fixed the problem.

jmozdzen
30-May-2016, 11:25
Hi kedlm,

while we were not able to offer help in those 4 hours between asking and answering your own question ;) , I want to thank you for taking the time to come back and provide your solution for further reference. A great start to your participation here!

Best regards,
Jens