PDA

View Full Version : SLES 11 SP3 OpenSSL security updates for SLES 11.3



chandanmedhi
30-May-2016, 17:29
Hello Folks,

Could you please guide me, what should be my OpenSSl security updates and how to download this ? Because I am facing issue in my SLES 11 SP 3 with openssl Version running

Version : 0.9.8j Vendor: SUSE LINUX Products GmbH, Nuernberg, Germany
Release : 0.50.1 Build Date: Mon Mar 25 11:10:09 2013

Do I need to upgrade my openssl version here and patch ?

Or else I can patch on my current existing openssl version.

One more problem is that, I have no registered zypper repo installed.

What should be my approach here ?

Advice please.

Regards

Chandan.M

malcolmlewis
30-May-2016, 17:49
Hi
So you don't have a current license to receive updates?

Have a look here for ones that are public?
https://download.suse.com/patch/finder/#bu=suse&familyId=7261&productId=42045&dateRange=&startDate=&endDate=&priority=&architecture=&keywords=ssl&xf=7261&xp=7261_42045

Upgrade the system to SLES 11 SP4, grab an evaluation code, but why not register the system proper and receive updates and support?

chandanmedhi
30-May-2016, 18:15
Thanks for the reply. Much appreciated.

These are some of our legacy systems which need to be upgraded to higher version. Does it required to upgrade to SP4 to patch that ?

Also I am trying to download, but patch is restricted. Is this because of the registration or access not permitted ?

Restriction status: Restricted

Regards

Chandan.M

malcolmlewis
30-May-2016, 19:28
Thanks for the reply. Much appreciated.

These are some of our legacy systems which need to be upgraded to higher version. Does it required to upgrade to SP4 to patch that ?

Also I am trying to download, but patch is restricted. Is this because of the registration or access not permitted ?

Restriction status: Restricted

Regards

Chandan.M
Hi
Yes, you need an active subscription to download the updates etc, some are public, but suggest upgrade to SP4 for the latest updates, if you grab the SLES 11 SP4 DVD1, there should be an option for an evaluation code which should be good for a few months for access to updates.

https://download.suse.com/Download?buildid=tqRrEpjl5SY~

smflood
02-Jun-2016, 22:30
chandanmedhi Wrote in message:

> Could you please guide me, what should be my OpenSSl security updates
> and how to download this ? Because I am facing issue in my SLES 11 SP 3
> with openssl Version running
>
> Version : 0.9.8j Vendor: SUSE LINUX Products
> GmbH, Nuernberg, Germany
> Release : 0.50.1 Build Date: Mon Mar 25
> 11:10:09 2013
>
> Do I need to upgrade my openssl version here and patch ?
>
> Or else I can patch on my current existing openssl version.
>
> One more problem is that, I have no registered zypper repo installed.
>
> What should be my approach here ?
>
> Advice please.

Firstly if you are concerned about security then you should
upgrade your server to SLES11 SP4 and keep it updated - your
replies to Malcolm suggest you don't currently have access to
patches through a subscription.

There is the possibility of installing OpenSSL 1.0.1 on SLES11 SP3
and SP4 (included out of the box with SLES12) via an additional
security module if you have a subscription - please see
https://www.suse.com/communities/blog/introduci
ng-the-suse-linux-enterprise-11-security-module/ (URL may not
wrap).

HTH.
--
Simon Flood
SUSE Knowledge Partner


----Android NewsGroup Reader----
http://usenet.sinaapp.com/