View Full Version : help installing BCM4313 WLAN - SLED 11 SP2 x864

18-Mar-2012, 09:08
kernel version

as per lspci

02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)

I download the driver from www.broadcom.com/docs/linux_sta/hybrid-portsrc_x86_64-v5_100_82_112.tar.gz , and install it via

make clean
cp wl.ko /lib/modules/3.0.13-0.27-default/kernel/net/wireless/
depmod -a
modprobe lib80211
modprobe wl

everything went smooth


# modinfo wl
filename: /lib/modules/3.0.13-0.27-default/kernel/net/wireless/wl.ko
srcversion: 15AE62EF0C155763C426A57
alias: pci:v000014E4d00000576sv*sd*bc*sc*i*
alias: pci:v000014E4d0000435Asv*sd*bc*sc*i*
alias: pci:v000014E4d00004359sv*sd*bc*sc*i*
alias: pci:v000014E4d00004358sv*sd*bc*sc*i*
alias: pci:v000014E4d00004727sv*sd*bc*sc*i*
alias: pci:v000014E4d00004357sv*sd*bc*sc*i*
alias: pci:v000014E4d0000A99Dsv*sd*bc*sc*i*
alias: pci:v000014E4d00004353sv*sd*bc*sc*i*
alias: pci:v000014E4d0000432Dsv*sd*bc*sc*i*
alias: pci:v000014E4d0000432Csv*sd*bc*sc*i*
alias: pci:v000014E4d0000432Bsv*sd*bc*sc*i*
alias: pci:v000014E4d0000432Asv*sd*bc*sc*i*
alias: pci:v000014E4d00004329sv*sd*bc*sc*i*
alias: pci:v000014E4d00004328sv*sd*bc*sc*i*
alias: pci:v000014E4d00004315sv*sd*bc*sc*i*
alias: pci:v000014E4d00004313sv*sd*bc*sc*i*
alias: pci:v000014E4d00004312sv*sd*bc*sc*i*
alias: pci:v000014E4d00004311sv*sd*bc*sc*i*
depends: lib80211
vermagic: 3.0.13-0.27-default SMP mod_unload modversions
parm: oneonly:int
parm: piomode:int
parm: instance_base:int
parm: nompc:int
parm: name:string

but still I don't find the wireless card when I run the "yast2 lan"

I installed the same driver using the above step atop SLED 11 SP1 x86 and it worked i.e wireless lan card available in "yast2 lan" . But this time I installed the driver on SLED 11 SP2 x864.

Muhammad Sharfuddin

Automatic reply
22-Mar-2012, 13:30

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team