PDA

View Full Version : Multiple network cards and bridges in Xen with SLES11 SP2???



ingematica
19-Mar-2012, 17:42
How to --> Multiple network cards and bridges in Xen with XEN 4.1 in SLES 11 SP2 ?????

Harware: Hp Proliant DL 380 G7
KERNEL: Linux ********* 3.0.13-0.27-xen #1 SMP Wed Feb 15 13:33:49 UTC 2012 (d73692b) x86_64 x86_64 x86_64 GNU/Linux
Xen 4.1.2_14-0.5.5

With previous distributions is created as follows:

Create custom network-script which works as a wrapper and calls network-bridge from it.
/etc/xen/scripts/my-network-bridge:
#!/bin/sh
dir=$(dirname "$0")
"$dir/network-bridge" "$@" vifnum=1 netdev=eth1 bridge=xenbr1
"$dir/network-bridge" "$@" vifnum=2 netdev=eth2 bridge=xenbr2
"$dir/network-bridge" "$@" vifnum=3 netdev=eth3 bridge=xenbr3
ifconfig xenbr1 up
ifconfig xenbr2 up
ifconfig xenbr3 up


Add execute-permissions:
# chmod u+x /etc/xen/scripts/my-network-bridge
Edit Xens config:
/etc/xen/xend-config.sxp:

#(network-script network-bridge)
(network-script my-network-bridge)

But with SLES 11 SP2 does not work, How to??

Thanks

jmozdzen
19-Mar-2012, 18:51
ingematica,

iirc you're supposed to set up NIFs & bridges with the base OS mechanisms - you basically create 'em like you would if you had no Xen at all, using yast or by manually creating the required config files in /etc/sysconfig/network.

I can't recall if this was true for SLES11SP1 already - I've been doing it that way since SLES10SP2 :D

Regards,
Jens

unixgrp
15-May-2012, 09:31
We run into the same problem.
It seems to me SLES11 SP2 is very buggy !

The problem is inside the xen script:
/etc/xen/scripts/network-bridge

You have to comment out the lines 241 to 243

# if [ `brclt show | wc -l != 1 ]; then
# return
# fi

The script will only activate the first bridge (when no bridge is active and the brctl command only shows the header line)

regards

Rainer




How to --> Multiple network cards and bridges in Xen with XEN 4.1 in SLES 11 SP2 ?????

Harware: Hp Proliant DL 380 G7
KERNEL: Linux ********* 3.0.13-0.27-xen #1 SMP Wed Feb 15 13:33:49 UTC 2012 (d73692b) x86_64 x86_64 x86_64 GNU/Linux
Xen 4.1.2_14-0.5.5

With previous distributions is created as follows:

Create custom network-script which works as a wrapper and calls network-bridge from it.
/etc/xen/scripts/my-network-bridge:
#!/bin/sh
dir=$(dirname "$0")
"$dir/network-bridge" "$@" vifnum=1 netdev=eth1 bridge=xenbr1
"$dir/network-bridge" "$@" vifnum=2 netdev=eth2 bridge=xenbr2
"$dir/network-bridge" "$@" vifnum=3 netdev=eth3 bridge=xenbr3
ifconfig xenbr1 up
ifconfig xenbr2 up
ifconfig xenbr3 up


Add execute-permissions:
# chmod u+x /etc/xen/scripts/my-network-bridge
Edit Xens config:
/etc/xen/xend-config.sxp:

#(network-script network-bridge)
(network-script my-network-bridge)

But with SLES 11 SP2 does not work, How to??

Thanks

enovaklbank
16-May-2012, 14:30
Forget the scripts like /etc/xen/scripts/network-bridge . jmozdzen is right, they are obsolote since 2007 at least.
SLES10 GA and maybe SP1 used them, but since SP2 everybody is told to use yast and other OS tools (iputils etc).