PDA

View Full Version : Nautilus fuse mount points



Günther Schwarz
28-Nov-2011, 11:42
Where does Nautilus on SLED10 or SLED11 mount a network file system such
as a SMB share? With Debian-based distributions I'm used to have a look
at ~/.gvfs, but this directory is not present with SLED.

Günther

mikewillis
28-Nov-2011, 12:36
Günther Schwarz;2156613 Wrote:
> Where does Nautilus on SLED10 or SLED11 mount a network file system
> such
> as a SMB share? With Debian-based distributions I'm used to have a
> look
> at ~/.gvfs, but this directory is not present with SLED.
>

Such mounts should be under ~/.gvfs. They will not show up if
gvfs-fuse-daemon is not running. If running, gvfs-fuse-daemon process is
owned by the user that's logged in so you can check if it's running
with

Code:
--------------------
$ ps U $USER | grep gvfs-fuse-daemon
--------------------

If it is running there should be something in the output of mount like
this:

Code:
--------------------
mike@localhost:~> mount |grep gvfs
gvfs-fuse-daemon on /home/mike/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=mike)
--------------------


If gvfs-fuse-daemon is not running try starting it manually.

Code:
--------------------
$ /usr/lib/gvfs/gvfs-fuse-daemon
--------------------



One thing to note is that I have found gvfs-fuse-daemon does not work
on machines where I have an NFS mounted home directory. Trying to start
gvfs-fuse-daemon results in

Code:
--------------------

me@mine:~> /usr/lib/gvfs/gvfs-fuse-daemon
fuse: missing mountpoint
--------------------

My understanding is that this is expected behaviour. The NFS server has
root squash enabled (as it should) and for gvfs-fuse-daemon to work root
needs to be able to access the user's home directory.


--
mikewillis
------------------------------------------------------------------------
mikewillis's Profile: http://forums.novell.com/member.php?userid=7510
View this thread: http://forums.novell.com/showthread.php?t=448774

Günther Schwarz
30-Nov-2011, 17:18
Am 28.11.2011 12:36, schrieb mikewillis:
>
> G�nther Schwarz;2156613 Wrote:
>> Where does Nautilus on SLED10 or SLED11 mount a network file system
>> such
>> as a SMB share? With Debian-based distributions I'm used to have a
>> look
>> at ~/.gvfs, but this directory is not present with SLED.
>>
>
> Such mounts should be under ~/.gvfs. They will not show up if
> gvfs-fuse-daemon is not running. If running, gvfs-fuse-daemon process is
> owned by the user that's logged in so you can check if it's running
> with

OK, I'm still puzzled.

:~> uname -a
Linux test 2.6.16.60-0.81.2-default #1 Thu Jun 30 09:20:04 UTC 2011 i686
i686 i386 GNU/Linux
Nautilus 2.12.2

> Code:
> --------------------
> $ ps U $USER | grep gvfs-fuse-daemon
> --------------------

:~> ps -ef | grep gv
ben2 24186 7290 0 17:14 pts/1 00:00:00 grep gv

> If it is running there should be something in the output of mount like
> this:
>
> Code:
> --------------------
> mike@localhost:~> mount |grep gvfs
> gvfs-fuse-daemon on /home/mike/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=mike)
> --------------------

:~> mount | grep gvfs
:~>

> If gvfs-fuse-daemon is not running try starting it manually.
>
> Code:
> --------------------
> $ /usr/lib/gvfs/gvfs-fuse-daemon
> --------------------

:~> find /usr/ -name gvfs*
:~>

So the system seems to be old enough to do this entirely different. The
samba share is accessible within Nautilus.
I will try again with SLED11.

> One thing to note is that I have found gvfs-fuse-daemon does not work
> on machines where I have an NFS mounted home directory. Trying to start
> gvfs-fuse-daemon results in
>
> Code:
> --------------------
>
> me@mine:~> /usr/lib/gvfs/gvfs-fuse-daemon
> fuse: missing mountpoint
> --------------------
>
> My understanding is that this is expected behaviour. The NFS server has
> root squash enabled (as it should) and for gvfs-fuse-daemon to work root
> needs to be able to access the user's home directory.

Broken by design. This reminds me of Novell Casa which wants to write to
/home/.casa. Not so easy to do with NFS base home directories.

Thank you very much indeed for the detailed explanation.

Günther

mikewillis
09-Jan-2012, 10:56
This thread made me look at this again and I found a solution


Code:
--------------------
$ ls -l /etc/X11/xinit/xinitrc.d/move_gvfs_dir
-rwxr-xr-x 1 root root 648 2011-12-20 11:09 /etc/X11/xinit/xinitrc.d/move_gvfs_dir
$ cat /etc/X11/xinit/xinitrc.d/move_gvfs_dir
#!/bin/bash

# gvfs-fuse-daemon won't work if ~/.gvfs isn't writable by root
# when home dir is on nfs server ~/.gvfs isn't writable by root (unless the nfs
# server is badly set up)
# making ~/.gvfs a symbolic link to somewhere on the local harddisk works
# around that so gvfs-fuse-daemon is able to run even when home is on nfs
# and contents of gvfs mounts are accessible under ~/.gvfs as they are with
# non nfs home dirs. which is nice if you want to get at them via command line
# there's some discussion at
# https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/435719

rmdir ~/.gvfs 2>/dev/null || rm ~/.gvfs

ln -s "$(mktemp -d)" ~/.gvfs
--------------------

I've had it in place a few weeks now, seems to work as desired.


--
mikewillis
------------------------------------------------------------------------
mikewillis's Profile: http://forums.novell.com/member.php?userid=7510
View this thread: http://forums.novell.com/showthread.php?t=448774