PDA

View Full Version : wifi problem



mmaher
29-Aug-2016, 08:49
hi all ,
I am a new opensuse enterprise desktop 12 sp1 user after installation on my dell latitude I found that there is no wifi connection (no wifi setting ) my card is dell wireless 1397 mini-card with a Broadcom chipset BCM 4312 802.11b/g LP-PHY , it looks like as there is no wifi card while during installation by opening hardware recognize it found the card normally with driver b43-pci-bridge ,,,, Hint (my Ethernet port is not working so I have no access to the internet)
can any one help me !!

mmaher
29-Aug-2016, 09:10
http://tinypic.com/r/34sky86/9

malcolmlewis
29-Aug-2016, 13:26
On Mon 29 Aug 2016 07:54:01 AM CDT, mmaher wrote:

hi all ,
I am a new opensuse enterprise desktop 12 sp1 user after installation
on my dell latitude I found that there is no wifi connection (no wifi
setting ) my card is dell wireless 1397 mini-card with a Broadcom
chipset BCM 4312 802.11b/g LP-PHY , it looks like as there is no wifi
card while during installation by opening hardware recognize it found
the card normally with driver b43-pci-bridge ,,,, Hint (my Ethernet port
is not working so I have no access to the internet)
can any one help me !!




Hi
So did you check if the kernel-firmware package is installed?

If you check the output from the journal;


zypper in kernel-firmware
journalctl -b --no-pager |grep firm


It does sound like you might need to install manually, see;
https://forums.opensuse.org/showthread.php/484106-Broadcom-firmware-is-needed-for-b43-but-I-have-no-network-an-easierwork-around

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.27-27-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!