PDA

View Full Version : missing php packages on SLES



meikestone
21-Mar-2012, 09:23
Hello,

I missing following php packages on the SLES11SP2:
- php53-sockets
- php53-phar
- php53-posix

Why they are not included in the Distribution? Where can I get them.

On the Repository http://download.opensuse.org/repositories/server:/php/SLE_11/ 'I can find them, but php5.3.10.

Thanks Meike

Automatic reply
29-Mar-2012, 13:30
meikestone,

It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

Has your issue been resolved? If not, you might try one of the following options:

- Visit http://www.suse.com/support and search the knowledgebase and/or check all
the other support options available.
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.suse.com)

Be sure to read the forum FAQ about what to expect in the way of responses:
http://forums.suse.com/faq.php

If this is a reply to a duplicate posting, please ignore and accept our apologies
and rest assured we will issue a stern reprimand to our posting bot.

Good luck!

Your SUSE Forums Team
http://forums.suse.com

malcolmlewis
29-Mar-2012, 15:37
Hello,

I missing following php packages on the SLES11SP2:
- php53-sockets
- php53-phar
- php53-posix

Why they are not included in the Distribution? Where can I get them.

On the Repository
http://download.opensuse.org/repositories/server:/php/SLE_11/ 'I can
find them, but php5.3.10.

Thanks Meike



Hi
I'm not a php user, but I wonder if they may be compiled in to the core
php53?

--
Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.13-0.27-default
up 15:24, 3 users, load average: 0.00, 0.03, 0.05
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

enovaklbank
30-Mar-2012, 11:30
They're really not in the repos.

If you compare the spec file from the php5 src.rpm with the one from php53, they're pretty much the same. That means, the spec files contain -sockets and -posix packages' description.

But in the SDK for SP2, there are no php53 packages at all, while the php5 ones are there.

Only idea I have is to install the src rpms (zypper si php53) and rebuild the packages (rpmbuild -bb php53.spec). Of course this is not supported...

ab
30-Mar-2012, 17:39
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Bug# 752660, "php53-devel and php53-posix missing"

Comment #10 says the following package are being added to the SDK
(presumably via a channel) pending QA approval:

php53-devel
php53-imap
php53-posix
php53-readline
php53-sockets
php53-tidy

php53-phar was not there in previous SDKs as far as I can tell and the
bug is continuing with deciding whether or not it should be added. Just
FYI.

Good luck.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.18 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJPdeHUAAoJEF+XTK08PnB5vDoP/0n+3iRFl5Dla76fmC4/rdVz
bsqBqDCbo6Y/zdrNt/1UTmMuq2ddZY+YnA80C/f26yGxlEITemvqBun/Hjj1OKam
jpqBGDg3GY/XuXTv1uQaDTaaLGPezvMGE02T8FCXx8D5SUy333OKyQkQUpPR2 smY
ChMcTzkXg6bV7foB8M9XE8sJHz5VWrDA8iMMyLzOPqKnYa2epu p8AH/KFhw67IWk
qkPEqo5bMw4ZuGjBDtGrIDoSIB3lKV4kMnbOPhoindYcRRtMah lsWHxISH1v8Gsu
qlMbM67wN43agKgudMl6jfKFo+wCrzygfHducqBeWwqBAEYl+K MhUvbxZpezyDi6
EA5RFSFpg5KEDN7bIsT43zssG74fdW2D8MApro4yAFhroarJb6 dQ20ZpXicPVBeG
THqxlVeMYYR5qMtEpcMUkgvRTM6HcTfjBvgaYLn5ka0vMjRtTp 1q4PoKL+sECn8p
IQyUKT2ptrk9sInYUPU7Otdqy1jPsUb1QQg7gSriQxhIougH1g xh+MZVwUsgtgS0
ZflKc5w8kpaDIQQta59Yn+pcJEcGcUBxVswd5eFBp+Un4d9PiK ChPFC1Aflgpukk
G8bK5i1VxPGHOmUk1U4J07GcjnP72GFKZT78HuM7ZBWYWtM3z2 wT1T0j0qjZ+WPI
g4MvpqbxuId7u7+WdbRL
=hRUA
-----END PGP SIGNATURE-----