PDA

View Full Version : Looking for libreadline6 for SLED 11 SP3



ERICDAVANTURE
31-Oct-2016, 19:24
Greetings,

I run SLED 11 SP3 factory preload on my HP ZBook 17 G1 laptop and want / need to connect a PROXMARK3 RFID reader. The client software of the PROXMARK3 RFID reader requires libreadline6 package and I can only find libreadline5 package in the list of available packages for my SLED 11 SP3. Knowing that I can't upgrade to SLED 12 on my HP ZBook 17 G1 since it is not supported by HP, how can I install libreadline6 package on my SLED 11 SP3 ?

Thanks a lot for your precious help and time.

Eric J.P.E. DAVANTURE - Eric.DAVANTURE@orange.fr

ofvergara
31-Oct-2016, 20:44
have you tried this from pbone (http://rpm.pbone.net/index.php3?stat=3&limit=2&srodzaj=1&dl=40&search=libreadline6&dist[]=80&dist[]=46&dist[]=67&field[]=1&field[]=2)?

try to download & install this version for sled11sp2. it might help.
however, before installing, be very careful and validate dependencies first.

hope this helps.

malcolmlewis
01-Nov-2016, 03:08
Hi
There is a SP3 version available from OBS in the shells repo;
http://download.opensuse.org/repositories/shells/SLE_11_SP3/x86_64/

Unsupported of course, you would need to add the repository to pull in any dependencies.

FYI, the search on OBS is here: https://software.opensuse.org/search?

ERICDAVANTURE
01-Nov-2016, 19:16
Greetings Malcom,

Thanks a lot for your answer. This is much appreciated.
I did download http://download.opensuse.org/repositories/shells/SLE_11_SP3/x86_64/libreadline6-6.3-301.1.x86_64.rpm for SLE 11 SP3 64-bit and installed it as root by running zypper install libreadline6-6.3-301.1.x86_64.rpm and everything went fine.
Unfortunately, when running PROXMARK3 Client software again, it now complains that /lib64/libc.so.6 version 'GLIBC_2.15" is missing so I guess it will be a never-ending story and that I will only get at the end some unstable operating system due to the unsupported upgrades, right ?

I really do not know what to do in order to get the PROXMARK3 supported by my laptop with SLED 11 SP3 so far.

E.D.

malcolmlewis
01-Nov-2016, 21:56
On Tue 01 Nov 2016 06:24:02 PM CDT, ERICDAVANTURE wrote:

Greetings Malcom,

Thanks a lot for your answer. This is much appreciated.
I did download
http://download.opensuse.org/repositories/shells/SLE_11_SP3/x86_64/libreadline6-6.3-301.1.x86_64.rpm
for SLE 11 SP3 64-bit and installed it as root by running zypper install
libreadline6-6.3-301.1.x86_64.rpm and everything went fine.
Unfortunately, when running PROXMARK3 Client software again, it now
complains that /lib64/libc.so.6 version 'GLIBC_2.15" is missing so I
guess it will be a never-ending story and that I will only get at the
end some unstable operating system due to the unsupported upgrades,
right ?

I really do not know what to do in order to get the PROXMARK3 supported
by my laptop with SLED 11 SP3 so far.

E.D.




Hi
Compile from source?
https://github.com/Proxmark/proxmark3

--
Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.34-33-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below... Thanks!