PDA

View Full Version : HANA SPS 8 - supported SUSE versions



wlourens
03-Nov-2016, 12:42
Hi

I would like to request a upgrade the OS version of our HANA server.

Currently, HANA version is 1.00.82.00.394270. SUSE version is "SUSE Linux Enterprise Server 11 (x86_64), VERSION 11, PATCHLEVEL 2.

Can someone please confirm that HANA SPS 8 will be supported by SUSE 12? I can see that the latest HANA versions is compatible, but need to confirm the SPS 8 version.

We will be upgrading the database AFTER upgrade of the OS.

Best Regards
Willem

ab
03-Nov-2016, 15:30
You probably need to ask SAP where their software will be supported, as
they are going to be the final say on where they will support their stuff.
Will it work? Probably. Is it supported? Hard to say, particularly
since systemd is a big change and older versions of SAP's software may not
not have service unit files specifically for systemd, so that may be an
issue, not to mention testing that may not have been done with older
software on newer platforms.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below...

smflood
03-Nov-2016, 16:24
On 03/11/16 11:44, wlourens wrote:

> I would like to request a upgrade the OS version of our HANA server.
>
> Currently, HANA version is 1.00.82.00.394270. SUSE version is "SUSE
> Linux Enterprise Server 11 (x86_64), VERSION 11, PATCHLEVEL 2.

So this suggests SLES11 SP2 which is now out of support (and probably
the reason for upgrading your server?) but is it the SAP Applications
release? Please can you provide the output from "cat /etc/*release".

This will also tell us the architecture that's involved.

> Can someone please confirm that HANA SPS 8 will be supported by SUSE 12?
> I can see that the latest HANA versions is compatible, but need to
> confirm the SPS 8 version.

Given that SPS08 appears to have been released in May 2014 before SLES12
in October 2014 I would expect not, especially if you're using "regular"
SLES and not SLES for SAP Applications (which tends to be released after
"regular" SLES).

> We will be upgrading the database AFTER upgrade of the OS.

Unfortunately SAP are very protective of their support content so you
will either need a log in allowing you access or will need to contact them.

My guess is you will to upgrade from SPS08 to something that is
supported on SLES12 (note SP1 is current), possibly via intermediate SPS
releases, then upgrade the SLES OS. A complication is that you can't
upgrade directly from SLES11 SP2 to SLES12 SP1 but will first have to
upgrade to SLES11 SP3.

HTH.
--
Simon
SUSE Knowledge Partner

------------------------------------------------------------------------
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below. Thanks.
------------------------------------------------------------------------

wlourens
04-Nov-2016, 17:05
Hi Simon

Thanks for the response.

"cat /etc/*release" output is:

cat SuSE-release
SUSE Linux Enterprise Server 11 (x86_64)
VERSION = 11
PATCHLEVEL = 2

And I did get a note saying HANA SP8 is not supported on SLES12. So we will need to upgrade the database 1st to SPS 10, as SPS 12 is not supported on SLES11.2. Then we can upgrade the OS to SLES11.4.

Best Regards
Willem