PDA

View Full Version : SLES 11 SP4 Keyboard and language issue



mayuriroy01
09-Nov-2016, 08:18
Hello,

I am facing a very strange issue. I have a Brazilian(Portuguese) Keyboard ABNT2 . When I am connecting to my terminal which Xen desktop environment installed with Suse 11.4 and typing '/' in the Gnome terminal, it is not printing. However I have checked my key '/' and is working fine outside of the terminal. Other keys are working fine on the terminal. Other keyboard model is working fine.

Every time I am using xmodmap command to esacpe out from this issue.

Can you please suggest me the cause and solution for this issue?

jmozdzen
11-Nov-2016, 11:02
Hi,

with "Other keyboard model is working fine", do you mean that other hardware (but with same layout) works fine, or that a different keyboard layout (probably with the same keyboard hardware, or some other hardware) is working fine?

Are you using a MS Windows client system, connecting to a Xen-based SLES 11 SP4 instance? Or is your client a Linux system as well?

Such problems typically are caused by mismatching keyboard layouts between client OS / client software / DomU keyboard setting / DomU-OS keyboard setting, though other causes may be possible, too.

Regards,
J

mayuriroy01
25-Nov-2016, 09:23
Hello J,

Thanks for your response.

Yes I am using Windows and ABNT2 (portuguese/Brazil) set on my notebook, by default in /etc/sysconfig/keyboard , KEYTABLE="us.map.gz"
YAST_KEYBOARD="english-us,pc104" are set. Even Any combinations of keyboard is also not working.

Vendor of the keyboard is HP.

BR
Mayuri





Hi,

with "Other keyboard model is working fine", do you mean that other hardware (but with same layout) works fine, or that a different keyboard layout (probably with the same keyboard hardware, or some other hardware) is working fine?

Are you using a MS Windows client system, connecting to a Xen-based SLES 11 SP4 instance? Or is your client a Linux system as well?

Such problems typically are caused by mismatching keyboard layouts between client OS / client software / DomU keyboard setting / DomU-OS keyboard setting, though other causes may be possible, too.

Regards,
J

jmozdzen
30-Nov-2016, 18:30
Hi Mayuri,

sorry for not responding earlier - I somehow missed your reply :-[

It sounds strange that you're using US keyboard definitions for a portuguese/Brazil keyboard, but as I have no experiences with that specific layout, it my simply be a lack of knowledge on my side.

I couldn't see what Windows client software you're using to access the Linux host (there are multiple ways to connect to Xen VMs). I'd personally start by trying to get the layout consistent across the complete chain of software involved. From experience with various clients for Xen-based VMs, I can tell that setting the proper keyboard information on the client application is an important piece of the puzzle.

Regards,
J