PDA

View Full Version : First boot - "HDMI / DVI out of range"



suse_rasputin
10-Nov-2016, 10:53
Hi!

Downloaded the image and burned it to SD-card, started first boot with monitor (LG W2442PA-SF) and keyboard attached. See Grub screen, efi stub, subsequently some Dmesg stuff, ending with "switching root", then screen turns black and after a few seconds the screen throws an error:


HDMI out of range 35,7 kHz / 32 Hz

or


DVI out of range 35.2 kHz / 32 Hz

depending on which cabel (HDMI-HDMI or HDMI-DVI) I use.

Had this error in the past with other monitors and upstream opensuse ARM, could never resolve it, but with opensuse I could log in via ssh, set up VNC server and use the Raspi headless, as usual. As SLES wants to go through the usual setup (time zone, passwords), I can't access ssh here.

So actually the install is dead after first boot.

Any way around that?

Kind regards

raspu

jayk
10-Nov-2016, 13:50
Are you connecting directly to the monitor or are you using a KVM switch? I've seen that type of issue with earlier SLES releases when using a KVM switch.

suse_rasputin
10-Nov-2016, 14:31
Hi!

No KVM, simply cable. Cable(s) checked, even other monitor checked... The only aarch64 suse I can get working here on Raspi 3 is that by Stefan Brüns

http://download.opensuse.org/repositories/home:/StefanBruens:/branches:/devel:/ARM:/Factory:/Contrib:/RaspberryPi3/images/

I use the one with XFCE, working fine! The other aarch64 images of openSUSE gave me the same error in the past.

suse_rasputin
10-Nov-2016, 15:20
PS: However, the monitor has a built-in switch for the VGA/HDMI/DVI input! Might it be related to this?

suse_rasputin
10-Nov-2016, 15:23
PPS: I tried the XFCE aarch64 openSUSE again

http://download.opensuse.org/repositories/devel:/ARM:/Factory:/Contrib:/RaspberryPi3/images/

...same error, HDMI out of range.

algraf
11-Nov-2016, 14:02
PPS: I tried the XFCE aarch64 openSUSE again

http://download.opensuse.org/repositories/devel:/ARM:/Factory:/Contrib:/RaspberryPi3/images/

...same error, HDMI out of range.

So graphics stop working for you as soon as Linux switches to the accelerated "vc" drm driver. Since we have a working efifb fallback driver, you can just blacklist vc and still get usable enough graphics. I'm not sure how you can do that from the kernel command line, but I'm sure you'll figure it out :).

suse_rasputin
11-Nov-2016, 14:18
...or not. ;-)

I will stick to Stefan Brüns aarch64 TW till it's fixed in the future.

dsoothill
13-Nov-2016, 20:08
So I have a slightly strange widescreen Dell monitor which displays nothing on first boot and then eventually gives me an out of range message.

The way I overcame this to get at least the boot screen up is to edit the config.txt on another machine and to add an entry "hdmi_safe=1"

Taken from this page http://elinux.org/RPiconfig

"hdmi_safe Use "safe mode" settings to try to boot with maximum hdmi compatibility. This is the same as the combination of: hdmi_force_hotplug=1, hdmi_ignore_edid=0xa5000080, config_hdmi_boost=4, hdmi_group=2, hdmi_mode=4, disable_overscan=0, overscan_left=24, overscan_right=24, overscan_top=24, overscan_bottom=24"

This allows me to get the system configured so that I can then run it headless and get it on the network.

suse_rasputin
24-Nov-2016, 13:19
...same "HDMI out of range" with LEAP 42.2 for rapsi 3 from here:

http://download.opensuse.org/ports/aarch64/distribution/leap/42.2/appliances/

suse_rasputin
24-Nov-2016, 14:28
I added "hdmi_safe=1" to config.txt on the efi partition of the LEAP image after copying over to the SD-card. Same result, "HDMI out of range"...

Wrong config.ttxt? :-/

asimmons153
02-Dec-2016, 19:19
I experienced this issue upon my initial setup. I found a partial workaround of using a nearby TV as a monitor, this allowed me to get past the initial configuration so that it could have it run headless.

If anyone is experiencing this I would try any spare Monitors/TVs you have in the vicinity and see if you can get a picture using a different display.