PDA

View Full Version : Neutron Proposal Failed



ahmedhassaneankhalil
13-Nov-2016, 11:45
Dears,

i am trying to apply neutron proposal on Controller Node with Openvsiwtch and Gre but it's failed with below message


Failed to apply the proposal to: d44-a8-42-2b-0e-6d.barqsystems.local
Most recent logged lines from the Chef run:
STDOUT:
STDERR:
---- End output of neutron --os-username 'neutron' --os-password 'QvGMNJT4ePGC' --os-tenant-name 'service' --os-auth-url 'http://d44-a8-42-2b-0e-6d.barqsystems.local:5000/v3/' --os-region-name 'RegionOne' --os-user-domain-name Default --os-project-domain-name Default --endpoint-type internalURL net-list &>/dev/null ----
Ran neutron --os-username 'neutron' --os-password 'QvGMNJT4ePGC' --os-tenant-name 'service' --os-auth-url 'http://d44-a8-42-2b-0e-6d.barqsystems.local:5000/v3/' --os-region-name 'RegionOne' --os-user-domain-name Default --os-project-domain-name Default --endpoint-type internalURL net-list &>/dev/null returned 1

Resource Declaration:
---------------------
# In /var/chef/cache/cookbooks/neutron/recipes/post_install_conf.rb

162: execute "Neutron network configuration" do
163: command "#{neutron_cmd} net-list &>/dev/null"
164: retries 5
165: retry_delay 10
166: action :nothing
167: notifies :run, "execute[create_fixed_network]", :delayed
168: notifies :run, "execute[create_floating_network]", :delayed
169: notifies :run, "execute[create_fixed_subnet]", :delayed
170: notifies :run, "execute[create_floating_subnet]", :delayed
171: notifies :run, "execute[create_router]", :delayed
172: notifies :run, "execute[set_router_gateway]", :delayed
173: notifies :run, "execute[add_fixed_network_to_router]", :delayed
174: end
175:

Compiled Resource:
------------------
# Declared in /var/chef/cache/cookbooks/neutron/recipes/post_install_conf.rb:162:in `from_file'

execute("Neutron network configuration") do
action [:nothing]
retries 0
retry_delay 10
command "neutron --os-username 'neutron' --os-password 'QvGMNJT4ePGC' --os-tenant-name 'service' --os-auth-url 'http://d44-a8-42-2b-0e-6d.barqsystems.local:5000/v3/' --os-region-name 'RegionOne' --os-user-domain-name Default --os-project-domain-name Default --endpoint-type internalURL net-list &>/dev/null"
backup 5
returns 0
cookbook_name "neutron"
recipe_name "post_install_conf"
end

[2016-11-13T12:25:23+02:00] ERROR: Running exception handlers
[2016-11-13T12:25:23+02:00] FATAL: Saving node information to /var/chef/cache/failed-run-data.json
[2016-11-13T12:25:23+02:00] ERROR: Exception handlers complete
[2016-11-13T12:25:23+02:00] FATAL: Stacktrace dumped to /var/chef/cache/chef-stacktrace.out
[2016-11-13T12:25:23+02:00] FATAL: Mixlib::ShellOut::ShellCommandFailed: execute[Neutron network configuration] (neutron::post_install_conf line 162) had an error: Mixlib::ShellOut::ShellCommandFailed: Expected process to exit with [0], but received '1'
---- Begin output of neutron --os-username 'neutron' --os-password 'QvGMNJT4ePGC' --os-tenant-name 'service' --os-auth-url 'http://d44-a8-42-2b-0e-6d.barqsystems.local:5000/v3/' --os-region-name 'RegionOne' --os-user-domain-name Default --os-project-domain-name Default --endpoint-type internalURL net-list &>/dev/null ----
STDOUT:
STDERR:
---- End output of neutron --os-username 'neutron' --os-password 'QvGMNJT4ePGC' --os-tenant-name 'service' --os-auth-url 'http://d44-a8-42-2b-0e-6d.barqsystems.local:5000/v3/' --os-region-name 'RegionOne' --os-user-domain-name Default --os-project-domain-name Default --endpoint-type internalURL net-list &>/dev/null ----
Ran neutron --os-username 'neutron' --os-password 'QvGMNJT4ePGC' --os-tenant-name 'service' --os-auth-url 'http://d44-a8-42-2b-0e-6d.barqsystems.local:5000/v3/' --os-region-name 'RegionOne' --os-user-domain-name Default --os-project-domain-name Default --endpoint-type internalURL net-list &>/dev/null returned 1

eblock
14-Nov-2016, 09:16
Hi,

have you tried to execute the command manually? Maybe that output tells you more what exactly went wrong.
But obviously neutron can't list the networks, are there any at all? Maybe the net-create command already had failed and this is just a consequence?
If there are networks but you can't list them, maybe your network.json is not correct.

ahmedhassaneankhalil
14-Nov-2016, 10:16
i have checked the logs but this is only error that i had found So how could i checked which command is failed

and below is my network.json:

{
"attributes": {
"network": {
"conduit_map": [
{
"conduit_list": {
"intf0": {
"if_list": [
"1g1",
"1g2"
]
},
"intf1": {
"if_list": [
"1g1",
"1g2"
]
},
"intf2": {
"if_list": [
"1g1",
"1g2"
]
}
},
"pattern": "team/.*/.*"
},
{
"conduit_list": {
"intf0": {
"if_list": [
"?1g1"
]
},
"intf1": {
"if_list": [
"?1g2"
]
},
"intf2": {
"if_list": [
"?1g1"
]
}
},
"pattern": "dual/.*/.*"
},
{
"conduit_list": {
"intf0": {
"if_list": [
"?1g1"
]
},
"intf1": {
"if_list": [
"?1g1"
]
},
"intf2": {
"if_list": [
"?1g1"
]
}
},
"pattern": "single/.*/.*"
},
{
"conduit_list": {
"intf0": {
"if_list": [
"?1g1"
]
},
"intf1": {
"if_list": [
"1g1"
]
},
"intf2": {
"if_list": [
"1g1"
]
}
},
"pattern": ".*/.*/.*"
},
{
"conduit_list": {
"intf0": {
"if_list": [
"1g1"
]
},
"intf1": {
"if_list": [
"?1g1"
]
},
"intf2": {
"if_list": [
"?1g1"
]
}
},
"pattern": "mode/1g_adpt_count/role"
}
],
"enable_rx_offloading": false,
"enable_tx_offloading": false,
"interface_map": [
{
"bus_order": [
"0000:00/0000:00:01",
"0000:00/0000:00:03"
],
"pattern": "PowerEdge R610"
},
{
"bus_order": [
"0000:00/0000:00:01.1/0000:01:00.0",
"0000:00/0000:00:01.1/0000.01:00.1",
"0000:00/0000:00:01.0/0000:02:00.0",
"0000:00/0000:00:01.0/0000:02:00.1"
],
"pattern": "PowerEdge R620"
},
{
"bus_order": [
"0000:00/0000:00:01",
"0000:00/0000:00:03"
],
"pattern": "PowerEdge R710"
},
{
"bus_order": [
"0000:00/0000:00:04",
"0000:00/0000:00:02"
],
"pattern": "PowerEdge C6145"
},
{
"bus_order": [
"0000:00/0000:00:1c",
"0000:00/0000:00:07",
"0000:00/0000:00:09",
"0000:00/0000:00:01"
],
"pattern": "PowerEdge C2100"
},
{
"bus_order": [
"0000:00/0000:00:01",
"0000:00/0000:00:03",
"0000:00/0000:00:07"
],
"pattern": "C6100"
},
{
"bus_order": [
"0000:00/0000:00:01",
"0000:00/0000:00:02"
],
"pattern": "product"
}
],
"mode": "single",
"networks": {
"admin": {
"add_bridge": false,
"broadcast": "192.168.7.255",
"conduit": "intf0",
"mtu": 1500,
"netmask": "255.255.255.0",
"ranges": {
"admin": {
"end": "192.168.7.11",
"start": "192.168.7.10"
},
"dhcp": {
"end": "192.168.7.80",
"start": "192.168.7.21"
},
"host": {
"end": "192.168.7.160",
"start": "192.168.7.81"
},
"switch": {
"end": "192.168.7.250",
"start": "192.168.7.241"
}
},
"router": "192.168.7.4",
"router_pref": 10,
"subnet": "192.168.7.0",
"use_vlan": false,
"vlan": 100
},
"bmc": {
"add_bridge": false,
"broadcast": "192.168.7.255",
"conduit": "bmc",
"netmask": "255.255.255.0",
"ranges": {
"host": {
"end": "192.168.7.240",
"start": "192.168.7.162"
}
},
"subnet": "192.168.7.0",
"use_vlan": false,
"vlan": 7
},
"bmc_vlan": {
"add_bridge": false,
"broadcast": "192.168.7.255",
"conduit": "intf2",
"netmask": "255.255.255.0",
"ranges": {
"host": {
"end": "192.168.7.161",
"start": "192.168.7.161"
}
},
"subnet": "192.168.7.0",
"use_vlan": false,
"vlan": 7
},
"nova_fixed": {
"add_bridge": false,
"add_ovs_bridge": false,
"bridge_name": "br-fixed",
"broadcast": "192.168.123.255",
"conduit": "intf1",
"netmask": "255.255.255.0",
"ranges": {
"dhcp": {
"end": "192.168.123.254",
"start": "192.168.123.1"
}
},
"router": "192.168.123.1",
"router_pref": 20,
"subnet": "192.168.123.0",
"use_vlan": true,
"vlan": 8
},
"nova_floating": {
"add_bridge": false,
"add_ovs_bridge": false,
"bridge_name": "br-public",
"broadcast": "192.168.9.255",
"conduit": "intf1",
"netmask": "255.255.255.0",
"ranges": {
"host": {
"end": "192.168.9.254",
"start": "192.168.9.129"
}
},
"subnet": "192.168.9.0",
"use_vlan": true,
"vlan": 9
},
"os_sdn": {
"add_bridge": false,
"broadcast": "192.168.130.255",
"conduit": "intf1",
"mtu": 1500,
"netmask": "255.255.255.0",
"ranges": {
"host": {
"end": "192.168.130.254",
"start": "192.168.130.10"
}
},
"subnet": "192.168.130.0",
"use_vlan": true,
"vlan": 10
},
"public": {
"add_bridge": false,
"broadcast": "192.168.9.255",
"conduit": "intf1",
"netmask": "255.255.255.0",
"ranges": {
"host": {
"end": "192.168.9.127",
"start": "192.168.9.5"
}
},
"router": "192.168.9.4",
"router_pref": 5,
"subnet": "192.168.9.0",
"use_vlan": true,
"vlan": 9
},
"storage": {
"add_bridge": false,
"broadcast": "192.168.125.255",
"conduit": "intf1",
"mtu": 1500,
"netmask": "255.255.255.0",
"ranges": {
"host": {
"end": "192.168.125.239",
"start": "192.168.125.10"
}
},
"subnet": "192.168.125.0",
"use_vlan": true,
"vlan": 11
}
},
"start_up_delay": 30,
"teaming": {
"mode": 1
}
}
}
}



Hi,

have you tried to execute the command manually? Maybe that output tells you more what exactly went wrong.
But obviously neutron can't list the networks, are there any at all? Maybe the net-create command already had failed and this is just a consequence?
If there are networks but you can't list them, maybe your network.json is not correct.

eblock
14-Nov-2016, 12:30
The command that fails is

neutron --os-username 'neutron' --os-password 'QvGMNJT4ePGC' --os-tenant-name 'service' --os-auth-url 'http://d44-a8-42-2b-0e-6d.barqsystems.local:5000/v3/' --os-region-name 'RegionOne' --os-user-domain-name Default --os-project-domain-name Default --endpoint-type internalURL net-list
Could you run it manually and see what the output is?

Unfortunately, networking is not my strong suit, I didn't edit the network.json myself, a colleague did that for me. So I can't really help you with that, I just wanted to point it out as a possible cause for the proposal failure, maybe someone with more experience is able to figure out if that's a suitable configuration.

bmwiedemann
14-Nov-2016, 12:55
and below is my network.json:


"nova_floating": {
"add_bridge": false,
"add_ovs_bridge": false,
"bridge_name": "br-public",
"broadcast": "192.168.9.255",
"conduit": "intf1",
"netmask": "255.255.255.0",
"ranges": {
"host": {
"end": "192.168.9.254",
"start": "192.168.9.129"
}
},
"subnet": "192.168.9.0",
"use_vlan": true,
"vlan": 9
},



in the default settings, the nova_floating net has
"netmask": "255.255.255.128",
and "subnet" starting at .128
so that it is only the 2nd half of the public network, but you changed it to cover 100% of it, which could cause this trouble.


apart from that, it is not a good idea to use barqsystems.local domain, because .local is reserved for multicast dns service discovery and could conflict with yours - especially on nodes that have mdns configured in their /etc/nsswitch.conf
Instead you could use local.yourdomain.com or whatever.example

However, changing these values needs a reinstall of the cloud.