PDA

View Full Version : weather widget not working (libgweather) sled11sp4



ofvergara
02-Dec-2016, 20:17
hello people,
a few months ago, i noticed that my weather widget was not working anymore (that's the one that used to be located on the left side of the clock in the gnome 2.28 interface).
in the beginning i thought it was a connection issue that might resolve itself.
well, it didn't and then i started searching for answers (http://askubuntu.com/questions/817083/my-weather-widget-is-not-working).

in the webpage linked above, the author posted a "dirty" solution by modifying manually a new weather forecast URL in the ".c" file in the libgweather application. however, this applies to ubuntu.
how do i achieve this in my sled11sp4?

see below the image i took for the weather application found in my system:



204


in the sled11sp4 SDK dvd-iso i have, i see the libgweather-devel-2.28 file.
please guide me on what do to next in order to update this manually since i don't have support/patches anymore for my sled11sp4 (although i still own a valid 3-year subscription to receive updates for my distribution, its life (EOL) ended way before i anticipated).

thank you very much for your advice/guidance.
cheers.

malcolmlewis
02-Dec-2016, 21:13
Hi
Your in luck ;) I grabbed the src rpm (off DVD2), added the patch and rebuilt on the openSUSE Build Service;
https://build.opensuse.org/package/show/home:malcolmlewis:SLE_11_General/libgweather

Once built, go to http://download.opensuse.org/repositories/home:/malcolmlewis:/SLE_11_General/SLE_11_SP4/ and drill down to your arch for updated libgweather packages (lang file in the noach one) and then manually install.

ofvergara
02-Dec-2016, 22:11
Hi Malcolm,
thank you very much for helping out and providing the updated rpm's.
However, i ran into a little problem.

when i tried to uninstall the original 3 files (one at a time) using yast, each complained about removing 20-30 gnome-related dependencies.
so i dodged that and went to the good old terminal instead. however, i was unsuccessful as well with a very strange error.

if your versions are newer, why is the system complaining with this message?


205


what do you think?
is there a wrong reference to the numbering sequence in the rpm patch files?

thanks mate for your assistance. greatly appreciated it and waiting eagerly for your reply.
cheers.

malcolmlewis
02-Dec-2016, 22:26
Hi
Yes, OBS wouldn't set the version number, you need ti force the install to let them downgrade.

malcolmlewis
02-Dec-2016, 23:32
Hi
OK, sorted the version number, download the new rpms they are set to 2.28.0-1.4.9 now.

ofvergara
02-Dec-2016, 23:37
Malcolm, you are the man!!
i forced the installation in the terminal, restarted the laptop (just in case) and there it is!!

thanks a lot!! greatly appreciated.


206


the next topic (or class) would be, how to do it with another package in the future by myself instead of pestering you ... ;)
cheers!

ofvergara
02-Dec-2016, 23:52
downloaded the new rpm's with version 4.9
updated them in the terminal --> outcome: All good --> end result: Fantastic !!

thanks a lot, Malcolm!!
where's that star you are talking about in your signature? ;)

malcolmlewis
03-Dec-2016, 02:37
Hi
You know if you have an active subscription you can update to the next release?

Since you have an active subscription, you do have access to updated rpms and the src rpms so can either grab stuff there, or download the DVD2 (8+GB) which has all the src rpms and build packages from there.

Else, just ask here and will se what we can do ;)

malcolmlewis
03-Dec-2016, 02:43
downloaded the new rpm's with version 4.9
updated them in the terminal --> outcome: All good --> end result: Fantastic !!

thanks a lot, Malcolm!!
where's that star you are talking about in your signature? ;)

Hi
At the bottom of the post... just to the right of Blog this Post?